Setting: when to remove mail from server

In the setup of my email account (pop3, not imap) I am asked when I want to delete mail from the mail server. I checked the box “never”, but mail is being removed from the server every time I open the inbox on FP2. Very annoying, since I have another phone from my employer, and I like to keep mail on a desktop pc. This way I can’t download it anymore.
Anyone with a solution?

That sounds odd. Which e-mail client (app) do you use?
Om my FP1 I use K-9 as my e-mail client, handling two IMAP and one POP account. I distinctly remember setting the “leave mail on server” option when setting up the POP account (even if I can’t find it now, maybe it shows up only when creating a new account) and it definitely works as it should.

I use the default mail app that is supplied with FP2, can’t find anywhere what it’s called.

Not totally sure about this (I’m using IMAP on the phone), but I think the “delete (not) on server” setting only deletes (or not) mails from the server that you delete in the mail client?
IMO the “leave mail on server” should do the trick (like @kgha suggested).

Just verified on my laptop with Thunderbird and a POP3 account. There are two settings:
-> “Leave mail on server”: I have untagged this, so mails are deleted from server when I have downloaded to the laptop.
-> “Delete from server when they are deleted from inbox”: can only be checked when above setting is checked; so this should lead to the behaviour that deletion on the client leads to deletion on server.