Setting menus crashing in FP1+Cyanogenmod

I have a series of problems at hand with my FP1. I would be very grateful if anyone out there could help me out with any of them!

Firstly, the Systems settings menu and now even Manage apps -menu don’t open. When I try, they just flash quickly on the screen without allowing any time to even read them. This problem started smaller last winter and then disappeared, but now it has come back and is getting worse and causing other problems. First it was just the system settings menu. But now it concerns also manage apps. I can’t even make a downloaded new app work because the phone doesn’t let me allow them any superuser rights from the
-The first time this happened I could reboot my phone. But the problem now is that I don’t want to loose all my stuff, so I want to do backup first. However: - the phone doesn’t detect the SD-card that is inside. -I have Cyanogenmod instead of Google, so backing up using cable+Google Plus is not an option.

  • I downloaded MyBackupPro for this, but the phone doesn’t allow me to grant
    it superuser rights so I can’t use it. So is there any other way to backup my phone?

  • Now another problem that costs me actual money (I hope that my operator will compensate it later) is that some bug is sending non-existent SMS to some Finnish numbers and to one number abroad. In reality there are no SMS sent but on the bill it shows as if I had sent for example 2-4 text messages at the same time. Avast! Mobile security virus scanner didn’t find anything. I aimed to remove some of the apps I had lately installed, in case that some of them had brought a bug along, just to notice that I can’t even access the apps menu anymore in order to do so.

Fortunately I could create a bugreport, which I will try to copy-paste here asap. I sent it to FP zendesk, just to be told that because I use Cyanogenmod, they can’t help me and I should ask for support here at the forums…

So it would be great if someone that can interpret the report/ othwerwise has a clue what this could be about, would tell me their advise in terms of where to maybe start solving this bunch of problems!

Should be the last time when person like me who doesn’t understand much about software gets an alternative phone and an even more alternative operating system for it…and then finds herself in a mess like this with no idea how to get out…

Hey @Aino! First of all: Welcome to the forum! :slight_smile: You might want to introduce yourself here.
Secondly: Please tidy up your post. The bullet points did not work out right, so your post is quite hard to read.

Maybe @Madde can help you out with your problem because he has some experience with Cyanogen Mod (also is active on the xda-forum). I’d also advice you to post your question at the corresponding xda-developers-thread here:

PS.: I’ll also take this out of the Bug Reports category since Cyanogen Mod is not officially supported by Fairphone.

Thankyou for advice, I’ll post there and hope to finally find the right people to help me out!

1 Like

Please post back here, if you find a solution to your problem! :slight_smile:

1 Like

Hi @Aino, i applaud your courage to try Cyanogenmod on the Fairphone. However, i would recommend to switch back to Fairphone OS for the time being. This may sound not really helpful, but here is my reasoning: The Cyanogenmod Developer providing CM for the Fairphone is doing this on his own, the release is more of a “developer preview” with a lot of stuff not working. It is not meant for “non-developers” that are not (yet) tech-savy enough and even more so, for a device you rely on daily. I strongly encourage you to switch back to FP OS.

Now, with that out of the way, you write that the problem occured briefly last summer. The CM for the Fairphone was released in September, so am i right to assume this happened with the Fairphone OS installed as well?

About the Backup, which will be required for switching back to FP OS as well, maybe you could use ADB (Android Debug Bridge, A program that lets use access android system function from a connected pc via usb)? I have not done this before, but here is a guide describing such procedure:

Out of interest, what data would you like to backup? SMS? Contacts? Pictures? Everything?

1 Like

Hmmm… If I remember right, i installed Cyanogenmod very soon after getting my FP1, which means in the first months of this year… I tried Google for a second, just to find out that to use it would make me install my apps etc. all trough signing in to Google first :confused: An idea which I don like at all! If I now go back to the default (which would probably be the easiest&securest way, I believe you), I very warmly welcome all hints as to how to use Google only as a necessary evil and at the same time avoid it as much as possible in my everyday mobile phone activities …!

I couldn’t install ADB (nor Helium as someone recommended somewhere), because the phone settings didn’t open so that I could have allowed any app superuser rights.
But fortunately I could upload all my photos to Dropbox and eventually managed to download and use a simple app for SMS-backups -> Dropbox. All the rest doesn’t matter so much, the apps I’ll need I can download again.

You can use FairPhoneOS without using Google services. I am using FairPhoneOS without installing Google Apps, I removed the widget installator. I am using and I am happy!


Hi Sim6, thankyou for your note and recommendation! I had seemingly mixed things up in my mind as it’s a while when I got rid of Google Apps by installing Cyanogenmod instead (if I remember right, it was difficult to get rid of once-installed Google otherwise). But now I did hard reset and can start afresh - with nice surprises that I don’t remember to have existed back then, like the whole system in my own mother-tongue Finnish :slight_smile: I hope I’ll manage to download f-droid tomorrow when I get a wifi-connection.

1 Like

is your problem fully solved by the hard reset?

1 Like

It seems now that it is. Thankyou for advice, everyone!