Separate ringtone and message volumes

Hi,
I want to hear ringtones for calls but only vibrating for messages etc.
(Because i dont like to miss calls, and vibrating is a nice deal between nothing and beeping)
On samsung devices you have since years different volume bars for that and i thought it would be a general android feature.
( its something you cant do on iOS at all)

Does someone know a workaround? I can mute some Apps inapp, but for example not FB messenger.

update: set Default message sound to no sound works for messenger, but it seems,that some apps are ignoring that. ill observe what.

4 Likes

Sadly that’s not an AOSP feature, so it’s probably not going to end up in FPOS :roll_eyes:
I’ve had it in LineageOS for years as well, but it isn’t implemented in the LOS based Calyx either.
Could someone running /e/ or iode report about the situation there please :pray:

I’d be really interested which apps don’t respect this setting, did you maybe overwrite the default notification sound for that app? :thinking: Is it a timer or alarm clock app? Those use different defaults.

I have the default notification sound set no “None” as well and so far only had problems with Signal because I had set custom notification settings for some conversations, otherwise everything’s nice and quiet :relieved:

1 Like

These are the possible sound settings in /e/:

So I’d say you can have different volumes for phone calls and message notifications (if understood the request correctly).

1 Like

Hi,
Thanks for the information, that’s interesting.

Yesterday I had sounds from Google Calendar reminders and the Facebook app (not messenger).
On FB i found an Option to mute, but not on Calendar. Maybe it counts as Alarm, but it worked on Samsung phones so it shouldn’t be.

i didn’t changed anything in FB and i have the FP4 since 4 days. I only changed the sound settings in Telegram, WhatsApp and FB Messenger, to mute them. (which works)

I hope every other App uses the default sound/no sound … otherwise it will be annoying.

(Fun fact: if you try to mute this messengers on iOS, they also don’t vibrate anymore. I thought about getting an iPhone and this was one of the reasons against getting one xD.)

Hi Volker,

Yes you did.

Wow there is written “Ring and notification volume” and extra “Notification volume”.
Really confusing :smiley: but as long it works… :slight_smile:

Edit: Ahh there is a button at the bottom to unlink/link nice!

1 Like

Yes, that’s how it’s supposed to look, with the toggle to link them underneath :+1:
So it’s at least implemented in /e/-OS.

Aaah, did you change the notification sounds in each app separately and didn’t change the global notification sound to “None”? :thinking:

1 Like

Yes, seen you slide it to “on” then notification sound setting is “greyed out”:

1 Like

The global setting is “None”.

On WhatsApp, i did both: there is a check for Notification Sounds on/off, and it was also already set to “default(none)” So i will try to set Sounds on again.
Telegram just took the default(none).
And for the FB messenger I can’t choose own sounds, it just gives me a set of it’s own sounds.
I just turned off the App sounds inApp.
(so also typing sounds etc. but media stuff still has sound)

So some Apps do their own stuff and others respect my global options.
And if they let me change something is also random.

1 Like

Final (?) feedback:
seems that no app gives message sounds, so far so good, except google Calendar.
I found, that the Calendar sound does count as Ring/notification sound, but doesn’t care about my opinion. :man_shrugging:

I would say, it is okay like it is, but sometimes I will face an annoying beep.
As long, i’m not hiding from an angry dog or something like that… xD

2 Likes

You might still try out a different/better calendar… :wink: