English

SDcard slot broken?

Tags: #<Tag:0x00007f05d9d04f90>

Hello there.

I’ve noticed a lot of folks having trouble with the FP2 and SDcards. I have a problem which I think is unique, or at least not reported here yet as far as I can tell. Im runnng the latest Fairphone Open 19.11.2 Android 7.1.2

I have a SanDisk Extreme 64GB XC card, gold and red trim. I’ve been using it in my FP2 to hold media like MP3s, Images, Videos etc. Recently, I managed to fill it and that was fine. I started listening to my music and VLC began to complain. Things were missing and it started to fail.

I got a message that the card was corrupted and needed to be formatted. I started this process and it failed at about 25%. I took the card out and placed it in my PC - seems to read fine.

I decided I’d format it myself on Linux. I tried vfat and ext4. I put the card back into the slot and it wasn’t recognised at all. No messages, no options. It’s as if my phone doesn’t have an sdcard slot at all.

I tried a second card of the same type. This didn’t work. I tried a smaller card. No dice. I tried rebooting, shutting down and even putting the phone in the fridge for a while. Finally, I tried the power+volume-up boot menu and attempted to ‘upgrade from sdcard’. The program informed me it couldn’t mount /sdcard.

I’m wondering if I’ve damaged the slot somehow? Can’t see any obvious damage. I could understand the card being at fault but not several cards that work in other machines. I’d at least expect the ‘please format your sdcard’ message.

Any thoughts FP2 folks? Cheers!

Ben

The slot may be damaged, or it could just be dirty. Have you tried cleaning it with isopropyl alcohol (on a sliver of kitchen paper maybe)? You can also use some contact spray (the kind that leaves no residue), being cautious not to overspray.

On a side note, I’d advise some caution with putting phones in fridges. The interior of refrigerators is often rather damp, and the damp gets into the phone and when you take it out it can condense in the phone’s interior, potentially causing short circuits. Not a massive risk, mind you, but something to keep in mind.

2 Likes

Hello there,
Thanks for the reply. Unfortunately a little clean hasn’t worked at all.

I suspect something else might be the issue as the system wasn’t happy with the card just before it failed. Possibly it’s a solder joint that has broken or potentially a software issue. Not sure how best I can diagnose this. I’m guessing the SD Card slot is on the mainboard, so replacing that would be expensive.

Not really sure where to progress here. I might start taking the phone apart.

Ok so this has gotten weirder…

I don’t often make or receive calls (mostly text and whatsapp) but I received a call and after I hung up, the SD card appeared! I got the 'do you want to use the card internally or as an external drive" dialog and that was that.

But then it disappeared again! What?!

I tried cleaning with isopropyl but that didn’t appear to do anything.

I made a call later on in the day and the sdcard came back! But it didn’t last very long and disappeared again.

I suspect this is a software fault somewhere but an odd thing is going on. Any ideas? I thought maybe something was loose, and it was merely the act of me holding the phone in a certain way but that’s the only idea I’ve come up with.

Cheers

Ben

Have you tried without a SIM card? They can cause odd problems sometimes.

1 Like

According to your assumption the SD card slot is directly soldered onto the core module as Ifixit shows it here.

You could try if it mounts when being in safe mode to exclude any third party software interference.

1 Like

Thanks for the suggestion. I gave it a go but no luck there unfortunately.

Thanks for the suggestion. I tried safe-mode as described here:

Sadly, it still doesn’t mount. I tried taking the card out and putting it back in whilst in safe mode. Still no luck.

Have you tried to insert the card and fully boot the device while the back cover is off. Then gently put some pressure on it and the slot part?

This could reveal if there is a broken solder joint.

Hi there.
Yes, I tried that. No dice unfortunately.

I’ve also gone with a full factory reset and that hasn’t worked either. It does feel like a proper hardware fault at this point but there’s one more thing to try - a full reinstall from scratch.

B

Ok so both the Fairphone Open and Fairphone OS as fresh installs don’t solve the problem.

I guess we can now say this is a hardware thing somewhere? Odd that occasionally, just occasionally, the card comes back.

Hopefully I can get this fixed. It’s some-what crucial for me. T.T

B

The card occasionally working supports the idea that it’s a hardware thing: a broken solder joint will make contact sometimes. Maybe try (carefully) pressing on the card connector to see if that makes it come back - that’ll be definite evidence of the nature of the problem.

If it is just a broken solder joint and if you can find someone who’s good at soldering surface mount components, this may not be too hard to fix.

Interestingly, after a full fresh install, I received another phone call, and the SD card has appeared again! I’ve set it up as external storage and then left it for a good 20 minutes

Logging back into the phone (waking it up I guess), and the sd-card has gone.

This is very weird indeed!

:thinking: Very, very strange. I have no idea what on earth could take influence on your SD card while using your phone modem…but since you are up to trying everything to fix it…how about disassembling the phone completely (only module wise) e.g. following Ifixit and by the way clean some contacts before remounting it all again??
If that does not help I would assume it to be a fault on the core module.

Hello there,
Thanks for the reply. I took the phone apart and checked the contacts. The SD card slot seemed slightly loose but I think it’s within tolerances. I looked at the solder contacts to the main board and they seem pretty robust. So I put the phone back together. Unfortunately the SD card remains undetected.

I’m wondering if there are some other diagnostic tools I can use? I can’t see anything obviously wrong with the hardware though now I’m more confident with taking it apart I might have a closer look.

1 Like

Maybe you mean the SD card felt slightly loose due to it being held with feather contacts. But the socket itself (empty without card) should feel fixed when still being properly soldered to the PCB.

After having tried out all of this without success I’m also out of any further advice.
If it’s not a broken pin of the slot it looks like a hardware problem on the core module.

1 Like