SD card problems although formatted as portable storage

Hi, and marry Christmas,

Sundisk extreme 128 GB.
Use it for extension memory
Formatted on my old phone and again on the FP4.


first I think you should not format on the FP4 again.

Second at the moment it seems there are explicitly issues with SanDisk SD cards some Samsung Evo seem to work properly

the FP4 that told me to format the card because “the card is corrupt” . this is happen The first time I put the card in it.
The card was formatted on the old phone, so when I put inside in the FP4 is like brand new

Update: I can confirm the

256GB Samsung EVO Plus SD Card
microSDXC UHS-I Class(10) U3 4KUltra HD

is working without any I/O problems.

In the meantime I have updated my Fairphone4 with the newest release and retried the Sandisk Extreme 128GB SDXC V30 U3 A2. Still same I/O errors - still unusable. The Sandisk SD card works in other PCs without any problems!

BR, Toni

1 Like

Hi, I can confirm the results of @astx and @bluefire . I also tried a Samsung EVO Plus 256GB U3 A2 V30 and it works so far with my FP4. Without formatting I use it as mobile/external memory, and the apps (OsmAnd+, Deezer, native Camera/Foto App) have no issues, large amounts of data can be stored and read without problems, So on one hand I’m happy that I finally have a working combo (and no defect SD Card slot) but on the other hand its a bit unsatisfying to know that there is a major bug either in FP4 or in Android 11 accessing SD Cards from certain manufacturers.

I cant get the SanDisk SD to work with my FP4. I formatted it in another smartphone (Samsung Galaxy S5) crosschecked with Windows 10 PC and had some tests but it seems that there are heavy issues especially with reading files and recognizing the SD Card by the FP4 because all ever written files to this card can be seen on Win10 PC.

1 Like

After some time of testing, I have to admit that my SanDisk (Extreme microSDXC UHS-I A2, 128 GB) fell back to its previous bad habits, including the I/O errors. In fact, it is more probable that the error persisted all the time and I just didn’t recognize it with my use pattern. As reported elsewhere (Fp4 and SD card - #5 by F.Sowa), my BugReport folder is also full of those 0 byte txt files indicating some sort of storage error and larger files won’t copy (anymore). So formatting the SD card in another phone as suggested by @Chris_R may not be the ultimate solution, I’m afraid. I’ll chance my luck with a Samsung card now. Has anybody contacted support yet? If not, I can take care of that.

1 Like

Please contact support so they hear this is a common if not default issue
Thanks for the update.

1 Like

Done. I’ll keep you updated.


I am using a ‘microSDXC-Karte Evo Plus 512 GB’ and I initially decided to use it as internal storage and that worked fine with some exceptions (storage information in the android settings were weird as it showed the card having 499 GB of 1 TB used at all times no matter what. The phones total storage was displayed correctly, but as used…) Then I decided to switch it to mobile storage and now after formatting I get the permanent notification that the sd card is not supported… What the hell.
I’m interested in your support reply.

1 Like

This could also be some hiccup from the previous internal format. Have you tried formatting it externally using another phone or computer before configuring it as external storage?

1 Like

I also have issues using SD cards with two Fairphone 4’s. I have tried

SanDisk Ultra 128 GB microSDHC Memory Card + SD Adapter with A1 App Performance Up to 120 MB/s, Class 10, U1 (Twin Pack). After seeing the initial prompts from Android about slow performance, I tried

SanDisk Extreme Pro 128GB microSDXC Memory Card 170MB/s Class 10, UHS-I, U3, V30

However, this seems to have made things worse, with 1 phone seeing the card is missing/corrupt and the other reporting errors using the cards. I have only just found these forum posts and the “recommendations” not to use SD Cards as internal storage, so I’d already done that. However, I’m somewhat bemused how Fairphone can sell a phone with an option which is so clearly inadvisable and not include something in the packaging as a warning if they’re not going to remove the option in the OS.

There seems to be mixed reports on Samsung cards working. Are there any confirmed reports of success with the Samsung Evo plus 128GB Micro SD SDXC Class 10 memory card U3 100MB/S (MB-MC128HA APC)? FYI I have raised case 485888 with Fairphone support. However, if I can fix it with a known working card rather than waiting for 5 days I would love to do that!

Thanks for your help.

1 Like

I haven’t followed this thread. But for what it’s worth, I have a Kingston Canvas Select Plus microSD Card 10 UHS-I - 512GB. I use it as portable storage (movies, music, offline music/Google Maps, etc.).

In the beginning I couldn’t format this SD card on my phone. It failed at around 20% in the format process. After I formatted the SD card on my computer to exFAT I was able to successfully format it on my phone and it works without issues now.


Nah I have spent the whole day now reformatting and reformatting this damn SD card and it won’t accept it. What a joke. No wonder why other manufacturers don’t use SD card slots anymore, because those things are a pain in the ass.

I have done the same like you. What do you use as allocation size for exFAT formatting? For me it won’t work no matter what I do and it fails on 20% on the phone.

I used the full size. I used GNOME Disks to format it. No special options enabled. I also don’t know if GPT is used or not. Will check in the near future. Because I prefer GPT.

I’m using a SanDisk Extreme 128 GB set up as external storage and it works like a charm.
Lucky me, I guess.


Update. The Samsung Select SD card has arrived.

H2Testw shows similar read speeds to the Sandisk Extreme (76 vs 77) and slightly slower write speeds (58 vs 67). Despite this, the FP4 is no longer complaining about slow performance, reinforcing the belief that this is a software issue. The card was immediately recognised and I was prompted to complete “setup”. I selected use as external this time and was again prompted to format (despite exFAT formatting at the factory). I did this and was invited to move applications to the drive…which was a little strange…When I declined I was told the card was ready to use.

When checking the card in storage settings it immediately shows 130GB of storage is consumed.

This is strange for a couple of reasons:

  1. I definitely selected portable storage rather than internal. The Android system files appear to have been automatically moved, yet this took no time.
  2. The system files when stored in on board storage, was much less than 130GB.

However, no further errors about the SD card and apps are performing as expected (with none running from the SD card). Again, this reinforces the belief that there is a known bug affecting specific card manufacturers which is not being advertised by FP. Still no response from FP Support.

Your screenshot shows a 256GB SDCard inserted but the above Photo shows a 128GB sdcard? Also it looks like the SD card shown as 256GB size is not formatted as external storage. IMHO your phone still thinks it has a previously installed 256GB card as internal storage attached…
I wouldn’t trust the storage settings. Your data may get corrupted!

Update: I can confirm the

256GB Samsung EVO Plus SD Card
microSDXC UHS-I Class(10) U3 4KUltra HD

is still working without any I/O problems.

BR, Toni

Yes it looks like internal storage Oops!
I have similar issues on FP3 using internal.
It doubles the size of the card and then takes 50% plus a bit away.

This is a test with a 16GB card

But it works fine as externsl with no capacity errors

1 Like