SD card problems although formatted as portable storage

For future user, could you name which Sandisc SD you exactly tried? I think on the long run we might open a wiki listing compatible SD cards for the FP4 as well, so your experience might help. I think we have seen issues with some SanDisc Versions while others worked well.

For the issue, just a few thoughts (hope I did not overlook in your summary, hat you already tried):

  • which file explorer do you use?
  • did you try another music player (is YT Music comparable player app?) It seems VLC is still one of the best

Edit: change log of Pulsar indicates there where compatibility issues with A11+A12, is your App up to date?

5 Likes

Thank you for your reply anf for reading, yes I can provide the info. I’m sorry that I forgot.

SD card: SanDisk microSDXC Card 128GB ExtremePro A2 (UHS-I)

File Explorer: The App called “Files” on the FP (and Android in general I think). Computer explorer is Windows 10, freshly reset (bc of other issues unrelated to the phone) and up to date.

YT Music has the same issue. I did try VLC too, bc I thought it can open so many different file types, maybe it helps. However, the issue persists there. It worked insofar that it could open the M4A files iirc (it’s about a week or two ago so I’m not sure if I remember everything correctly), but still it didn’t show all my music, only about a third of it (unrelated to the media format - some of it that showed was MP3, some was M4A. After having tried to format the SD card as it was suggested here, I could try that player again.)

I installed and re-installed Pulsar several times already, so honestly I just thought it will install the most recent app version automatically.

There is a file Explorer called Total Commander. I never used it, but the people who use it, say its a quite good file manager App and has more options as others. You could give it a try (just note it seems the surface needs getting to used.

Overall, if I would be you, I think I would put some of my music to the Internal storage and wait to use an SD card, until further information is known and the teething troubles are sorted out.

1 Like

I think I’ve seen Total Commander at my workplace, but I never used it.
Anyway, I think I’m just going with the music I have on Spotify (internal memory) and see if there will be more information on this issue later.

1 Like

Update:
It seems to work fine with a Samsung EVO Plus SD Card (256 GB; microSDXC UHS-I).

1 Like

I can’t get my Samsung EVO Plus 128 GB to work with the FP4 either. The FP4 doesn’t manage to format the SD card as portable storage: It starts, briefly shows a progress bar at 20%, then immediately reports success, but not rightly so. Then a permanent notification appears saying “This device doesn’t support this Samsung SD card. Tap to set up in a supported format.”

I have also tried formatting the SD card (exFAT) using Windows and putting files on the card that way. But when I plugged it back into the FP4, it showed the same notification as above.

(Edited: I will #contactsupport to say: Please let me know if and how I can assist in resolving this issue.)

There is no FP team here on the forum. Please #contactsupport .

3 Likes

Have also massive problems with sdcards as portable storage. Tried different 128GB A2 V30 U3 sdcards from sandisk and transcend. None of them is working correctly in the FP4 sdcard slot. Note: all of them worked perfectly using FP3 or any Desktop PC.
Using e.g. termux to md5sum check a signal backup I get completely different results and afterwards I/O errors. A restart of the phone is needed to access the sdcard again.
Formatting sdcard sometimes work, sometimes not. I’m not 100% sure this is a hardware problem because there are similar android 11 sdcard problems reported.
My FP4 has latest android updates…
Has anyone had similar problems and found a 100% working sdcard model?

BR, Toni

Hi everyone…
I have a similar problem with my FP4 as reported by @Zr4 . My usecase is to use SD Card as external storage for apps like “Deezer”, “OsmAnd+”, the native camera app and also as native download folder. In addition I stored a bunch of extra photos to the SD Card using “MyPhone Explorer” App. First everything runs fine. Without errors Deezer stored offline content to SD card, photos are dumped without error and within the mentioned apps the paths to the storage was set up properly and app behaviour was normal. After downloading some maps, OsmAnd was the first app facing problems during download (mayby due to large file size) There was no consistent error message (i.e. cannot close file, …corrupt file… i/o error and so on). Sometimes after reboot or reinstall or both the problem was fixed and some maps could be displayed despite download error but sometimes not. Due to the “feature” of Android 11 ( restricted acces to filesystem i.e. …/android/data…) i had some handling problems with the app, therefore i first argued a problem with the app itself. But problem become worse and worse in an exponential manner and expanded to the other apps: deezer was not able to open offline content , dumped photos cannot be read anymore and the camera app was not able to store a photo. My SD Card is a SanDisk Extreme 512GB XC1 U3 A2 and I used it fresh out of the box without any additional treatment or formatting. I now run the hints described in this stream and give more infos later if the problem could be fixed…

Update: Have bought a new Samsung EVO Plus SD Card
microSDXC UHS-I Class(10) U3 4KUltra HD

  • formatting OK
  • data copy OK
  • no I/O errors during md5sum check of a big signal backup (~ 4GB)

Looks like there is a problem using SD cards from SanDisk and Transcend (128GB A2 V30 U3)
I will report an update in a few days, if this sd card is now stable.
Of course this is only a workaround - the incompatibilities to SanDisk and Transcend SD cards still needs to be fixed by google/fairphone!

BR, Toni

2 Likes

same problem here with a SD card. i formatted the card then put in the FP4, the FP4 said to me that the card is corrupted, so i proceed again with formatting the card in the FP4.
After couple of weeks it’s happen that the phone froze and reboot in a safety mode.
after a lot of switch on and off the phone started working but very slow, impossible to every app.
so today i decide to try to remove the sd card and the phone start to working perfectly…

Hi and welcome to the forum.

More detail may be useful
a) which card are you using ?
b) how did you initially format it ?
c) when you formatted it in the phone was it as a portable drive or an extension to the internal memory?

Hi, and marry Christmas,

Sundisk extreme 128 GB.
Use it for extension memory
Formatted on my old phone and again on the FP4.

Alex

first I think you should not format on the FP4 again.

Second at the moment it seems there are explicitly issues with SanDisk SD cards some Samsung Evo seem to work properly

the FP4 that told me to format the card because “the card is corrupt” . this is happen The first time I put the card in it.
The card was formatted on the old phone, so when I put inside in the FP4 is like brand new

Update: I can confirm the

256GB Samsung EVO Plus SD Card
microSDXC UHS-I Class(10) U3 4KUltra HD

is working without any I/O problems.

In the meantime I have updated my Fairphone4 with the newest release and retried the Sandisk Extreme 128GB SDXC V30 U3 A2. Still same I/O errors - still unusable. The Sandisk SD card works in other PCs without any problems!

BR, Toni

1 Like

Hi, I can confirm the results of @astx and @bluefire . I also tried a Samsung EVO Plus 256GB U3 A2 V30 and it works so far with my FP4. Without formatting I use it as mobile/external memory, and the apps (OsmAnd+, Deezer, native Camera/Foto App) have no issues, large amounts of data can be stored and read without problems, So on one hand I’m happy that I finally have a working combo (and no defect SD Card slot) but on the other hand its a bit unsatisfying to know that there is a major bug either in FP4 or in Android 11 accessing SD Cards from certain manufacturers.

I cant get the SanDisk SD to work with my FP4. I formatted it in another smartphone (Samsung Galaxy S5) crosschecked with Windows 10 PC and had some tests but it seems that there are heavy issues especially with reading files and recognizing the SD Card by the FP4 because all ever written files to this card can be seen on Win10 PC.

1 Like

After some time of testing, I have to admit that my SanDisk (Extreme microSDXC UHS-I A2, 128 GB) fell back to its previous bad habits, including the I/O errors. In fact, it is more probable that the error persisted all the time and I just didn’t recognize it with my use pattern. As reported elsewhere (Fp4 and SD card - #5 by F.Sowa), my BugReport folder is also full of those 0 byte txt files indicating some sort of storage error and larger files won’t copy (anymore). So formatting the SD card in another phone as suggested by @Chris_R may not be the ultimate solution, I’m afraid. I’ll chance my luck with a Samsung card now. Has anybody contacted support yet? If not, I can take care of that.

1 Like

Please contact support so they hear this is a common if not default issue
Thanks for the update.

1 Like

Done. I’ll keep you updated.

4 Likes