SD Card no writing permission in FP2

You mean like this? Doesn’t work either

Hmm, guess you should first copy it somewhere where you can write as non privileged user, I.e. /storage/sdcard0/ and then go back with adb shell, become root and then you can copy out to the final destination. A bit uncomfortable, but should work this way. Don’t forget to remount /system to after that…

remount you mean

adb shell
mount -o rw,remount /system

That didn’t work for me. I don’t have access to my SD card anymore at all.

I moved the file to the correct location with Amaze
Then I did the code above but it didn’t change anything. After rebooting my phone I don’t have any access to any external storage anymore

No, I meant remount, ro for getting it write protected again, which does not matter, as one has to reboot anyway.
My SD card sometimes doesn’t show up after a reboot. Solution is to shut down and boot again… Don’t know why

I managed to flash the original FP OS

Early in this thread “fp1_wo_sw_updates” wrote:

If that doesn’t help you try the workaround for the privacy impact.

After FP2OS Update 1.2.8 on my FP2 there exist a new thread especially with Writing SD Card on OTG USB (e.g. includes usb otg mounting)

My intention on various longer excerpts of my exercises especially after rooting my device after upgrading deals with writing on SD card but only for beeing asked before. This follows exactly the policy of android 5.1 (google) . While before upgrading nothing could help (me) to show the menu dialog for this policy with original amaze file explorer ( - FP2 ticket did not solve and other file explorer had no chance to write - ) then the upgrade works with my FP2 as it did before with many other people. However after upgrade the mounting disappeared due to FP new default entry in the PC-USB connection menue. (can be switched back with a PC-USB connect)

Finally I am using a re-rooted FP2 but without modified permissions.xml file (adb patch). Now I am asked by the SU-root app (F-Droid) every time before write access is requested. And now I am using Ghost-Commander (file explorer) while original amaze-app fails to write most of the time.

After 1.2.8 upgrade, and re-root, I did modify permissions.xml and had to reboot for this modification to apply.

Regarding Ghost-Commander, if your path want closer to the ‘/’ than ‘/data’, it will continuously prompt you for root access (and I wont report the problem through their sourceforge). But if you use the menu to get back to the home-page and then directly go to “external storage”, you won’t be prompted for root access anymore (providing you modified your permissions.xml and rebooted).

I knew that I could avoid beeing asked. However I already stated that I now rather like to be asked :slight_smile:

I have same problem, both for saving apps and even having the option to store photos on the SD card (is it because it’s a 64gb micro SD?).
I downloaded the suggested app but it reached the red warning screen saying it needed root access and I dont begin to understand how to figure out how to deal with the root…

Please, how does one get this this root thing you speak of?

Have a look at this:

An easier way to get root is to install FP OSOS which is currently being tested:

Well, it is easier to activate root and of course the OSOS - with a more open source approach and no google apps installed - is a great OS, and I really can recommend it!

But only for getting root its a bit far fetched, as it includes to also flash the user partition, so you’ll have to set up the phone again.

1 Like

Thanks for that link. I followed and downloaded the boot.Fairphone-fp2-su-eng-r203.img file, but when I clicked it nothing happens.
Then I checked the wiki post again and I think in section 2b it explained you need to connect to a computer and download more stuff and flash the image and so on.
At this point I am lost. First off my computer can’t even see my fp2 - only have one basic cable but it worked OK for other androids. And second, I have zero programing experience, am a basic computer user, so is there a simpler way to upload this file?
Chrs. Magnus

Well, if you take some minutes, some people wrote a step by step tutorial there (in the wiki). From the discussions I know that also others managed who had no experience, so it’s not too hard, just requires some patience.

That said, there is also an alternative ( to use an app, but it is not recommended as some claim it may drain battery and it’s less secure.

If you are not familiar with computer stuff you should also be aware that rooting the phone has severe security implications and with root rights you can easily screw up the software of your phone.

you can do that without going through the root thing – it worked for me, at least. i found a short clip on youtube (there are more, but this one was easy enough to follow), in which a step-by-step explainer guides you through the setup of acces your sd card with ‘ES File Explorer’ . once you managed to go through the steps, moving files between internal storage and sd card is as easy as it was with FP1 and the older android (where we had root access).
hope that helps : )

I bought a SD card yesterday and my Fairphone 2 (I love it!) accepted and found it without
any problems. I want to store all of my picutes and Videos on this card. Does
anybody know how I can change the storage location from internal to the SD
card? I can not find the button.
Thank you and have a nice and sunny weekend, Lea

1 Like

How do you want to store the pictures and videos on the SD card? With an USB connection to the computer? With an app (which app)?

I also have the same problem. To save space on the internal drive, I would like photos and videos I take with the FP2 to automatically be stored on the sd card. I have been able to do this with all the other androïd phones I had.

1 Like