SD card: no writing or deleting possible

Hi,

Today I wanted to change the mp3’s on my 64GB SD card. But somehow, it suddenly doesn’t work anymore. It’s been weeks since I changed anything on that card, I’m not sure WHAT happend to cause it.

I tried first with Android File Transfer (on my Mac), but that kept crashing (it did that before), I tried mounting it as USB then, which didn’t help. It performs the deleting and copying, but when I check it after unmounting it, the changes are lost. I tried with the default file manager, with ES file manager and FX file manager, all the same result: sometimes it performs a deletion, but when I check it with another filemanager or on my laptop, the files and folders are the same.
I also tried formatting it again, first from within the settings, but also with mac Disk Utility. Even that doesn’t work. I frequently restarted my phone during all the attempts, even removing the battery and the microSD card.
Somehow, nothing works.
I googled what and found a kitkat problem with sd cards, and a solutions, but therefor you need Kitkat 4.4.4, we have 4.2.2 I think?

Some useful hints?

Oh yeah, one of the apps I recently installed, was Xprivacy. To do that, I first had to install something called Xposed. I deleted those, but that didn’t help.

Maybe that caused the problem?

I also tried everything written here (the first thing, the second doesn’t work voor 4.2.2 and the last thing I also didn’t try): Fixing external SD card write issue.

Sorry, no idea yet.
I am afraid the KitKat tips won’t help you much. Google changed some internals with Android in 4.4 which to not affect us on 4.2.2.

When you format the card with your laptop, do you use a card-reader or your Fairphone?

EDIT: although all file managers first seemed to show the deleted files as indeed GONE, now I check again and they’re BACK. SO didn’t work after all…

I don’t have a card reader, I used the Fairphone.
The trouble seems gone: after I did trick number 3 from the link above (Method 3: Using Xposed framework with HandleExternalStorage module) and THEN REMOVED the line in “platform.xml” from trick number one (permission: group gid=”media_rw” /). Suddenly I could delete files again.
Not sure WHAT exactly was the solution, because I tried so many different things…
If it was Method 3 that helped, maybe the Xposed app caused the trouble in the first place, because reïnstalling it and fiddling with it resolved it (maybe).

So: the problem still exist.

  • Tried formatting the card in another Android phone, that didn’t work.
  • Tried formatting in an old Windows PC, but it wouldn’t mount. I had no internet-access so I couldn’t download extra card utilities.

Is it possible the SDcard is broken?

1 Like

I’ve got some SD cards here, that stopped accepting changes. If I understand the tech correctly, the SD cards can only change the content only a limited number of times (per cell). If you’re using a cheap card, it might happen sooner than you’d expect. After it reached its end of life, you’ll experience the issues you’ve described.

1 Like

Thanks for your reply HackAR. Since I only put data on the card twice, that would be incredible fast. I wrote to the manufacturer. This is their advice:

Make sure your cardreader supports SDXC (older readers do not support this) and try the card with another cardreader or another PC and see what happens.
Else you can try our autoformat tool (Windows OS only) to test/reformat the card (This will delete all data from the card!) or run the windows chkdsk or the SD format tool to try to repair the card .
http://support.microsoft.com/kb/315265/en-us#method1
http://www.transcend-info.com/Support/Software-4/
https://www.sdcard.org/downloads/formatter_4
If that does not solve the problem, it might be the card is defect and I suggest to return to your dealer for a replacement as they are responsible for the warranty.

I have a mac, no windows. So I couldn’t try this yet (and most of my friends have OLDER computers, so with OLDER card readers.

I hope I get to a new PC before the warranty is over, I hope anyway that the software-solution works!