SD card issues since upgrade to Marshmallow on FP Open OS

Hey everyone,

I’m having problems with my external sdcard and can’t seem to get it solved:
Ever since I have my Fairphone, sdcards (no matter which) were oftentimes not mounted again after (random) reboots.

This got substantially better since I upgraded to FP Open 17.06 (MM).
However, now sdcards are not recognized anymore in the Android file manager, so I can’t select the sdcard as storage for my backups etc.
Also, when an sdcard is mounted as external, every time I click on it under storage & USB, the settings-App crashes.
I tried the HandleExternalStorage Xposed module, but that didn’t help either.

Am I not getting the logic right how MM handles sdcards or is there another problem?
Any help is greatly appreciated!

Many thanks

This did the trick:

While the above method fixed my immediate problem, my documentprovider still doesn’t display anything. Any idea why that would be?
It worked before in the past, but doesn’t since the MM update.

Thanks for any hints and help!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.