Screen turn on delay

The past few weeks I have noticed a delay when pressing the on/off button to turn on the screen. It seems to slowly become more and more serious, but I’m not sure about that. By now, I have to wait about 3 seconds after pressing before the screen turns on. However, this is after the phone fell asleep on its own or was asleep for a longer time after I turned off the screen manually. There is almost no delay when I turn the screen off manually and then immediately back on. Sounds like a sleep / battery saving feature, but I don’t use anything special on the phone. The standard battery saver feature is off. I use a relatively new slim back cover and FPOOS version from maybe 2 months ago with Xprivacy.

:slight_smile:

But on-topic:

Do you have adaptive brightness enabled? That can take a while to get the display readable in bright environments.

If not, here’s a device-independent advice I guess …

Hello… I found a quick fix… That solved my this issue…
–> power off
–>remove all type of card
–> insert cards
–> turn on…
Solved… Hope it helps…

1 Like

Adaptive brightness isn’t on and the screen is definitely off when it appears black. However, I recently have problems with my Samsung microSD card. Seems like it’s dying (way too early) of old age. So maybe these things are related. Will try the ‘taking out cards’ idea.

Taking the cards out and putting them back in didn’t help, but keeping the malfunctioning microSD card out for good fixed the issue. So I’ll have to replace it even sooner, then.

Does anybody have an idea how this could be the solution? Why would a faulty sd card be responsible for the screen not turning on fast?

I just know that the card’s really messed up. It is recognized in any of the possible ways it could be recognized. Normal, corrupted, unsupported… Every now and then it switches. After the screen turned on following a delay I sometimes saw what I think was the status message of the card disappearing (recently there’s an almost permanent status message either showing it’s broken in some way or, if it’s not, telling me there’s an SD card inside and allowing to eject it etc.).

well, technology is pretty weird! +___+

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.