Screen not turning on

I just started using my Fairphone 4 yesterday. Finished the migration and today the screen will not turn on.

What happens is this:
After I reboot the phone (using the Power+Volume Down combination to force a reboot) the screen is fine. Until the screen turns off once. Now I cannot turn the screen back on.

I know the phone is running, since it vibrates when I touch the fingerprint scanner, and I can connect to it over adb. Using scrcpy I can even see and control the screen. With that I also confirmed, that the screen brightness is all the way up. Only the screen doesn’t turn on at all.

This is, obviously, a mayor show stopper for me. Has anyone had this before? Does anyone know how to fix it?

Fairphone recommends to “take the display module off and put it back on again” here (“Other damages” section):

The link with instructions in the article above doesn’t work right now, but you might find this Fairphone video helpful:

I did that (detached and reattached the display), but it didn’t have any effect… The problem still persists

Have a look here when you used a Google back up of a previous phone with Display always on


Nice, that fixed it! Thanks, that’s amazing!

I was already suspecting the always on display to be part of the problem, since it would show that screen, even though it didn’t before (I first tested the phone without importing the Google Backup).

Thanks a lot!


I have the same problem. But I am sorry I don’t understand the answers. It is a software or hardware thing that must be done ? Can someone explain slowly please ? :wink:

The easiest way will be to install the APP linked here and disable Ambient Display.

Would you be so kind as to explain more “slowly” what has to be done ? I don’t understand what I shall do ! Thanks !

Download the App linked from playstore and if you then dont see the ambient display Funktion in this app, please come back here, I’m sorry but else I cant exolain this more slowly or detailed. Without having the App it might be difficult to understand what is meant.

Hi. I have just received my brand new FP4. When the screen locks and turns dark, It remains dark when I unlock it ! I hear the “unlock” sound when I put my finger on the fingerprint sensor. But the screen remains dark ! I have to reboot the phone to see something again. And each time it is locked, the same problem happens. What shall I do ? Thanks.

Welcome to the Fairphone community.

Did you possibly copy your Google account with all setting from your old phone? And did it have an always on display?
That was discussed her already.

I’ll search for the thread, wait a second.

Here it is:

Thanks a lot. But sorry I don’t understand what ir means “to disable doze_always_on”. What shall I do exactly ? Thanks !

To not duplicate efforts I moved your post here

I have erased everything (nothing imported from my previous phone) and restored factory settings, it still does not work. After being locked, the screen does not light on again.
I refuse to do any hardware thing. I assume it must be sent back. So disappointing.

So you did not recover a Google Backup? During setup you are asked if you want to do this. How do you try to unlock the screen, by pressing the power button?

Hello. Yes I have restarted from scratch with no Google Backup and I still face the problem. Yes I try to unlock by pressing the side button, but it remains dark…

Just to be sure: You are actually pressing the button and not only touching it which might just trigger the feedback from the fingerprint reader depending on configuration?
What exactly is your process for restarting the phone when this problem happens? (long-press power button, remove battery, something else?)

1 Like

I have tried both to press the button and to touch it. The screen remains fully dark. It seems that the phone is alive as it vibrates but it remains dark. If I maintain the button pressed, the phone switches off. Then I can switch it on. It works. But when the screen lock after some inactivity period, this happens again : it cannot be revived.

I would say it is broken and you have to open a RMA

Did you really make a full wipe and reconfigure the phone from scratch? Maybe the ‘doze_always_on’ setting is persistent, once configured.

Are you able to connect the phone to a computer by USB and someone talks you through the ADB commands?