Screen Mirroring doesn't work on FP2

Hello there!
I can’t connect my FP2 to my Sony BRAVIA TV. It always stops when my TV says “Preparing ‘Screen Mirroring’. Please wait…” and the TV LED flashes in some kind of cyan. Does anyone have similar problems?

Hi Clemens,

what kind of connection does your TV use (WiFi, Bluetooth, USB Cable…)?

Kind regards

Maybe this tutorial helps:

I use WiFi and unfortunately it doesn’t help. I even tried much more than this guy did in his video, but it always stops at the step shown at 4:00 :frowning:

Hi there,

screen mirroring (screen casting) doesn’t work for me either here. Though, it’s a Samsung UE55H6470 SmartTV.
I’m running the latest Fairphone Open build (FP2-userdebug 5.1 FP2 fp2-sibon-16.06.0).

The screen mirroring works fine with a Nexus (not exactly sure which one it was) and Sony Experia Z1 Compact (running the pre-installed Android 5.1 as well).


Before my FP2 I had a Z1Compact as well. That’s why I thought it does only connect from Sony to Sony…

Works fine for me with the FP2 (FP OS 1.5.1) and both an LG TV and a Windows 10 PC. (Windows 10 can act as a Miracast reveiver(!) since the recent 1607 update).
So it should work, but maybe there are compatibility issues with certain devices?

I can confirm what Stanzi explained. I have the most recent Version of the Fairphone Open OS 16.07.1 and the issue ist still there. I tried 3 different Miracast receivers with always the same result, that it tries to connect but then fails(Samsung H7080 TV, Miracast Stick, AirServer on Windows 8.1).
Other Android devices where able to connect easily.

The Fairphone 2 Mirroring Feature seems fairly Buggy to me.

PS: I had the exact same issue also the last 2 OS versions ago, so it’s still the same as it’s always been.

1 Like

Maybe it’s an issue with Fairphone Open OS? Stanzi, are you running regular FP OS or FP Open?


Hello there

After installing FP Open OS this stopped working for me as well. I have tried 2 different miracast receivers and both fail. They both worked on FP OS.

The two miracast devices is:

ASUS Miracast Dongle
A 2015 panasonic TV (sorry can’t remember the exact model)

I’m using FP Open os 16.08. and the problem is still there.

1 Like

I recently installed FP Open OS 16.09, and still I can’t connect via Miracast. For test purposes I went back to the regular FPOS, and there everything worked fine. Is this problem officially recognized as a bug?


So can we consider it confirmed that Miracast doesn’t work at all in Open OS? Or does anyone have it working? Did anybody report this to Fairphone support?

I’m still on FPOS (with GMS) where Miracast works fine with all the devices I’ve tried so far. I’m thinking about switching to Open OS, but loosing Miracast would definitely be a showstopper.

1 Like

I tested with 16.09 and now with 16.11 Fairphone Open and A Fire-TV Stick. It starts “connecting” but then The Mirror Mode on the Fire TV Stick will exit and the connection is shown as lost on the FP2. . So I suspect also it is broken in Fairphone Open.

1 Like

When will they fix it? :’(

1 Like

Unfortunately I can confirm, it is not working for me either.

1 Like

Doesn’t work on my Windows 10 pc either. I’m running Fairphone OS 1.11.1

I think we can consider it confirmed that while Miracast does not work at all with the Open OS it generally works fine with the regular FPOS.

Since you are running regular Fairphone OS your issue seems unrelated. I just re-checked with FPOS 1.12.0 and a Windows 10 PC and it works just fine. So this might be an issue with your PC.

1 Like

Miracast doesn’t work with Windows 10, but with my Samsung TV.

FPOS 1.12.0,
Fully patched Windows 10 (1607)

The connection starts but fails some seconds later without showing the FPs screen content.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.