Screen brightness keeps changing

When I use the phone the screen brightness changes very often (sometimes every 5-10 seconds or so) even if the ambient light is the same (I’m at home and I’m not moving around) and the phone light sensor is always pointing to my face.

It’s quite annoying…

It seems as if there is some crazy battery saver that diminishes the brightness. Unfortunately it’s happening also now that I’m typing and the battery is at 74%, while the battery saver is configured to intervene at 15%.

Did anybody experience the same issue?

Any workaround?

Regards,
Max

1 Like

No I haven’t experienced this issue. The battery saver can be set to individual apps. For example my install of Firefox has the section > Manage battery usage, so it is possible that some app you are using, browser etc has some settings you could look at.

Another idea would be to dismantle the phone and clean the contacts.

It does it with all apps not only one.

I’ll clean the contacts, if it doesn’t solve the problem at least it won’t hurt.

Thanks.

Regards,
Max

Hey, I noticed the same when I just got my Fairphone. For me this setting did it: under “Display” I turned “Adaptive brightness” off. Does that help?

2 Likes

@Josien Just to say
a) Adaptive brightness should not do that and
b) I have adaptive brightness on with no such issues

Thanks @amoun, that’s good to know. Then I’m having the same issue as @mpolito1969.

1 Like

I like adaptive brightness, I don’t want to give it up.

All is in the “should”.

That you don’t have zny doesn’t mean much, only that it seems to be a problem with their devices but there could be a software bug as well. Well, thinking about it that means there would be bug anyway…

Bugs related to brightness changing randomly are often linked somehow to adaptive brightness.

Perhaps your proximity sensors are badly calibrated? I don’t know how to recalibrate them on FP3 though.
Or perhaps they are dirty? Try carefully cleaning the display.

I am experiencing the same issue, I installed a third party app which visualize the values the system is getting from the light-sensor. (for those who don’t know, the system is using this data to determine how bright it has to set the screen when adaptive brightness is on) As you can see, the value is jumping from [the real ambient light-value] to basically 0 and back over and over again. The graph in the screenshot shows a timespan of around 5 Minutes, it’s a massive mess. To me it really looks like a hardware failure but I am not educated enough to be sure.

I would appreciate if some of you could check if the same is happening to your values. No matter if you have the issue or not, so we can compare. I was using the app com.exatools.sensors but there are plenty of alternatives on the playstore for this purpose.

EDIT: Added the link to the app I was using.

2 Likes

I can’t find your app and I think using the same app would give more comparable results.

Can you put a link to the Play Store page?

Sure: https://play.google.com/store/apps/details?id=com.exatools.sensors

This is what I get after a couple of minutes of staring at the phone.

It was supposed to read every some seconds the sensor value and draw a point on the graph but apparently it doesn’t work like that.

The only way I found to have the app drawing something is putting the phone close to a light, then in the dark, then close to the light again… this way it draws spikes on the graph but if I keep the phone facing me with a constant light on the sensor it doesn’t draw anything.

1 Like

It seems in that regard the app blows. It only continues drawing if there is a bigger change in the received values, but sometimes it doesn’t for some reason. I found an app (Lux Light Meter Free) that works better for me.

I did different tests for an hour now and there is one certain issue I found that is definitely a software-bug. If you go into a brighter place, the screen-brightness goes up as it should. BUT if you go back in a darker place it doesn’t go down again, no matter what you do and how long you wait. Only one thing makes it go down again and that is when the value of the light-sensor hits 0 for a few seconds.

Could you check out if you have the same bug as I do?

Hi I’m using default OS A10 update 0084 I’m not using any app to measure the changes and adaptive brightness works as expected with the some two to three second delay.

I have now just checked via the dial pad *#*#66#*#* Service Tests > Test single > Ambient Light Sensor. It’s late and the only light is a 12V 3W LED lamp and the sensor gives values ~ from zero, when pointed away from the LED ~ to 600 when 0.5m away.

4 Likes

I managed to record the misbehavior in action. For reference, the brightness is set to 50% for the darkest spot. for the most part everything works as expected but look what happens if the sensor reports 0. The screen-brightness should drop to 50% but drops to 0% instead. As soon as the sensor reports 1 or more, it jumps back to 50%+.

Hi @Switch
What OS, version and launcher are you using my screen GUI is different.

I cannot set the brightness for the darkest spot and have adaptive brightness at the same time. So in your case if you have adaptive brightness enabled ~ if the sensor reads 0 then the screen brightness should also drop to 0.

I tried with the phone number posted by amoun and the sensor behavior seems to be OK.

Switch, I’ll do the test you asked for (software bug) and let you know.

Ciao,
Max

Hey, I am using LOS 18.1, but I tried many Roms and experienced the behavior on some of them as well. Maybe all have this issue but I didn’t verify.

The way you set the brightness for the darkest spot is: Make sure the sensor reports 0 and set the brightness as desired in the Display-settings (not in the quick-settings).

I am pretty sure this is not normal behavior, I had many Android phones in the past and it never was like this. It also wouldn’t make sense since almost every phone’s display becomes unreadable at the lowest brightness setting (including FP3). Turns out this is only true if Gapps is installed.

Just now I altered the brightness settings and this caused the issue to disappear. So I tried some things to make it come back and it turns out restarting the phone does it.

To reproduce the bug (the bug seems to be present only on phones without Gapps):

  1. Enable adaptive brightness
  2. Set the brightness very high (to make the issue more visible)
  3. Restart the phone
  4. Cover the light-sensor (above the screen) so the sensor reports 0
  5. Now you should see a massive drop in brightness (to 0%)

Well my FP3+ at the lowest level is readable indoors away from light in the day and fine when it is dark?

Sorry that makes no sense to me as when adaptive brightness takes over what ever you set is ignored. The only way to set the brightness is to disable the automatic option.