Saving media from Skype doesn't work

Hello, I have just gotten myself a FP4, after using a FP3 for a few years (that will pass on to a family member).
One thing I’ve noticed that seemed funny to me, and is different on the FP3 is when saving media from a skype chat. When trying to save a video or image, on my FP4 a (skype?)message appears: “unable to save picture/video”. On the FP3 it works, storing it in a Pictures\Skype folder.
No such thing on the FP4 thoug. I am suspecting there is a different way of dealing with permissions in Android11 perhaps? Anyone else having this? Would be great to find a solution.

Out of curiosity, are you using an SD card?

1 Like

Yes, as external storage, same as i used in my FP3, just took it and put it in the new phone.

1 Like

Are the files you are trying to save newly received ones or are they from an older conversation? :thinking:
Apparently Skype only stores shared files for a certain amount of time: How long are files and data available in Skype? | Skype Support

If that’s not the case, have you tried reinstalling Skype?

There are multiple users reporting similar problems on the Skype forum ([1],[2],[3]) dating back to 2020, but there hasn’t been any information on a fix.
If you can’t get this resolved yourself I suggest reporting it to Microsoft, this might well be a Skype and not a Fairphone problem.
But you should #contactsupport as well, so both sides are aware of the issue.

1 Like

Hi, thanks for answering, i tried on my FairPhone 3 as well, with newly received files. No problem there, so i assume it’s not a Skype thing as such.
I did unmount the SD card and restarted Skype to try to follow the hint @Amoun was giving in his reply. No luck there. I also reinstalled Skype, but also that doesn’t seem to help.
I’ll continue checking things. Will #contactsupport soon if no solution is found.
Thanks again!

2 Likes

Hi again, I’m still not able to use the save option in Skype to store media from chats on my phone.
I did find a workaround, however:
When sharing the media, after the list with apps to choose from appears, when i cancel (hit the back button), the media appears in the download folder…
Strange, but it kind of works.

1 Like

If Skype is able to save files to the filesystem, then the permissions are probably correct. This starts to sound more and more like a Skype for Android problem to be honest.

Have you heard anything from Microsoft support? :thinking:

Actually, i noticed today that a camera app i sometimes use (Open Camera) is not able to save pictures either.
“Cannot save image” is displayed when taking a picture.
At least there i was able to change the started setting by first enabling the option “Storage Access Framework”. Then I was able to choose a folder (I chose SD card) and it works.
Didn’t find such an option in Skype though…

:thinking:

Hi again, for some reason I “accidentally” hit the Save option instead of the share option I got used to as a workaround when I wanted to store an image, and it said image saved! Tried to save some video file as well, and it worked!
No idea why that happened though. No recent updates from Skype i know if, no firmware update either I think.
I wouldn’t be surprised if it turned out to be some other app install/uninstall/update even…

Anyway. Problem “solved”!

Cheers,

Michiel

2 Likes