Sailfish alpha5 and new camera issues

Thanks, @mal, for the new release.
I followed the excellent update instructions you provided coming from alpha4.
Updating worked flawlessly.


  • Youtube (or other) web videos don’t play at all in Jolla standard browser. It says: “No video with supported format and MIME type found”. Using “Web Pirate” from Jolla store does not help. The latter claims missing GStreamer plug-in. Before the update, video playback worked.
  • Neither the main nor the front camera works. (Test pattern appears.) I ran the detection instructions 12+ times, nothing ever changed. I have an oldish FP2, I suppose all hardware is first version with ‘low res’ camera modules.
  • Also flashlight does not work, but I suppose this is directly related to camera issue.

If I can provide some debug info, let me know. I’d be glad to help…

1 Like

That seems strange, can you check if minimediaservice process is running (ps aux | grep minimediaservice)? In any case some logs might be needed, please provide output of dmesg, journalctl -a and./usr/libexec/droid-hybris/system/bin/logcat. I also have only been using the old camera modules so that should not be the problem.

Ok. I noticed via “Settings”/“Apps”/“Camera” that for the main camera the correct resolution is shown, but not for the front camera. So I ran the detection cycle a couple of times more until the front camera setting showed up with the right resolution too. Taking picures/videos is not working though.

My guess is, that camera failure and video playback failure are more or less the same reason, like missing libraries or messed up dependencies after update process. I noticed that I have some custom codec packages from Warehouse installed. Perhaps the update procedure broke these? Hmm, so the “ssu lr | grep openrepos” command that is part of the update instructions did not disable them as required, just listing them? Arrgh. So, my bad.
Can I fix this by disabling the repos (or uninstalling all Warehouse stuff) and running the alpha4 to alpha5 update process again?

Anyway, if it helps, here are the logs:

Try running zypper ref (using devel-su) and then zypper dup and see if it tries to update anything. Interesting that you were able to get the correct resolutions even when camera doesn’t work.

zypper ref went through a list of repos. It said, most were up to date, but some “openrepos-” were retrieved.
zypper dup then updated some stuff that looked like codecs (“gstreamer1.0-plugins.bad…”, “libvo-aacenc…”, “OpenAL…”, “libvpx5…”, …)
But nothing changed, even after reboot.

Can you also show the /etc/dconf/db/vendor.d/jolla-camera-hw.txt you have?

Here it is:

That looks normal. Is there any difference between how different camera modes look like? Do all just show the test pattern?

One possibility is that there are some android 5 generated files somewhere causing issues. Try removing all other files and folders from /data except the folder .stowaways (which contains sailfish rootfs, DO NOT touch that).

Photo/video front/main are all the same testpattern. Video is always 16:9 and photo is 16:9 or 4:3 depending on the camera apps setting.
Recording the test pattern (taking a photo) does not work. Taking a video (of the test pattern) seems to work but fails at playback. After that, test pattern disappeared. Black. I closed camera app, then it refused to start again. After reboot, it works again with test pattern. When trying to playback a recorded test pattern again, the app hangs again. Recorded test patterns have a black preview which can only be seen directly after recoding when swiping to the left. Intent to play, kills the app. Video files are saved, but do not appear after that on left swipe in cam app. (Only the ones recorded the same ‘session’) I gallery app there’s nothing (I have no old/other media on the phone).

Ok, I wiped everything from /data except .stowaways and rebooted. Still no camera and no video playback. /data content was recreated now (in 1970 mostly :smiley:).

Very strange. Let’s continue debugging the issue tomorrow. It’s getting late.

True. What I’d like to try is uninstalling everything that is related to openrepos, as I think, if I have a plain install from scratch there should not be anything from an openrepos repo, should it? But I have no idea how to tell zypper to do that…

I have always had several openrepos active when doing updates without any issues, of course not all packages cause issues. Can you make a quick check which kernel you have using uname -a? Just in case the kernel update failed for some reason.

Linux Sailfish 3.4.0-perf-g96d3f9e #1 SMP PREEMPT Wed Feb 28 20:35:35 UTC 2018 armv7l armv7l armv7l GNU/Linux

That is the correct kernel so that’s not the problem. Needs more debugging tomorrow.

Ok, I got it. It’s hard to say, what I did exactly but something like this:

  • First I used Warehouse to uninstall some GStreamer-Plugin-* stuff. That resulted in jolla-camera being uninstalled. :open_mouth: So I went to ssh and reinstalled the packages: zypper install jolla-camera-lockscreen jolla-camera qt5-qtmultimedia-plugin-mediaservice-gstcamerabin. That brought camera app back, but did not make it work.

  • Then I used zypper to uninstall some gstreamer/codec stuff from repos openrepos-lpr and openrepos-lpr_A7. Among them was: libout123-0, libwebp6, gstreamer1.0-plugins-bad, libvpx5. Zypper did not just remove stuff in this process but also pulled in replacements for some packages. That resulted in YouTube working! :grin: Seeking does not work. (I am pretty sure, at first seeking worked until I fixed the camera, like below, but I may be wrong. It’s late.)

  • Then, I did pkcon install gstreamer1.0-droid. I don’t know, if I should/could use zypper instead, but anyway: Camera started working! :crazy_face: Both of them and flashlight.

Sorry for my hardly reproduceable chaotic “method”.

Ok, @mal, I tried something.

  • I did pkcon remove gstreamer1.0-droid just to see what happens. The result was a test pattern on the camera again, but really heavy seeking and jumping on YouTube WORKS!!! :man_dancing:
  • Doing pkcon install gstreamer1.0-droid brings back camera functionality but YouTube seeking fails again. (Though, only after restart of browser. If I keep the video in the tab, seeking still works at the same time camera works.)

Hope you can use this for investigation, @mal! I’m out! :sleeping:

1 Like

Ok, so the problem was a conflicting package from openrepos. Good to know, maybe this is a good note for other that if they have gstreamer packages installed from openrepos there might be issues.

Yes, and as I got a seeking capable YouTube playback, perhaps this is a hint for you, how to fix that issue for the release?

It gives some hint but not an actual solution, it tells that the issue is probably in the gstreamer1.0-droid package and not in the browser.