[ROM][UNOFFICIAL] Unofficial LineageOS 20 for Fairphone 3/Fairphone 3+

As always, my sincere thanks to your overwhelming response to [ROM][UNOFFICIAL] Unofficial LineageOS 19.0 for Fairphone 3/Fairphone 3+.

On this positive note, I present to you the first build of LineageOS 20 running Android 13 for Fairphone 3/ Fairphone 3+. It’s coming earlier than expected because Android 13 was simpler than Android 12.

If you would like to express your thanks to me by means of hard currency, please visit my Ko-Fi page: TeamB58 .

A summary on what’s working and what’s not:

  • Updated kernel to 4.9.337
  • Updated proprietary blobs from Android 11 MR4 release.


  • Boot
  • WiFi
  • Hotspot
  • Bluetooth
  • Camera
  • Radio(Network) - tested both SIM slots
  • Data - tested on single SIM
  • Encryption
  • Location/GPS
  • NFC
  • LOS 19.1 to 20 upgrade(without any data loss)
  • Fingerprint lock
  • Voice call/VOIP calls - Need confirmation.

Not working

  • Not a bug/issue but Fingerprint authentication will not work for 3rd party apps(like Banking apps).
  • You tell me!

Please test and report if you find any other strange issues.

Here’s the download link: AndroidFileHost link

Looking forward to all of your feedback and suggestions.



Thank you so much for all your efforts you put in LOS for the FP3 - much appreciated!

Do you think you will manage to get Fingerprint authentication working for 3rd party apps in LOS20? I assume that this is important for many users …

Possible but let’s just await an update from FPOS in order to proceed further on this.

1 Like

Hi TeamB58,
I switched due to the permission problems with Android 12 to the Android 13 port from “Spark OS” ([ROM][13][UNOFFICIAL] Spark OS 13.4 [FP3][AOSP][ANDROID 13] | XDA Forums ). There, the fingerprint works fine for banking app and the like.

So I hope you can compare their sources with your. And hopefully you can cooperate for common stuff - porting of AOSP to FP3.

Thanks for you work,

1 Like

Hi All,
Thank you for your continuous support. We are now nearing the Official release and hence please let me know if you encounter any critical issues so that I can address them before the release.

Regarding the Biometric authentication for apps, I shall re-enable this for now but a final call will be taken once we have an update from FPOS.



Do you know if the WLAN-behaviour in standby is now fixed? In the most recent release of 19 it still loses connection Ehen in standby, at least for me.


Thanks for that question! I also still have these WLAN disconnections

Could you elaborate on this? Why was it disabled?


Sorry but do we have an issue created for this in the Official Issuetracker? Please assign it to me and I shall start looking into it since this is the only one that’s unresolved from a long time.


Hello, thanks for the team for your involvement!
I have a couple of hours available in the coming days, and a spare FP3, so I’m willing to install and test. Is there a more recent build than in the OP?

I just tried with the build in the OP:

  • go to fastboot
  • fastboot flash boot "[filepath]\lineageos 19.1 (android 12)\lineage-19.1-20230220-recovery-FP3.img" (yes, i used LOS 19.1’s recovery, should I use another?)
  • got to sideload mode
  • adb sideload "[filepath]\lineageos 20 (android 13)\lineage-20.0-20230207-UNOFFICIAL-FP3.zip"
  • on the phone, allow unsigned yada yada

Then I get:

E: Current SPL: 2023-02-05 Target SPL: 2023-01-05 this is considered a downgrade
E: Denying OTA because it's a SPL downgrade

What do i do wrong?

FWIW, I could install it by booting temporarily to TWRP.
After a reboot to LOS’s recovery, I installed MindTheGapps

Hi @TeamB58,

Thanks for all your efforts - great work! I’ve tried out the current status including the “reverted biometrics security downgrade”, and all appears to work fine. I just want to share two observations:

  • After a dirty flash update from 19.1 to 20.0, Wallpaper and Style crashes. Manually toggling the Photos and videos permission off and then on again fixed the issue. I saw that you are already dealing with this at Drop default permissions (I7eefdf43) · Gerrit Code Review (lineageos.org), but it hasn’t been resolved yet.

  • If one considers to add AuroraServices v1.1.1 in an own build as prebuilt apk, LOCAL_CERTIFICATE := platform is required to make it work.



I am sorry, it took me this long, but currently, I hardly find time to do anything. I created a bug here:

However, I dont find a way to assign it to you. Can you pull it to you or point me to the correct button? (First time Git-user here…)

Thanks for this issue.

Yesterday, I actually spent 2 hours trying to reproduce this on my test lineage 20 build. I have tried both 2.4GHz and 5GHz network and could not reproduce it. I tried 5 times and device connected to the network on all 5 attempts.

Could it be specific to some routers? I’ll continue to reproduce from my side.

I have a FRITZ!Box 7490 and a FRITZ!Repeater 300. both with current firmwares 7.29.
At the moment, I don’t often use other WLAN, but I will try to test it, when I do

A post was merged into an existing topic: Official LineageOS 20 for FP3/FP3+