[ROM][UNOFFICIAL] Unofficial LineageOS 19.0 for Fairphone 3/Fairphone 3+

Thanks for the new build. Location and tethering works for me too. So nice to see the Monet theming working across the OS.
Still have a few small issues.
The phone will not complete update if I use Lawnchair as my launcher. It also acts weird after a reboot if Trebuchet is not set as default. This could be a Lawnchair issue, as it’s still in Alpha.
Images are not downloading for my with Telegram. Can anyone confirm this?

Mhh i’m now on 19, but i had to whipe my data.
Recovery told me that my data got corrupted.

For me its not that bad, cause i had a backup. Just wanted to point it out ^^

1 Like

Hm, I think we are talking past each other. Let me try to make it more clear what I was trying to say:
I am very happy with the camera access feature as it is. It reminds me of how webcams work on computers where there is a light right next to the camera that is on as long as the camera is used. However I thought that it might not be necessary to reserve space in the notification bar for the camera access notification by making the feature even more computer-like: I thought of a feature where instead of a dot in the top right corner of the screen the notification LED would turn on if the camera is accessed.

also NFC doesn’t seem to work on my Phone.
At least Yubico Authenticator tells me (after installing ykDroid) ‘This device doesn’t seem to Support NFC’

think i found the error… had problems with flashing the lastest build yesterday, so i took the link from the staring post… so yeah… i’m still on the version 20220228. I tried to update it to the latest build via adb sideload. recoverey tells my everthing went smooth, but after the reboot i’m somehow still on the old version. at booting no error is displayed :thinking:

1 Like

That’s strange… I tried multiple times and it works!!

Works fine here.

1 Like

yeah, pls look at my replies in the thread ^^
i accidanltly installed your first build from 19.0. it seems that your current build suffers the same ‘problem’ like in Official LineageOS 18.1 for Fairphone 3/Fairphone 3+ - #408 by TeamB58 . I unlooked the bootloader again, and now it did install without problems ^^v

I’ve been using this ROM for a couples days and want to say thank you to @TeamB58 for bringing Android 12 to the FP3
Location was not working at first but the new build fixed the issue
The only thing that is not working now is the Rakutten Viki app, I get a black screen when playing a video. I guess this is because this ROM has no DRM. Does someone know a way to install DRM on Android ?

1 Like

Good catch.

DRM is indeed disabled currently. I mean, the proprietary widevine blobs are not included. I am just waiting for official Android 11 release because it might be tricky to use Android 10 DRM/widevine blobs for Android 12.

Now that the boot issue is resolved in LineageOS 18.1, I have ported to 19.1 as well. I’ll share the next build when the May SPL has been merged. Could be probably by next Monday then.

Thanks for all your support.


Enabled here: https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP3/+/331360

Should be available in the first release.


Hi All,

Official LineageOS 19 is getting delayed because of the fingerprint issue:

  • Setup fingerprint → Lock screen → Unlock using fingerprint and it works
  • Restart phone → Unlock using fingerprint and device does not get unlocked.

What to do now?

  • Release Lineage 19 with this issue
  • Address this issue first and then release Lineage 19

0 voters

Addressing this issue might take longer time because neither @dk1978 nor I could get to the root cause of this issue.

Choice is yours now.

I’m not sure i understand this correctly. Isn’t it normal that you first have to unlock with your pin and only afterwards finger print works? Or doesn’t it work at all after reboot?

That’s right. But it isn’t working even after an initial unlock.

There seems to be some issue with either firmware file or the library.

1 Like

The fingerprint sensor has never work reliably for me even on stock firmware so I don’t care

1 Like

Hey! Is it the same, when doing an upgrade installation, where the fingerprints are already registered (no clean installation)? For me, fingerprint sensor works quite good, but I can live without it for a few months.

Problem is, if it becomes official, many users would probably see this as a basic feature and be frustrated.

1 Like

The FP sensor is not a mandatory part for the phone to work, but it’s also used to make the use of a password vault such as Bitwarden, or of a 2FA keys manager such as Aegis, much more convenient.
So, why not releasing it, but with a huge red-letters warning.
Hopefully the bug gets solved soon.

1 Like

Hi All,

I am very happy to inform you all that the fingerprint issue is now resolved. Special thanks to @Quallenauge for pointing out the issue.

So, we might go official as soon as it’s merged in frameworks.



Hopefully the last update for the Unofficial topic.

  • The frameworks change for fingerprint issue is now merged.
  • I am now waiting for:
    • June SPL to be merged
    • Updated tag for April/May for the kernel security.
    • @dk1978 to retrun back from vacation.

Thank you for all you patience and sorry for the delay.



For those who don’t know, lineage 19 is officially available for FP3 LineageOS Downloads
I can confirm that DRM is enabled


Official topic here: