[ROM][UNOFFICIAL] LineageOS-GSI 17.1 for FP3

Already installed it, thanks. At the same time I also updated the German Corona Warn App. Now CWA won’t work anymore. No idea whether it comes from the OTA or from the CWA… :frowning:

1 Like

@juri.gagarin.ii: You are right - something appears to be wrong with the MicroG signature spoofing. I’ll check it. For the time being, I have revoked the recent build…

1 Like

Oh OK. Is there a way to revert to the version before without loosing data?

1 Like

@juri.gagarin.ii: I found the glitch and fixed it - a new build is on the way and will hopefully be available later today … but note it’s Friday 13th - so it may become Monday latest. Download and install the new OTA as usual; I expect it to keep your data as usual including your MicroG EN collected IDs (which continued to be collected BTW).


Although it is Friday the 13th I was brave and downloaded it. Now microG and Corona Warn App are working again.
Thanks so much!


I did the Update the minute after Friday 13th :wink:
It works almost perfectly. A2DP is still the only think didn’t run.
Is it foreseeable at some point when this will be fixed?

1 Like

Wrt A2DP, I currently wait for Fairphone to come up with a bug-fix update of their firmware. Considering the various reports regarding similar problems with the stock A10 and the /e/ beta & taking into account that all works fine on basis of a pimped A9 firmware, I’m confident that it’s not the GSI which is failing here…

Hi fwg-cag,
i had installed the image lineage-17.1-20200929-UNOFFICIAL-treble_arm64_bvN.img on 4.10. on the FP3
At first everything was fine, only LTE did not work, but 3G did.
After the update from 2020-10-07 everything was good, too.
But since the update from 2020-10-13 I have always had a problem with my phone:
Sporadically it restarts, even when it is on the table.
Often it doesn’t stop at a restart, often it’s 5 - 6 - 7 shortly after each other.
Do you have an explanation for this?

I have to mention: I only replaced the main camera with the new 48MB, the Selfiecamera is the old one. Is there possibly a connection?


this looks pretty promising. Sady the sourceforge mirror is pretty unstable and almost unusable me for (100 kb/s and always canceling) because it is located in NA. I have now unsuccessfully tried to download the rom for 3 days. Would you be so kind and provide another mirror, maybe mega.nz?

Hi there,
I’m about to buy a fairphone 3+ and plan installing lineageos 17.1. Is VoLTE and Wifi Calling supported? I know my carrier supports it, so I’m curious.
Thanks to all,

Hello there
first of all let me thank you for the amazing job you have done. I switched from iOS to LOS 17.1 since a month and besides some well known problems that Android 10 has on the FP3 (see bluetooth issues and fingerprint sensor that works just for a bit than stops to recognize your finger) and some problem in not being able to run specific apps without Google (see Flipboard) I’m pretty happy with it. I’d actually like to offer you a beer or two if there is a way to donate.

Now I wanted to make a very stupid question: Last month I’ve installed the 20201113.img . I was wondering if I can perform the update that came out yesterday simply from the updater as you mention here.

If not it mean I have to reinstall LOS again but instead of loading the .img I have to sideload it from TWRP. then what? I’m a bit confused if I read your instructions on sourceforge.
It will not be a problem to lose my data so far but as @frank-bxl mentions, is a bit of a hustle especially with the banks app.

Thanks for the effort !!

Last time I had a feedback this rom wasn’t compatible with the fp3+, so that would be your first problem, even before worrying about volte

The official LineageOS 17.1 is now compatible with FP3+ and the new camera modules for FP3.


Now we have to find out whether it is possible to switch to official without loss of data. Is anybody brave enough to try? :grinning:

1 Like

@juri.gagarin.ii I tried to migrate to the official LineageOS 17.1 image, using the steps described here: https://wiki.lineageos.org/devices/FP3/install

And then leaving out the step:

  1. Now tap Factory Reset, then Format data / factory reset and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage, as well as format your cache partition (if you have one).

It wasn’t able to boot after installation for me. After the second failed boot attempt, the LineageOS recovery prompted me to factory reset, after which it was able to boot normally, but of course then the data was gone.

I did have my previous installation encrypted, so that may very well make a difference (although I’ve just as well had it in the past that I got prompted for the unlock pattern and it worked).

1 Like

@phg @in-go
You may have already heard that there is now an official LineageOS 17.1 Nightly image. I used to have the same Bluetooth issue as you with the image in this thread and just installed the official image, which fixed it for me. I did not need to install a new FairPhone firmware for that either. I just followed these steps: https://wiki.lineageos.org/devices/FP3/install

1 Like

I’m watching both threads daily.
The minute the microG version is available I’ll switch to official LOS17.1 .


Thank you very much @Ereza for your feedback, i’ll install very soon the official LineageOS :slightly_smiling_face:
I often use Bluetooth, so i had to reinstall official Fairphone OS to use it…
Happy new year !

1 Like

Dear all,

Thank you for confidence in my GSI solution, however, as the official LOS17.1 and LOS17.1 for microG are now available this GSI effort becomes obsolete as I have no plans to go further e.g. to a LOS18.1 GSI. Thank you so much @dk1978 for porting LOS17.1 to the FP3 and thus enabling the FP3 to become a valuable solution for privacy concerned people who care about our environment but need a secure and reliable smartphone. I personally don’t know any better alternative currently.

How to get from the GSI into one of these official streams?
Unfortunately, a “dirty” install without wiping the userdata appears not to be possible. I have tried that without success by compiling an unofficial image using the same keys as in my GSI builds, hoping to be able to provide you a smooth migration path via OTA - but all trials led to a wipe data request. So, our only option is to backup the userdata on the GSI and restore it after installing LOS17.1.

Backup/restore migration using adb root - oem lock compatible
Before installing LOS17.1, please, backup your userdata using either TWRP backup or the Linux bash script backup-userdata. After installing LOS17.1 following this guide, you may restore your userdata via TWRP (fastboot boot twrp-xxx-FP3.img!) or -in case you decided to fastboot oem lock your bootloader- with the Linux bash script restore-userdata. The later only requires adb root access, which you may temporarily grant in the Developer Options of LOS17.1 even on the oem locked phone. By using these bash scripts, your data in /data/media, your user installed apps and your settings shall be transferred via your local computer -even apps, which signed themselves out from adb backup-, only your accounts are skipped and have to be newly signed in.


Hello all,

@fwg-cag, the integration of F-Droid and Aurora services is a great feature of your GSI for me, despite the Bluetooth problem I also experience.
Are they also present in the official distributions?

I’m totally new in advanced tweaks with TWRP, Magisk etc, I managed to try your GSI and the /e/ system because following the instructions worked, but I still have to learn to go deeper… And I really like your work!

1 Like