[ROM][UNOFFICIAL] LineageOS 16.0 for FP3

Question to the admins: I can’t edit/update my first post anymore? Can someone make this a Wiki article if this is still possible? Thanks for that. Everybody can edit the post now. Please feel free and invited to extend and improve it. :slight_smile:

I created branches with recent changes from the /e/ device tree (also not merged yet) and created PRs for it. It removes some audio blobs and it fixes the screen lag issue. Scrolling is very smooth and nice now.
I made a build together with the recent changes from @dk1978 which should solve the NFC issue. Of course it also includes general updates in LOS.
As it is not merged yet I called it “Intermediate pre-merge build” :wink:

I couldn’t test the clean build without microG because I have my FP3 already in daily use and didn’t want to restore backup etc. If someone tries it, please give feedback if it works.


I faced it at some time in the past. But I can’t remember what I did. Maybe it’s processed after fresh repo init. I guess it only works with LineageOS repositories. We need to get official repos for that. However I didn’t check what is required for that so far. Maybe we’d simply need to ask for it. :smile:

Thought I just started trying to build it with a container, according to the README from github. As I’m not really experienced here (ha! ;-)), just for clarifying. When I look at the *.img, for flashing with fastboot, these are way larger than the payload in the twrp flashable zip. Is this correct, or did my build stumble somewhere?
And, as I’m on 0120 actually, do I have to do something with vbmeta.img? I don’t understand whether this is implied by " With generated vbmeta.img it shouldn’t be required to have both slots in successful state anymore" from the README


Yes, that’s correct. They are much larger. E.g. system.img is about 1.3G.

Yes, it’s better to flash it as described in the README.
Flashing the zip package with twrp is little bit easier though. It does everything for you.

1 Like

The vbmeta.img in my build was only 4096 bytes, file stated “data”, as opposed to the other .img files. Just restarted the container after removing the file, maybe something went wrong with it…

Here you can find what is necessary:

Yes, that’s correct. VBMeta only contains hashes for the other partitions and a signature (here for details).

Maybe you or someone here can answer this question on the page with yes: Do I want to provide continuous support?
:smile: :smile:
Unfortunately I don’t have too much time left at the moment. However I’d join the maintainer group if someone wants to take care for it :nerd_face:


I will answer with “yes”. :grinning:
This project is time-consuming, but worth it, and I don’t plan to give it up. By joining the official LineageOS community I expect that we would gain feedback and advice from other experienced devels, so it seems to me like a clear win.


That’s great :slight_smile:

I installed the newest build, but when I try to install Open GApps with twrp (after flashing, without firstboot). The apps are not there. How to install Open GApps to this build?

Did you have a look at this post? It might help.

Yesterday I tried to install it. As I had a few unrelated problems, i rolled back, but a few observations:

  • I couldn’t connect to my wifi, it would not take my password. Wanted to investigate later, but as i had no time left, no logs. Will try later again, if it doesn’t ring a bell
  • My sd card is formatted texfat. This was shown as unusable and i would have to reformat. Any way for a support of this fs type?
  • As i depend on some apps i wanted to install the patched play store from shadow53. It did not show, regardless of how i tried. Any hints?

I tried the disable verify option but it didn’t help. It’s just weird that I don’t see the installed apps and the install does not give me an error.

I installed the LOS without microG on my phone and tested. Everything worked quite fine - even Magisk. Amazing work you did!

Then I thought yesterday, I should lock the bootmanager to use the phone witout that boot warning. But with that I managed to wipe my phone - even Magisk. Somehow I mixed up the 2 partitions it seams.

But I have a question: Will the probblem with a complete wipe be always there when I update LOS before OTA is working? Or are there any hints to avoid that?

Greetings from good old Germany!

Hi Plus4,

But I have a question: Will the probblem with a complete wipe be always there when I update LOS before OTA is working? Or are there any hints to avoid that?

I am afraid this happens by design. See


Installation of Magisk and restoring user data will have to happen after relocking the bootloader afaik.

Best regards

Thank you for your answer, dk!
I’d like to go on testing LOS (because it is the best Android out there).
Is there any backup tool (on FDroid) that might help me restoring the installed apps or their configuration?

I can install Magisk with locked bootloader? :thinking:

Well… Roughly speaking the following should happen:

  1. Download the TWRP image for the Fairphone 3.
  2. Use TWRP to create a backup of the user data. As mentioned above somewhere, you can use the fastboot boot command to launch TWRP.
  3. Unlock the bootloader.
  4. Flash an update of the LOS ROM
  5. Use TWRP to modify the boot partition with the Magisk stuff, basically this can be done with the install function.
  6. Restore user data from backup.
  7. Re-lock the bootloader

If anybody has some details or comments to add, go ahead.


Great idea! I never thoght of the backup-functions of TWRP. I only used it to flash.
Well … the only problem I found out was, that I am unable to launch TWRP from fastboot with locked bootloader.
Maybe it works with the installed version …

Thank you for this ROM, its working really well for me :slight_smile:

I have been using Dual SIM for more than a month now, its working fine. You can probably remove it from the known bugs/untested list.

WiFi hotspot is not working for me, i reported it here.

I also experience some random crashes that i cannot pin down.


Hi iexos,
thanks for testing out our ROM!
I can confirm that the WiFi hotspot doesn’t work (yet). I will start working on it as soon as possible.