Reverting to Android 7 from Android 10 of the Fairphone Open OS

I will try a factory reset and post my experience here.

How can I check whether I am using an SD card formatted? I did not install any additional hardware.

1 Like

You can post a screenshot (hold POWER and VOLUME DOWN simultaneously) here of Settings > Storage. This will allow us to see immediately if an SD card is part of the internal storage or set up as “portable storage” (the safer option).

EDIT: Well, if you never put an SD card into the FP2, this is probably not necessary. :angel:

I am trying to get a screenshot but apps are just freezing (amaze, bluetooth,…)

As you said, since I did not add an SD card, I do not think the problem comes from there.

Thanks a lot for the quick replies!

2 Likes

The factory reset did not help. The apps freeze if I move around quickly within the app. I will downgrade to a Android 7 and check the result.

Hello,

Due to lots of instabilities in using apps in my FP2, I would like to downgrade from Android 10 to Android 7. I want to skip Android 9 since it also had the same instabilities but a fewer rate.

Any help on a step-by-step guide would be appreciated.

Thanks.

2 Likes

I merged your 2 topics as mainly having the same topic and adjusted the title here a bit

2 Likes

Thanks a lot for this guide! It was of great help.

I tested both Android 7 and Android 9 after following your steps. Android 9 still has the same instability issues whereas Android 7 is much more stable. So, I will stick with 7 for a while.

Thanks again!

1 Like

Hi @bjprabhu,
I used my FP2 for about 5 years up to Android 9. Over the whole time there were always minor or even bigger bugs. Already in A7 and even worse in A9 display artefacts and freezes were very anoying. So I put my FP2 aside and ordered the FP4, which has minor bugs too but runs reliable. I was already thinking about to send my FP2 back for recycling (battery is nearly dead).

As I heard of A10 for the FP2, I dared to try a manual installation to be as clean as possible. I did the following (first of all, back up your data):

  1. factory reset of the FP2 running A9
  2. manual installation of A10 following these instructions FP2. Manually update with Windows – Support (fairphone.com). The first attempts of flashing failed, but after changing the USB-Port it went flawlessly (!?), so what.
  3. after restart in A10, I did a factory reset again.

Now I’m playing around with the built-in apps as Chrome browser (web sites, videos), connecting bluetooth box, taking photos, watching google gallery and a downloaded app Fritz-TV looking video. Everyone works fine except one: the Youtube App freezes display running audio further on. Nothing helps except Volume down + Power.

I did these tests without a SIM-Card and no SD-Card. So I’d suggest to test your FP2 without any of these cards. I have heard that old SIM-Cards can make current OSes unreliable.

If you want to give it try, share your experience with us.

1 Like

Here some additional experiences made this morning. First of all, I updated all apps via Play-Store and did a Google Play-Systemupdate.

  1. very random display artefacts (noisy sprinkling) which vanish when display content changes (I have the first hardware version of display)
  2. display freezes seem to occur only when charger is plugged in. Running in battery mode or plugged via USB to a notebook works fine, Youtube videos too. This reminds me to happen in earlier versions, especially when charging in a train (fluctuating or not smoothed power supply, bad charger?).

Generally in my opinion it’s not a good idea to run an OS version which is really outdated.

Edit: changed USB cable which fits tighter to the FP2. The old one loosed connection sometimes. Now no screen freezes any more while charging. Fingers crossed.

2 Likes

So now one day using my old FP2 (clean A10, see above) instead of my FP4 (A11) I am really excited. If the FP2 would have run so smooth before, I probably had not switched to the FP4 :grinning:

My setup and settings I described above. I have the new camera modules installed. Besides stock apps I tested Fritz!App TV, CPU-Z and GPSTest. I didn’t test Whatsapp, Signal and no game apps. Under System → Maintenance → Extended Hardware Functions: all enabled

My experience:

  1. GUI runs smooth and reliable independent of typing or wiping speed. No hangs or freezes.
  2. battery drain is hard to estimate for me due to bad health of my battery. Nearly zero when the phone is not used
  3. the stock photo app couldn’t connect to the camera one time, but it could not be reproduced until now
  4. GPS fixes fast using three Satellite-Systems USA, Russia and China. Galileo is not supported by the FP2 at all as I know. Google Maps positions are exact, compass calibrates fast
  5. phone calls are o.k. in voice quality and stability. The speaker volume in handsfree mode is low as always before (in media mode speaker volume is much higher). WLan-Call and VoLTE are not available (missing driver support by Qualcomm?)
  6. sending and receiving SMS o.k.
  7. browsing with Chrome o.k. including video with Picture in Picture (which crashed in A9), some internet games.
  8. Bluetooth Box and Headset (cable) connect easily and sound o.k. (BLE activated but not tested)
  9. Youtube and Fritz!App TV Videos run smooth and reliable

Here is what I found (still) making problems:

  1. WLan randomly loses connection but reconnects immediately (happens less than once an hour, I notice that from beginning on (A5) together with my Fritz!Box Router; WPA3 is not supported)
  2. Nightlight definitively doesn’t work! When on, display freezes often especially at video playback. Nothing else helps but Power + Volume down to restart the phone. Maybe it has to do with my display module which is of very first version. I recognize that since introducing nightlight in Android.

Conclusion: with Android 10 Fairphone made the FP2 usable for a longer period of time. Congrats!
Since there were 5 major Android Versions published for the FP2 over the years, I suppose that some problems of my previous versions were based on the consecutive updates OTA via updater. Although I performed more than one factory reset in the past, I think there was something like accumulating waste which led to unreliable functionality. Now the clean install (factory reset A9, manually flashing A10, factory reset again) is something like a rejuvenation for the FP2.

3 Likes

Hi @KleinerAdmin.

Thanks for the detailed description of your setup.

My problems did not go away even after a fresh installation A9 for which I followed your guide and tested the following with no additional apps:

1 A9 had exactly the same problems as before. The one that I observed immediately is the freezing of the application when the scroll speed was high. For example, when I wanted to enable “Developed options” is “Setting”, if I scrolled down too fast, the application would freeze.

  1. A7 seems to work well since Saturday. I have installed a four or five apps (QKSMS, brower,…) from Fdroid. They are normal ones and not something exotic.

For A10, the reported problems were observed after an update done from A9 done by the Fairphone Updater.

The current state of affairs is that my FP2 is not stable with neither A9 nor A10 while A7 is usable.

When you mentioned the new camera module, I recalled that when I checked the Camera app after a fresh installation, a camera error popped up. I had to remove the back cover and put it back for the Camera app to function correctly.

I wonder whether these problems are appearing due to the camera module. Do you think I could ask the FP support to ship me one to test whether this is the source of the problems. My FP2 is no longer under warranty but the problems were reported on this forum within the warranty period. Maybe this is a sufficient proof of my good faith!

Hi @bjprabhu,

I’d suggest to dis- and reassemble all components of your FP2 and cleaning the contacts. Then follow exactly my guide: remove all SIM- and SD-Cards, factory reset the actual OS, manually flash A10 even if A10 is already installed (not A9, not via Fairphone Updater), factory reset again.

You can also check to start your FP2 without camera module.

Check the phone without SIM- or SD-Cards!

If your problems still persist even without camera module, I suppose your FP2 is seriously damaged.

3 Likes

I am not sure I have the skills to disassembling and reassemble my FP2. Also, I need my phone for daily use, and I am afraid doing such manipulations may render it unusable.

By the way, after the factory reset, all the sensors stopped working. The autorotate feature no longer functions and the other sensors (accelerometer, gyro,…) are not recognized my phyphox app.

Reporting issues here is not valid for claiming warranty with Support.

To test another cam module you would have to dissamble your phone at least partially and its really quite easy to do, so just try it.
Maybe you have an Angel close who can Assist? #fairphoneangels

2 Likes

It’s easy to disassemble the phone. The only tool you need is a little screwdriver. On the Fairphone site yout can find manuals. If you already use your phone for a long time, it’s most likely there are bad contacts to different modules (display, camera, top and bottom module). Give it a try!

2 Likes

After testing the FP2 running A10 for some days, I can resume:

System, GUI, stock apps, interfaces run reliable and smooth. Phone calls are o.k., battery drain moderate. WLan connection reconnects randomly, nightlight leads to display freezes.

In addition: camera access randomly fails (“error accessing device”). The elder camera module as a substitution is recognized by the OS, but camera apps report access error at all. Putting back the newer camera modul (12MP) leads to the initial, instable situation.

Sounds like a contact issue. It might help to remove the small “black rings” around the screw hole, with this its srcrewed a bit tighter. Some modules believed dead could be reanimated with this

1 Like

Hi, I’ll give it a try. But contact problems starting with software update? Anyway, I’ll report.

Coincidences can always happen😉. My FP2 has not yet received the update, so cannot test, but during beta I have not seen this camera bug reported. Did you try open camera app? If you feel its software related it would be worth it to open an ticket in the big tracker Products / Android 10 on the FP2 · GitLab

There are open issues reported in the bug tracker about Wifi