Revert to stock from LOS 20 with stock flasher issues


I’ve followed the exact steps on the Fairphone website on 3 separate windows pc’s to revert my FP4 back to stock from LOS 20.
I’ve made sure the drivers are installed on each one and followed the instructions fully each time.
I can find my FP4 in CMD using ADB devices and Fastboot devices but the script closes every time at the same point.
It’s asks me to type Yes to start the flash it then closes.
It’s either a duff script or Google Anti Rollback preventing flashing from A13 to A11.
I can try on Linux as the next step :triumph:

A Question for you: What was the reason for this rollback?

Just wanted to try Ubuntu Touch and see how it lookedand worked. I could then decide between the two.

I assume you use Windows? Thats a bug in the script…


You are right, completely forgot to check the new factory images they released some days ago and the problem is still there :man_facepalming:

Over three months later and they still haven’t managed to fix a simple mistake, JFC, time to reopen my ticket :roll_eyes:

1 Like

Maybe @gabrieleb can help with this one as well?

1 Like

Let’s hope so, there is no way to re-open the ticket and I’m not willing to start a new round of useless support communication about such an easy to fix issue, this should have been fixed 5 minutes later!

(Request #549862 if that’s needed)

@srdempster if you don’t understand the information in the :de: topic, here’s what you need to do to get it working:

Edit: I found the link to create a follow up ticket, let’s see how long it takes this time.


You’re assuming someone human is actually reading your support tickets, I’d say the joke is on you here :wink:

Well, I did communicate with a very friendly support person, once my ticket got noticed 3 weeks later.

If the bug however reached an actual human at the dev team it got forwarded to, I’m not so sure anymore … :upside_down_face:

Having worked at tech companies in the past, I can damn near guarantee one of two things:

  1. It’s on the to-do list. It’s just being avoided for one reason or another, maybe it’s “not my issue to fix it” or it’s 4 people looking at it daily and all thinking “yeah I’ll fix that later”
  2. The support guy forgot to forward it, you’d be surprised how many things people forget when you’re the 40th support ticket that person is responding to that day

I “fixed it” in the end by using a live Ubuntu and ran the script there. Ubuntu Touch is a nice OS and nearly there for me but not without the eSim support yet.
So reran the script to reset a 2nd time and sticking with LOS 20 till UT has the support. Thanks for the guidance.

1 Like

If the answers I got are to be believed, neither should be correct. There was a brief period of one day FP support waited for the dev team to reply, here’s what I got back after that:

After speaking with my team, you were correct in all the things you spotted here.

All the edits have been made and these have been fixed now.

As we know, this hasn’t been fixed at all, so I’m inclined to agree with you that it’s somewhere in backlog purgatory and the devs just replied with “yeah yeah, we fixed it”.

I would absolutely blame the dev side in this case, FP support has been slow but helpful, although they did write on October 31st …

No specific timeline yet - it usually takes us a couple of days to get these images ready. Keep an eye on the page, and they will be there soon. :blush:

… so maybe, as I suspected before, everything at Fairphone is running on Valve time :smirk:

Hi there - I have been reverting my fairphone 4 phone from e/OS to fairphone OS using Windows 11.

I unlocked the bootloader and I can see it says ‘unlocked’ when the phone is in fast boot. I have downloaded the latest firmware (FP4.FP4I) but I am having an issue.

I have extracted the file and then double clicked on the flash_fp4_factory and the script runs, and then it says (in yellow) that this will wipe the phone and I have to confirm by typing ‘Yes’ and hit enter. When I do this the script drops and you can’t see it any more, perhaps a crash? Looking at the phone it is still on the fast boot screen and nothing obvious is happening.

Any ideas on how to resolve?

I’ve moved your post to this existing topic :slightly_smiling_face:

Same unfixed issue with the installscript, workaround is here.


Thanks, that was helpful!


Noted, fixed, and notified customer support.

@hirnsushi you should have mail waiting in your inbox.



Thank you, I just read the mail :+1:

Checked the factory images as well and everything seems to be in order now :smiley:


I now have one annoying issue and thats my proximity sensor has stopped working. Is there a test menu in LOS 20? I want to see if its a bug in OS, something I’ve done and can fix. I don’t really want to go back to stock to test if its working if its a bug or not.

Since you’ve tried Ubuntu Touch before, you might want to have a look at this topic:

I’ve re-openend it, so you can follow up there if you want :slightly_smiling_face:

1 Like

Funny I’ve just found it as well what a pain in the arse! Thanks for the reply. Looks like I’ll need to magisk anyway to get wallet working so’ll research and post back my findings in a week or so.

1 Like