Regular apps crash FP1 after upgraded partition layout Kola Nut 1.8.7

Hi there,
I finallay upgraded my FP1 with this partitioning layout for the Kola Nut 1.8.7.
after upgrading I installed the Google package, restarted twice.
I backuped the Application and Files befor, with the Backup Tool provided.
so I restored them by the tool afterwards. one app failed to restore.

Unfortunately when I f.e. start google maps, youtube or the most other apps. it just crashes.
When I go to the Fairphone updater, it displays “error loading config file”.

what can I do, so the phone works properly again?
Many thanks in advance.

A couple of questions that may help people here figure out what’s going on:

  • Was the partition layout upgrade successful? (Check Settings > Storage. Is there a single internal storage of >13Gb?)
  • Were apps opening normally before you restored your backup?
  • The two apps you mention are both google apps, do the problems also occur on apps that do not rely on google services?

To fix the fairphone updater, you can try to reset the app’s data. It’s under Settings > Apps > All (swipe left until you get there) > Fairphone Updater > Force stop + clear data. You can then try the updater app again. If/When you can access the app again, check what is reported as current operating system. It may help to reapply the update to 1.8.7 (first make sure you still have that backup).

Alternatively, If you still have a copy of the backup you could perform a hard reset of the phone. You’d then need to restore the backup again. If the problem is because of something related to the backup this wouldn’t help that much, hence the question about whether you know if the phone worked normally before the restore. If you don’t know, check whether apps work normally after the hard reset, but before the restore.

1 Like

the update worked, it is just one partition + my SD Card.
the apps were opening normal, before.
Also other apps are crashing but not all!

I uninstalled f.e. google maps and reinstalled, that worked.

It is strange that it showed me only one app failed, during backup restore procedure but so many crashed.

thanks now I can enter the updater again, nothing to update anymore (fairphone kola nut 1.8.7). and I restored several apps, the ones that crashed dont crash anymore. thanks for the help. :slight_smile:

1 Like

Then I guess that restoring the backup isn’t working well for apps after the partition update - maybe it is restoring some data to the wrong place. Luckily, the partition upgrade is something you only have to do once! Probably the other apps will also work again after reinstalling them, just update here if that isn’t the case.

This might be connected to the problem that the backup app didn’t back everything up. Some apps are looking for data on the internal storage but it’s not there anymore because it wasn’t backed up