Registering is a complete failure

My phone kept informing me about registering myself, so I figured “sure why not” and I clicked on the message. It led me to a “404 not found” link…

That is the first brilliant mess.

Then After a week the link finally worked, I wanted to login on my phone, I type in my email and password that is 100% correct as I literally copy - pasted it - Login failure.

That is the second brilliant mess.

So naturally I wanted to reset my password. Of course, it completely failed. No email after ten requests.

That is the third brilliant mess.

Seriously get your organization together people. There is no excuse for this.

1 Like

Can you tell a little bit more detailed, about what kind of ‘registering myself’ you are talking? And please be aware, you are talking to fellow users here in the forum, not to the company Fairphone.


I would still assume that they are watching more or less regularly as well.

Anyway, with “registering myself” I am talking about the notification that I received from the My Fairphone App (where I am not [yet] logged in mind you) which tells me to register to get my extended warranty n stuff. After clicking said notification, the things mentioned above happened.

And no you cant expect


As I wrote here, the link worked later, but then it continues with issue number 2 and 3.

There are different passwords for shop and forum. Which one did you use?
I just tried to sign up and my shop account worked perfectly.


Hello @Hahnfruh

We had a small hiccup with our warranty registration form yesterday, and the fix went live in the evening, now you should be able to correctly register.


I think there’s a glitch with the newest version of My Fairphone App. It stopped recognizing my registered warranty, and the link to register is not working. It is a truly minor issue but reporting it here as it might be confusing for new users.

1 Like

Mine still remembers my warranty.
I’d suggest to log in through their website and check if your warranty is still appearing there: This might be an app issue, or a general Fairphone backoffice issue…

1 Like

Thanks for following that up. How can I check it through the website? I can still see the rewards for registering warranty under my keep club account, but I when I go to warranty registration section it asks me for the IMEI and afterwards reports an error. It all looks like a temporary glitch. Will store the confirmation email in a safe place as a backup though:)

Go to and log in (little circle with a head in it).

If their website has also issues recognizing your warranty, it might be your account data have been somehow corrupted, and in this case you should contact them.

(Store your confirmation emails and other proof in a safe place anyway–always! :grinning:)

1 Like

Thanks. Will give it a few days. It is nothing urgent and it feels a bit like wasting the resources. There is nothing wrong with my phone and I have definitely registered the warranty.

Just a follow up. All good now


I want to register my F5 but when I click the fairphone app and navigate to the register for extra warranty it loads a form and then it loads an image on top of that form. So now I can’t see, read or finish the form and I am thus unable to register my new purchase.

I have two questions:

  1. Can someone help me? I really want to register my phone. Is there a way to do this on my laptop? When I log in on the Fairphone site I can’t seem to find the place where I can register my new phone.

  2. Why is this not just an auto include? Why does Fairphone want to inconveniece new customers like this? Is this normal for them? I never had this much hurdles and hoops when I switched from Samsung to Oppo. But this time around the switch is really taking its toll and I am getting more frustrated by the second. The switch cost me about six or seven hours so far. I am not happy at all that I bought this phone and hope that after this (hopefully) last hurdle I wil finally be able to use my phone properly and with the warranty that was advertised.

Hello and welcome
Yes, you can register for the extended warranty via the website,
I think it works better than via the app, at least this is what I heard.

I am sorry about the frustration with the switch. Not sure what went wrong.

Edited to delete the misinformed part

It is somehow crucial still as you have to register within 90days of purchase, unless that was changed.

@Daniel_van_Ginkel I moved your post here as there seem to be some hicc-ups with the homepage which can affect the app as well.

@yvmuell thanks so much for pointing it out.

The website clearly states 90 days period but strangely enough I have never noticed it before, my bad.

@Daniel_van_Ginkel please ignore that ignorant part of my previous post

Hi, I have recently bought a FP5 and i can’t registrar via the pre installed app. Its coming up with an error code 404, page not found.
Can anyone help please?

See above as well