Reboots by running OsmAnd navigation on a charging LOS Fairphone2

Now I have experienced it a second time: I have got reboots of my Lineage FP2 when running the OsmAnd navigation and charge the phone at the same time. It happened to me after running the navigation app for about one hour riding my bike and charging the phone via hub dynamo and the ‘Forumslader’ charger. Programms running: OsmAnd, Bluetooth switched on.
The situation is similar to running the navigation app at a car with charging the phone plugged in at the cars battery. In my case the situation is even better because the phone is cooled down by the wind. So I don’t think, that this reboots are caused by to much processor heat. At another occasion I run the navigation for two hours without any reboot, but also without charging the phone at the same time.
Did anybody else experience such reboots with this or another navigation app, with LOS at the FP2 or other OSses? Normally I am quite happy to have no reboots with my LOS FP2.

I’m using the fp2 with osmand navigation while charging in the car for hours without problems…

1 Like

Anybody else with or without problems running navigation at the Fairphone2?
@lklaus Nice to hear! Besides the kind of vehicle there should be some more difference, which causes my problem?
What mode of location do you use? I used ‘high accuracy’ (hohe Genauigkeit), next time I will try ‘only GPS’ (nur Gerät).
Any other hints, what could be the reason for my reboots?
Unfortunately I can’t get the pro version of the DevCheck app. I would need the Google Play Store for that. Otherwise I could watch the processors and other temperatures while running the navigation.

I’m using car navigation, and only gps. I’m mostly in the open, and gps needs around a second to lock… When touching the phone it’s warm, but no way near the temps it was in the old fp open days…

1 Like

I’m (still) in FPOS and have reboots very rarely at all. I’ve experienced a reboot once during car navigation with Osmand but never again afterwards (okay, I don’t drive that often). It was charging and used GPS only. The phone hasn’t been warm at all since it was located directly at the outlet of the AC. So it was almost freezing there :wink:
But it was running fine for hours in a different car without that kind of cooling and the only difference was that it stopped charging due to heat.
At the recumbent bike (under seat steering) I don’t have a good spot for fixing the phone and charging it at the same time (in my belly pockets I’d need to pay attention for the cable when getting off the bike). So usually it is either charging in the luggage or navigating with audio driving instructions only. There I didn’t have any issues yet.

I still use FP Open and had similar problems on my last multi-day bike tour. I used “Locus Map” for navigating and was charging my FP2 with a powerbank. After several reboots day after day I recognised a pattern: every time the charging status was at ~92% the reboots started happening - never with lower power status. This was 100% reproducable: I tried to keep an eye on the battery percentage and stopped charging when getting close to 90%. That prevented reboots on multiple days until I again didn’t pay enough attention and accidentally charged above the critical point: instant reboot.

Also, I don’t think it’s the GPS or the routing per se but more some sort of “heavy” usage, as reboots also happen sometimes to me when I have the phone plugged in the charger at home and use it for other tasks (no GPS activated!). To my recollection it also happens in those cases when the phone is merely fully charged, but cannot confirm this for sure, as I mostly charge over night.
In other circumstances then the described “charging reboots” I very rarely experience any other reboots.


Hi @parisc, thank you a lot for your remarks, which may be quite important to find out, what is realy causing the reboots! And probably not only reboots, when a navigation app is running!
You said, it was 100% reproducible. So this is a failure malfunction of the FP2, which happens under specific cirumstances: A matter, the Fairphone devs have to deal with.
On the other side: Such reboots also should happen, when someone is running a navigation app and charges the phone at a car. It could be quite helpful, if other people could report about such incidents!

This afternoon again I was riding my bike for about 1.5 hours or 40 km, navigating with the phone and charging it. No reboot! When I started my ride, the phones battery was at around 70%, when I finished the tour, at 100%. But before I started, I changed two parameters:

  • I switched the phones location settings from “high accuracy” (hohe Genauigkeit) to “GPS only” (nur Gerät) and
  • within the OsmAnd app I changed within the common settings to "“Abgesicherter Modus, Verwendung für langsamere Android-Versionen” (my translation: “secured mode, application for slower Android versions”).
    Both changes may have reduced the computing power the phone had to provide. And therefore it didn’t reboot, even when it reached the 92 % charging mark.
    When the reboots happend to me, the battery was nearly fully charged, but I don’t remember the exact amount.
    In future I will concentrate my attention to the charging percentage and change only one parameter to find out, whether it makes a difference regarding reboots and the moments, when it happens.
    For further investigation it would be very useful, to employ the Pro version of the DevCheck app. With that app you could watch different temperatures when running a navigation app. But unfortunately I can’t get this version because I don’t have the Google Play Store at my phone. The Yalp Store doesn’t work for apps you have to pay for. I happily would pay for the benefit of that pro version!!!
1 Like

Does devcheck record the information, our would cpu-z be sufficient? Shows you all temp sensors

Can you post /proc/last_kmsg after reboot?


@chrmhoffmann An android layman as me doesn’t understand what you want me to do. Do you want me to copy a special file to you, which one? Could you please explain it detailed?

@lklaus Thanks! I will tray to use the cpu-z app.

I did two other tests, again each for 1 and 1/2 hour and 40 km:
A) No “abgesicherter Modus” in OsmAnd, “common settings"
and “GPS only” at “location” within device settings.
Programms running: OsmAnd, Bluetooth switched off.
Phone battery charged from 70% to 100%.
Result: No reboots!
B) No “abgesicherter Modus” in OsmAnd, “common settings” and
"high accuracy” at “location” within device settings.
Programms running: OsmAnd, Bluetooth switched off.
Phone battery charged from 30% to 100%.
Result: No reboots!

Difference to former tests: I have updated to the 2017-09-25 lineage fp2 version. But I am not shure, whether this update is preventing reboot.
Edit: Another difference: When the reboots occurred, Bluetooth was switched on.

1 Like

Today I ran the OsmAnd again with Bluetooth switched on, all other parameters as before. Result:
Reboot after about 1 and 1/2 hour with charge level 100 or near 100%. I started at around 40%. Now running Bluetooth seems to me to make the difference between reboots and no reboots. When I experienced the very first reboots with running OsmAnd, Bluetooth was running as well. I need Bluetooth to watch charge level, voltage, power in- and output and others at the Forumslader via the Forumslader app.
@ikarus, @parisc: Did you use Bluetooth when running your navigation app? Could you find out, whether it makes a difference for you using or not using BT?

2017 Oct 05th: Newest Lineage OS (2017-10-04), Bluetooth switched on, location: only GPS, WiFi switched off: After half a hour running OsmAnd the map at the fp2 screen disappeared, I only could see the black triangle representing my bike. I tried different measures to get the map back. With changing the scale I got it back, but the map didn’t move any more when I went on driving the road. The only way to get it back running properly was to reboot the phone. Quite annoying experience, because I need a reliable navigation device. I will be a guide at my bike clubs next CTF (Country Touren Fahrt). Do I have to go back using my Garmin device with this awful small screen?

Do you have an active Bluetooth connection as well?

Yes, I am running a dynamo charger with power bank batteries its name: “Forumslader”. This charger is connected via Bluetooth to the “Forumslader” app, running at the FP2.

Hmmm. Do you know how to capture a file called /proc/last_kmsg after a

No, I don’t, but should lern to do it!

Just for the record. Today I’ve been navigating for 6 hours without any reboot. LOS 20171004, gps only, no Bluetooth, charging all the time. No reboots, stable as a rock

Update; next day also around 6 hours, including charging from ca 40% to full

1 Like

Hi @lklaus,
nice to hear that it works for you so well! With that I don’t need to give up; may be, I’ll find another cause for my problems? To you I have the request to run Bluetooth while you do your navigation next time. Just switch it on and let it run in the background. Still I have the suspicion, that Bluetooth causes my reboots.

1 Like