English

Reactivate WLAN? You better reboot!

Hello fellow forumlings!

Here`s the specs:

I turn Wifi off when I am on the road. Since the last update, it wont turn back on when i activate it. It just goes “activating WLAN” and thays it.

I now have to reboot (where os a random reboot when I need it) the phone and then it works.

What do I do to fix this?

It doesn’t exactly sound like this issue: https://bugtracker.fairphone.com/project/fairphone-android-7/issue/36

But you could try the suggested workaround to toggle airplane mode on and off again (if you haven’t tried that already).

4 Likes

I shall try this. Thanks!

A quick browse on XDA found me three solutions to this precise issue (on different phones):

  1. Deactivating Settings > Date and time > Automatic date & time.
  2. Removing SD card
  3. Deleting /persist/wifi

The last one only with root access and at your own risk, of course.

4 Likes

Turn on and off Airplane Mode: No work, still stays on “activating…”
Turn on and off hotspot: Works sometimes, but takes longer than a reboot to take effect.
Deactivating Automatic Date & Time: Changes nothing
Removing SD Card: Changes nothing, but thanks for the tip. I had many many black black thumbnail images of pictures long since moved in the gallery that have haunted me for about a year :smiley:
Deleting /persist/wifi: I do have root access, but i didnt dare to try this as this FP2 is my daily driver and I cannot risk bricking it or anyhting.

Ok, now my wifi keeps connecting and disconnecting and then deactivates iself, forcing me to reboot the phone.

The Leidensdruck factor is now high enough to try the deletion of /persist/wifi but alas, I seem not to be able to find wifi in my /persist/ folder. Is it a hidden file or folder?

Screenshot_20200419-211827

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.