Re-install google play

Hi guys,

I’m afraid I am an absolute beginner when it comes to smart phones. A few months ago I’ve deliberately disabled Big Brother Google, but now I’d like to reactivate it.

I can find the Google Play Icon in the App menue under Settings, but I cannot move it to the main app screen.

Reading a previous thread slightly worries me (“humorkritik - Aug 24 - I ended up wiping the phone”)

Any ideas? And, should I have to wipe the phone, how do I save my contacts, which are currently on the phone, not the SIM card. Is there a copy function?

Thank you for your help!

Christian O, Brighton UK

You should find the “google apps installer” in the list with widgets.
In 1.8 press the menu key (bottom left of the 3 “hardware” keys), in 1.6 open apps (the six dot symbol in the quick access swipe menu) and go to the widgets tab.
Drag that one to a free spot on one of your home screens, and click it.
Full instructions can be found here.
That should do it!



what exactly have you done to disable Google?


Even if you don’t have to wipe your phone, you should think about a backup-to-SD solution.
I use TitaniumBackup, as you might have read in other threads. I got it from Google’s PlayStore, but just searched for an .apk and found some somewhere elese. However, I would quite probably not install it from websites I don’t trust.

I’d be really interested how you ‘disabled’ the Google apps without going back to factory settings… Google apps embed themselves quite deeply into Android. You can get rid of them, but it needs quite some effort and causes some pain, surely.

Thank you everyone! But I’m afraid so far your replies haven’t really helped.

I’ve followed the re-installation guide of Fairphone, and apparently Google has been re-installed. But I cannot activate the Google Play app (the white shopping bag), i.e. cannot get it from the apps menue (under menue) to the appear on the surface of my phone. And Google tells me that Google Apps isn’t installed on my phone when I try to test-buy (i.e. BBC weather)

As to how I de-installed Google in the first place - I honestly do not know anymore. I’ve dsiables all functions which allowed Google to track me, and removed Google Play from the home screen - and I’m sure something else, but I cannot remember.

By the way - as long as I haven’t got access to any apps, I wont be able to download a back-up. Which I’d need to wipe my phone. Seems a Catch 22 situation


don’t worry I believe the situation itself is not that bad, its just a communication problem. There are several ways to remove Apps from your phone or just to make them invisible. I try to find out what you have done.

If you have disabled several google services in Settings->Apps -> All (Anny?) this can cause funny effects but you can enable the services easily again at the same place (you will find them at the end of the List).

If you see the White Shopping Bag at your App drawer it is installed, but maybe you have disabled or removed a “helper” Service.

How long do you have this problem? What have you done before the problem occurred the first time?


PS: Andoid allows to install Apps even without using the App Store. The Store is just the most easiest and comfortable way to do it.

1 Like

Dear Bjoern,

thank you for getting back to me - and apologies for the late reply, we
were a bit busy on nights, Christmas dinners and Christmas accidents.

You ask what I have done before the problem occurred for the first time

  • I’ve just not used any apps! But then I thought I should finally give
    up my inner resistance against new technology and tried to start with
    BBC weather, and here I I run aground - the message is: ‘You haven’t
    opened google play account on this e-mail account on my ‘Geraet’ =
    phone’ . I have just created a brand new google account and re-booted my
    phone, still the same.

I can find the app store (white shopping bag) under ‘apps’ in
’settings’, but I cannot launch it. Those are the messages I get:

Google Play Store version 4.3.11

live buttons: force stop - uninstall updates - disable

tick on ‘notifications’

storage information

live button: clear data - clear cache

no defaults set

launch application - launch the application by main activity: the button
’launch’ is not active

Thank you for your help, Bjoern!

Kind regards,]


Hello Christian,

the Buttons you descripe are buttons you see at the Application Management menu. This is not the place to start any apps, it’s a place to mange, remove/disable then.

To launch an App you have to open the App drawer, which you do at the default Fairphone launcher by swiping from the left or the right edge of your phone to the middle and stop at the cycle symbol with the dots in it. I don’t know how to explain it well but you can see it at this Video.

I hope this will help you to start the playstore and install the Apps of your wishes. Otherwise just ask again.

Happy Holidays,

1 Like

Dear Bjoern,

I am impressed and touched by this late night response - and in Mainland
Europe you are even one hour ahead of us here in the UK. I’m afraid the
video doesn’t quite tackle my problem, and maybe it’s my fault, because
I so cannot speak ‘smart phone’ and find it difficult to explain my
problem precisely.

Hence: here come 5 screenshots of my Fairphone - and if they might to
bit-heavy for one mail, I shall send them in two lots:

These two shots show you what is on my screen when I do the ‘launcher
swipe’, the next will show you what comes up when I go open ‘apps’ under

Kind late night regards,

Christian Osmer

Hello again,

I think it was a little to late yesterday evening.
Of cause you where at the App manager, because I send you there.

The buttons you described are telling me, that you havend disabled the play store and that it is still installed at your phone. So you should find it at the App drawer.

I can’t find a option to hide apps at the Fairphone Launcer (I’m using the smart Launcer with hase one) so I have no idea why the play store icon is missing at your app drawer (but I will try to find one ;-)).

There are two thinks we can try.

  1. At the App manager App! Manager, where you have found the explained buttons should be another one called “Execute” if you scroll a little down. Can you start the play store that way?

  2. You can try to uninstall the updates of the play store. Normally it will install then automatically again after a while (a few hours) and (just) maybe it will create its icon new. In worst case you have an older (but still working) copy of the play store on your phone, when we find a way to start it ;-).


Hello again,

one Cup of Coffee later I noticed that you are using McAfee Security. Checking its Function List I saw that this App offers a way to “Lock Apps”. Have you locked the Play Store using McAfee? In this case you should be able to enable it again using this tool again.


Dear Shiny

thank you very much for all your help!

I’ve checked out McAfee, and the Playstore wasn’t blocked, but then I
tried your suggestion below and just uninstalled playstore’s updates.
And asyou said, it re-installed itself and now is visible in the app
manager, and works!

Saying that, when I read all the warnings one signs up to, like giving
playstore (i.e. Google) access to my messages, phone, location etc, and
playstore preventing the phone from going to sleep, I might uninstall
the whole thing not long from now and revert back to an app-free

But BIG THANK YOU for all your help. I taught me a bit more about my
phone, as well.

Have a good Christmas,

Kind regards,


1 Like


I’m happy I could help you.

I think a smartphone should be smart, and so I use some services that allow collecting Data about me but I try to reduce the lags.

So I wan’t to suggest you two Apps/technics that might be interesting to you.

  1. AfWall+: This is a simple Firewall App. By default it prevents the Network Access for every App and service. I’t dos’t matter wat Data a App collects if it is not able to send this data to it’s developers Server. And this App alows you to control seperaty if a a App is allowed to acces the Net via mobile connections or just at WiFi.
    This App is quite easy to use and can be installed with the Play Store.

  2. The second solution is a little more complicated but gains you more control. It’s called XPrivacy. This System allows you to control every right of every App separate. So it you want to use an App that needs Internet Access but you don’t want it to Access your Contacts, you can deny the access to the Adressbook by allowing the Access to the Internet. This assumes a deep control of your Phone API. The XPosed Framework ensures that control so it is needed to run XPrivacy.
    Using XPrivacy will make the first start of an App a little annoying, because you will asked about everything the App tryes to do. So you must understand what the specific Actions are needed for, you have to deceit if a specific right is mandatory for the function of your App, if you deny the wrong right your App cant work (but of cause you cann change your decision every time later. Normally the Xposed-Framework would installed manually bypassing the Play Store, and the XPrivacy Module is instööed via the Xposed Manager but I found this App that promises to install the other two thinks on a more easy way. Maybe you want to try it.

I use both solutions concurrently on my Fairphone, and both do there job well. Maybe they will help you to make your Fairphone smarter. You are at the privileged situation to own a rooted Phone this allows you to get control of your phone back with Apps like the described, for most smartphone users this is not an option because other phone manufactures wont allow them to use a thing like a firewall (or uninstall the play store).

So its your decision!

Happy Holidays,


@Shiny Thank you very much for your great assistance!

Everyone have a nice and peaceful holiday!

This topic is now closed. New replies are no longer allowed.