Random Screen dimming (while brightness slider stays at 100%) after A12 update

It is especially nice that they reply to others who make the same request that they do not know the problem.

1 Like

From here I would kindly ask we dont further discuss FP behaviour/information policy, as it is off topic here, there are several other topics just for this discussion


As in, ticket? I’m pretty sure we can’t use their GitLab.

1 Like

Glad I’m not the only one with this. As soon as I sit in the sun for 2 minutes, my display dims by what feels like 50%. Is this possibly a thermal problem or a hardware defect…
I have already contacted support.



Well, to paraphrase a well-known TV series, “Summer is coming”… :anguished:
We’ll quickly know if it is indeed temperature-related. I sure hope not, summer is known to be overall quite sunny (= bright).

(I for one am starting to wonder if it is not the clearly broken A12 "Android System Intelligence” aka “auto-learn” aka “AI” (see the thread about the FP not being able to learn user brightness preferences). There seems to be some kind of perverted logic behind those arbitrary brightness changes, and most of all, they happen in the usual reaction delays of A12’s broken adaptive brightness.)

1 Like

I can’t wait for this screen dimming & buggy proximity sensor combo. :smile:


So you are still on A11 :slight_smile:

No, I’m on Android 12.


OK I though you meant looking forward to fix, but just checking that you weren’t excited about getting the bugs :slight_smile:

If it doesn’t drive the user to depression there’s good chance it will make the user stronger

1 Like

It might obliterate their eyesight in the process.

1 Like

I had the same problem, but I think I have found a solution. In the accessibility menu you have a menu called “extradark” for the display. If you click on this, you can make settings for this. If you turn the there the Extradark mode on, then you have an option for intensity of this. In my FP4 it was about 75%. I put it on 100% (brighter). then I turned off the extradark mode again.
Since then it think i didn’t have these problems anymore. It seems although its turned off, that the FP4 activate this mode somehow. But if you put it on the brightest setting it doesn’t have any effect. i am looking forward for your comments.


Hi and welcome, thanks for that, I set it to 100% and will test over the weekend, luckily sun is shining, so easy to test.

Edit: sitting here in the sun since several minutes and my screen did not dim, that was not possible yesterday before I changed it.

So at the Moment I think it solved the problem for me while in the sun. Will observe further over the weekend.
To easier find that possible workaround I will mark it as solved for the time being.

Edit 2: no this helped only once, now I’m back to see almost nothing in the sun…as we have 3 (1 in a DE topic) reports it does not work I will remove the solution mark.


I set it to the lowest brightness and even that seems like it could have worked, so maybe only having toggled that option on/off helps? :thinking:

So far randomly switching between tabs in Duolingo, which really heats up the phone and usually triggers it, doesn’t dim the screen.
I’m cautiously optimistic :crossed_fingers:

Edit: At least turning it down didn’t work for long, Duolingo still triggers it. Interestingly enough it didn’t get any dimmer than before, so changing the level had absolutely no effect, this might not be it.
I’ll try the proposed solution for a bit.

Edit 2: Nope still happens. But I’ve made the observation that if I immediately switch out of Duolingo into a less demanding app (with how bad it’s handling resources any app basically), it only takes maybe half a minute to get to full brightness again, while after staying in Duolingo with a dimmed screen for longer it can take several minutes.


Interesting! I’ve tried switching this well named “extra dim” menu item on and off again too, so let’s wait a couple days and see it if this changes anything… :smiley:

In my case it unfortunately didn’t help at all. I previously had the Extra dim set to the lowest value so I changed it to the highest value. But the display is still absolutely unreadable in bright environment when the dimming happens.

i realized I have the random(?) dimming issue as well. didnt realize it before as it probably didnt happen too often but now it appears daily. and i dont find it linked to sunshine, it happens everywhere.

United States user. Anyone else notice that when it dims on Android 12. The touch screen seems to stop working for a moment when playing games. I leave mine on the brightest settings and have adaptive brightness turned off in settings. I play Mario kart tour and it gets annoying when it dims. Even if only for a moment. I don’t find it’s only when I play games like Pokemon go outside that the phone is a little warm. It’s the middle of summer here. In the 90 degree heat. I like taking it with my old iphone with internet enabled on it. I think it’s more of a safety feature. But like I said it’s annoying at best and it cost me a PokeBall or two (points in tour.) I enjoy using this device. I want to help the environment by supporting company’s effort in Europe. Please send a working model to other countries in the future.

Yes both mny wife and I get this issue, and it makes the phone quite unusable outside

A temporary fix that I found useful was disabling visual effects. The phone I have solves the problem. But it’s not a permanent fix. I’m able to game outside for longer without dimming. I was able to game for about an hour give or take a couple of minutes on a hot day. My phone is only two weeks old though. But it’s annoying when playing pokemon go. Mario kart tour. I just have to replay the level in most cases. Your results may vary is what I’m saying.

1 Like