Random main camera issue when trying to open it (id=0)

Hi all

I am experiencing a camera issues in by Fairphone 3+ with Android 13.

Some months ago when I tried to open the camera and below message appeared.

open camera error id=0

When this message appears the torch do not activate…
The issue appeared randomly and more frequently as the weeks passed.
The camera can be opened randomly as well, sometimes after a reset, sometimes when passing some time without use.

Other symptom is that when the camera works it take a lot of time to write the image on the internal or external memory.

Then I contacted Fairphone support team and followed some steps:

  • Launch camera app in safe mode
  • Clear storage and cache of camera app
  • Check latest updates: All updated
  • Run single test from ##66## → main camera and flash led failed
  • Phone restart
  • Install Open Camera. Error message: Failed to open camera. Camera may be in use by another application? ID:0

After all these tests the random issue persist, without a clear way to reproduce it or to solve it. Sometimes the camera works fine, most others not.

Thinking in a hardware issue I also purchased a new camera module. After install it and clear storage and cache the issue persists.

I also noticed some “camera in use” message in Torch button.
I noticed as well some positive response when blocking or/and enabling the Camera Access Button. But I could not reproduce neither the issue of the fix.

At this point, I am thinking in a camera connector or main board hardware issue.
The other option could be a software process that it interfering with the main camera.

Any idea of how to resolve this annoying problem?

Thanks in advance

Not very specific, but might be worth checking:
Speaking of the camera connector, it has two ends. The one you see is right at the camera module, but the other end is hidden under the silver plate of the motherboard. That hidden end can become disconnected (just as the visible end). Maybe it’s not properly “clicked” into the motherboard. Perhaps worth to look into this.


You might also try a factory reset if you have a working backup of your data.

Happy New Year and thank you for the info!

I will unmounted the plate to check the right connection of the camera cable.
I suspect to a dirty contact of similar because another symptom is that when the camera works the images taken take a lot of time to be written in internal or external memory.

I will provide feedback about the checking.

Best regards

Hello again

I disassembled the main board, including the silver plate.
I could identify the camera cable, I disconnected, cleaned the contacts with isoprophil alcohol and reconnected. Unfortunately the issue persist :upside_down_face:.

Just after reassembling the FP3, the system took some time to show any picture and shown a random responses. After 1 hour I could see an image and take some photos but after some retries the error message appeared again “open camera error id=0”.

The next step is a factory reset :sweat_smile:. This will took some time for FP3 backup. On the other hand will be interesting to check if the issue persist with android 11 in order to know if the issue root cause is Android 13.

Before the factory reset I would like to take some logs with additional information about the camera error. Anyone knows a easy way get those logs?

Best regards

You might use “MatLog Libre” app (from F-Droid) or use adb logcat from an USB attached computer (and after enabling USB debugging in developer options).


Thank you Volker for the MatLog suggestion

I would need to invest some time to get some useful information. I am not familiar with this debug tools.

Regarding the root cause I am suspecting of a main board hardware issue. Maybe a PCB degradation or similar. I would be nice to get a camera cable spare to discard another HW piece. Someone knows if this kind of spare is available?

On the other hand when I did the phone factory reset I expected to downgrade the android version to discard it as the root cause. Is possible to perform a camera test with the bootloader? By this way I could discard Android as the root cause. How could I enter the FP3 bootloader?

Thank you and kind regards

Hello Volker

I just tried the adb logcat to get a 4 seconds log from my FP3 camera issue. It has been really easy to get the log in an Ubuntu computer.

Please, check below the log. This is just what happens when trying to open the camera app and a fail message appears. I would like to remark a calibration error that I noticed.

03-10 21:18:12.163 30047 15585 E mm-camera: <SENSOR><ERROR> 515: af_actuator_set_params: failed rc -1
03-10 21:18:12.163 30047 15585 E mm-camera: <SENSOR><ERROR> 1084: actuator_process: failed rc -1
03-10 21:18:12.163 30047 15585 E mm-camera: <SENSOR><ERROR> 1188: module_sensor_actuator_init_calibrate: sensor_failure : ACTUATOR_SET_PARAMETERS failed
03-10 21:18:12.163 30047 15585 E mm-camera: <SENSOR><ERROR> 259: module_sensor_offload_init_config: module_sensor_actuator_init_calibrate failed
03-10 21:18:12.163 30047 15585 E mm-camera: <SENSOR><ERROR> 315: module_sensor_offload_init_config: failed
03-10 21:18:12.184 30047 15585 E mm-camera: <SENSOR><ERROR> 1505: module_sensor_init_session: failed
03-10 21:18:12.184 30047 15585 E mm-camera: <SENSOR><ERROR> 1644: module_sensor_start_session: failed
03-10 21:18:12.184 30047 15585 E mm-camera: <SENSOR><ERROR> 1667: module_sensor_start_session: failed

I also include the full 4 second log messages in pdf format (not possible to upload .log files)

I hope this could help

Best regards

FP3 Camera Issue 240310.log.pdf (70.7 KB)

Good that you could succeed in pulling the logs!
Still I’d just answered your question about how to get them. Unfortunately I can’t really help with the results (well, it just sounds as a module not being addressable by SW - so maybe a temporary HW failure?).

Thank you for the reply Volker

The problem is that the failure is persistent, some days I am unable to open the camera app.
But today only 2 times from 10 is the camera app fails to open.

I will send the log to the support team. Maybe they could see something.

Best regards


Just stumbled over this topic due to searching the error message with Google.
Had the same issue since about autumn 2023.
What seemed to help me is closing down Google Lense running in background and/or disabling the programmable button of my Cat S62 Pro on which have had that super annoying failure since months!