Question regarding Fairphone Updater

I still haven’t converted to the newer version Fairphone Open OS on my FP2. There is the Fairphone Updater waiting. What I find irritating: Both Yalp and Aurora tell me there is an update for Fairphone Updater (1.39.9 vs. 1.39.15). So when they report that, this means that a newer Fairphone Updater is in the Google Play store. Why isn’t that in F-Droid? Is it genuine, can I (or: should I) update Fairphone Updater?

Second question regards F-Droid: There is a newer version of the F-Droid Privileged Extension (0.2.7 vs. 0.2.9). Before updating that, F-Droid tells me have to uninstall it first (different key used). Can I safely do that or is there a problem with re-installing PE? As a FP Open OS user, I do not have root privileges…


1 Like

Good question. One you’d have to ask the people of Fairphone, not the community. I don’t think they ever revealed why they didn’t release a version for F-Droid.

Yes, definitely.

Open OS is rooted. You can enable root in the developer options. Without root the privileged extension doesn’t work anyway.

Where did you install the privileged extension from in the first place? Usually if you install it from F-Droid you shouldn’t have to uninstall it for updating.

The funny thing is: The whole idea of FP Open OS is to be Google-free. But without Playstore or Yalp/Aurora, one would never even SEE that there is an update for the Updater, hence never get it…

1 Like

Ok, I updated the Updater. But with F-Droid PE it gets complicated: There ist no uninstall… I got root privileges in Developer Options, but F-Droid does not give me an uninstall. When I go to F-Droid PE (which is identified as 0.2.7) I see three versions. Clicking on 0.2.7 or 0.2.8 give me “install” as an option, 0.2.9 gives me “update” which will yield the error message, that I first have to uninstall 0.2.7 because it used a different key (I do not remember where I got it from). Setttings | Apps lists only F-Droid, but not F-Droid PE…

The PE is included with FP Open. You can’t really remove it (it will be back after the next upgrade).

Then how can I upgrade it?

Oh yeah I forgot about that.
Since it’s pre-installed you don’t have to update it yourself. It should regularly update with the OS. In F-Droid there is an option to ignore updates for certain apps. You should do that so you don’t constantly get the update available notification.

Thanks, it worked (partially). Updating FP Open OS worked (although the script that ran inside TWRP threw two errors “unknown command”) everything seems fine. F-Droid PE is now newer, but just one version (0.2.8, not 0.2.9)


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.