English

Process System not responding


#1

Hey all!

Had my Fairphone 2 a few years now, we’ve had our ups & downs but it’s still working.

Recently my Fairphone has developed a few problems that might be related.

Firstly, I started getting “Process System Not Responding” messages, but pressing “Ok” or “Wait” both kept the phone functional. I have been getting more similar messages from Apps recently too.

Then, the touch screen began not to work. Having hard reset the phone, it began to load the top bar, the bottom buttons but no OS. Hard reset the phone a few times, no improvement. I then took apart the phone, gave it a bit of a clean, and reassembled.

This worked, but since then, I’ve been getting more of the Process System Not Responding messages, and my phone isn’t holding any charge, and is very very slow to charge up (couple of % per hour).

Any ideas?
Many thanks,
Shaun


#2

Have you tried a factory reset (hard reset) and OS reinstallation? FPOS or other system? System version?