Process irq/288-wcd9xxx draining battery

I’m using a Fairphone 2 with fairphone open OS, under android 7, (build-number: fp2_sibon-userdebug 7.1.2 19.11.2 sibon-24df0be9), and my battery loses systematically 50% to 90% overnight, and after having tried all sorts of things to stop it, my brother checked in a terminal (using Termux) with the top command which processes were using the CPU. A process named irq/288-wcd9xxx uses 15-20% of the CPU permanently, which could explain why my battery simply dies in 12 hours. Here’s a screenshot of what I get.

As kill or kill -9 has absolutely no effect on it (it seems to work when running the command, but the process is still there afterwards), does anyone have any idea about what it is, and how to kill it, or stop it?
Thanks a lot!

I am no techie, so I did the one thing I could think of.
I entered that info into the search engine of my choice.
It is really interesting, how many results (dating back to 2012) that yields, all having in addition the words “battery drain”.
Unfortunately none of those results is labeled “problem solved” and all the tech-info is beyond me.


It’s hardware interrupts coming from the audio codec (the FP 2 has a WCD9320). Are you experiencing any audio issues?
If you have an opportunity to swap out the bottom module with one from another FP2 that might be worth a shot (I wouldn’t suggest buying a new one before testing this).


I never had any audio issues, apart from finding my loudspeaker wasn’t very loud during phone calls (compared to when listening music for example), which I didn’t consider abnormal.
I may have the opportunity to try swapping modules, but not before a few months. I guess I’ll have to be patient :slight_smile:

I actually tried with the help of my brother taking of the bottom, then the upper module of. It didn’t change anything. We also tried a few commands to try to control the usage of the battery (I actually posted also on Android Stackexchange here, everything is detailed). If taking the module away doesn’t work, would swapping really make any difference ? My brother believes it needs complete re-installation of the OS.

Probably not.

In case you haven’t found it yet, there’s a wiki page on the forum that might be useful for that:


Ok thanks @Johannes, I’ll do this, but only when everything else fails.

Just a question, there’s another process named irq/195-ngd_sli, do you know what it is? It seems to permanently use my CPU 5 to 7% as well (it’s in the screenshot), and I hadn’t noticed it, although it now appears as abnormal as the other one.

I don’t know. A quick search suggests it’s to do with slimbus, but I know next to nothing about what that does.

1 Like

If I understood well what I read about it, it may have a link with the transmission of digital audio. The process irq/195-ngd_sli might be linked with irq/288-wcd9xxx.

Hi again, coming back for the end of the story.
After a little time my FP2 stopped working, I had to send it for repair where they changed the core and the battery (and installed FPOS just in case). I still was losing ~40% overnight, even though I wasn’t using it and hadn’t installed any apps. It normally was as if brand new. I then installed LineageOS 17.1. I now lose ~25% overnight, which means around 1% every 20 minutes. I find this really a lot, but perhaps I am mistaken. I rooted my phone (with Magisk), I checked whether any process was draining battery as I had done before on FPOOS. None was, so it couldn’t be the same problem. I started using my phone again, installed apps, drowsed a few of those using battery (using Drowser), and it didn’t change anything, so I doubt it’s related with apps.
So I wanted to know, how much do you lose on your FP2 in idle (it’s an open question)? And is it normal for my battery to drain so much?

In my DP2 times i had an idle drain at under 1% per hour, while on mobile only slightly above. I’d you’re rooted, did you try BBS? Helped me a lot. Also, was the battery swapped? How old is it?

1 Like

Battery was swapped, so it’s brand new, though I suppose I could test with another one that’s brand new as well (I have one).
I don’t know what BBS is, I looked it up, but BBS can mean so many things :sweat_smile:

Sorry, i meant better battery stats :grin:

1 Like

Ok thanks. The thing is I don’t have the Google services (LineageOS), so I can’t buy it. But nevertheless thanks for the suggestion! Wouldn’t there be another app that does the same?

There’s no need to buy it. It works the same when you get it via xda, iirc.
Gsam should be good also, though i did not fully grasp it. But then, i was already on bbs

Ok thanks, I’ll try it out!

It could be draining due to reception problems of course. If the network is week your phone is using lots of energy to stay connected.
I guess you could check by changing to flight mode over night and measuring the battery drain for that condition.

(Edit: just corrected a typo.)


I tried putting it on flight mode for the night, but it unsurprisingly didn’t change anything.
I’m planning to install Boot Manager with the XPosed framework. My brother said it changed a lot for him on his FP2.

1 Like

I now lose ~25% overnight

I’m using LineageOS 17.1 on my FP2 too and I have a similarly high power drain. My setup uses approximately 35% battery overnight. I never had this issue back with LOS 14.1, using a similar setup in terms of installed Apps.

I have not further investigated this, but I suspect that the new LOS image probably does not use the sleep-modes of the device to the full extend. I think (hope), these are likely child-hood problems of the LOS 17.1 release, as it is quite new. I expect the performance to increase with upcoming versions and bugfixes.

If you do not want to wait for upcoming LOS updates and you haven’t tried yet, you might want to give some older LOS version a chance. The nightly builds for LOS16 are still available for the FP2:

Well, for me, even on FPOS I had the same problem, losing 40% overnight. So for me, I don’t think it’s a problem with LOS.
I may consider to try on LOS 16, but I don’t know if it’s going to make a big difference.
As they are so many other reasons for a battery drain, and it doesn’t seem to be LOS here, I think it must be something else. I’ll try to get out useful data from BBS I suppose.