Problems with the Fairphone 2


first off all I have to confess, that I really stand behind of the principle idea of the Fairphone… an can also accept some points that are not as good as or as fast as the latest model of the Samsung or apple or huwei armada…

but things like turnoff the mobile phone without switching on the light, making phonecalls without changing during the call to the flight modus, holding a stable network connection with a strong Wi-Fi, or the possibility to connect to your mac without troubles, that are preconditions for a normal mobile phone… I am sorry but i am really disappointed with the situation now…


I truly can understand your disappointment.
This sounds like you are on the latest FOS/FOOS Android7 or maybe LineageOS based on Android7.
Fairphone is working hard on fixing bugs atm. Until now there is no estimation when the most annoying bugs will be fixed.
Feel free to search the forum for other topics concerning related issues and if you are interested the #bugtracker.

Until now no changes, it is very annoying that during a regular call the system changes to the flight modus… in April it is one year, that I bought the fairphone 2, if there is no update I will change the device… unfortunatly


Does this happen when you hold the phone to your ear? If so, did you calibrate the proximity sensor already (Settings - Maintenance - Proximity sensor)?

Else …

1 Like

Did you already #contactsupport?
You know, that the device after 1 year still is within warranty.
And what you describe (switching to flightmode) really is not normal behaviour or even common for the Fairphone; judging from this forum that is.
And faulty devices are a common occurance with every brand.

That of course does not solve the other issues, but it might at least give you a phone you can use. :wink:


Thank you for that tip… i think it really helps a lot…


some problems (sensor calibration) solved
but still I cannot connect to my Apple PC? Even with extra software it is not possible any more (Wondershare…)


Did you try a search in the forum? …

yes I did, bu I cannot find a solution, i am using Sierra on the mac and after the update of the fairphore the file transfer is not working anymore (it worked before the update!!!)



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.