Problems with keyboard (touchscreen failure)

Hello everybody,

since two days, some keys on the keyboard of my fairphone (no matter if I use touchpal or the google keyboard) are very hard to use. They either do not react or just if I select them very precisely. With swype gestures (touchpal but also google keyboard), they don’t work at all, but rather stop the swype process and create, for example, three seperate random words. Those “defect” characters concern “o”, “k”, and sometimes “m”, “?” and “1”.

I was using cherry 1.6, then updated to kola nut 1.8, reinstalled google apps, took out the battery, but all didn’t solve the problem (those were kinda the solutions I found in other posts). Any ideas on what to do?

Thanks in advance

Sound like a hardware issue, rather than a keyboard issue.

Please do the following:

  1. Run this touch screen test.
  2. Make a photo of the test picture (like here.
  3. Post it here.

Thanks for the reply!

I tried to draw a straight line on the right side, and the result was the “squared” line. On the left side, one can see that the major part does not respond. Having followed exactly your instructions, Stefan, I can now, after having selected “reboot” as the last step, neither turn my phone on anymore nor get back into the factory mode. The only thing the phone does when I press the power button is show a black screen for half a second.

So hardware problem and contact the support?

Wow, it doesn’t even boot anymore? :frowning:

Yes, definitely a hardware issue!
Please let us know, if you could get a warranty ticket! :slight_smile:


just got same problem i think : a “dead zone” on keyboard

Support needed ?

Thanks for reply !


1 Like

Thats quick answer, thanks !

1 Like

Likewise, I’d been having trouble with my touchscreen. First it was registering ghost touches (which was alleviated when I changed my wallpaper from a moving wallpaper to a static one!). I did the touch screen test and found a “dead zone” in the bottom left-hand corner. Also, the back button is desensitized and one of the red boxes in the right-hand corner wouldn’t change colour. I’ve tried to upload the picture but I’m getting a message saying new users cannot upload attachments, so I guess you’ll have to take my word for it!

I presume this is a hardware issue, so if someone could let me know how to proceed from here that would be great!

Many thanks!

Ok. Same problem for me.
I ran the touchscreen test and I found two ghost zones on the two sides of the screen, just near the hedges.
I saw the exact same problem for an other user in this forum.
If you have any clue for solving that issue, I take it.

The link for the other user with same issues.

You should contact support.