English

Problem with Fairphone Open OS, Wifi and google

Hello there,

short backround first: I’m running a Pi-Hole in my homenetwork.
Today I added google.com to my blacklist.
After that my fairphone (with fairphone Open OS) didn’t connect to the internet anymore.
It connected to the wifi but nothing more…
When I unblock google.com again it connects to the internet.

Here’s what I think is happening: The fairphone wants to do a “do I have internet check” and contacts google. Since it is blocked it can’t reach google so it thinks there’s no internet available.
Is this an error? Because I thought when I install fairphone open OS I got myself a google free phone.
Is there a way to change the website the fairphone uses to test the connection?

Greets :slight_smile:

That’s works-as-designed standard Android behavior.
FairphoneOS is a standard Android OS.
If you want to avoid Google as much as possible and block google.com then install /e/OS.
Other alternatives from the #oslist might do as well but might also use the mentioned internet connection check (I’m not sure for those cases).

EDIT: found from your previous posts that you’re probably using Fairphone Open. In this case there’s no Google framework in the OS, but the code to check internet connection is still inherited from the Google sources. So it applies what I say regarding other alternatives from the #oslist above…

Might I ask for how long you’ve been using your FP2? You may apply for a FP2 badge… :wink:

2 Likes

Oh yes, and it is a wise idea to do that. The following commands sent via adb will do the job:

adb shell 'settings put global captive_portal_http_url "server"'
adb shell 'settings put global captive_portal_https_url "server"'
adb shell 'settings put global captive_portal_fallback_url "server"'
adb shell 'settings put global captive_portal_other_fallback_urls "server"'

Replace server above with any trustworthy server that returns a 204 HTTP-Response. I personally use captiveportal.kuketz.de, just as an example. If you have an own server, you can easily use that of course too.

With

adb shell 'settings get global captive_portal_https_url'

you can double check that the URL has changed. Information how to enable and use adb can be found here in the forum and in the www.

4 Likes

Hey Volker,
thanks for your reply.
I forgot to mention that I do run fairphone Open OS… edited it now.

I use my FP2 since almost exactly 2 years now. :slight_smile:

1 Like

dude, thank you so much! :slight_smile:

Congratulations! :+1:
But for a badge you’ll have to use it at least one year more. :wink:

I’ll get there :smiley:

1 Like

Welcome :wink:

Because I was curious I double checked my current settings and found out that these parameters are not set in /e/ by default (I set them on the original G00gle infected OS for my FP3, but obviously forgot to do that when I switched to /e/). Would be interesting to know which server is used by /e/ by default. Does anyone know?

Edit: Could only find this

private static final String DEFAULT_CAPTIVE_PORTAL_HTTP_URL =
        "http://204.ecloud.global";

in the code, but I am not sure if this used in the end since the code base is … erm, pretty big.

Hey Snafu,
I just installed a freshly /e/ on my wifes newly bought used FP2 and checked the CaptivePortal.
The command
adb shell 'settings get global captive_portal_https_url'

Prints out:
null

so I assume the did not set anything? But how is it able to check if it has internet then?

Sorry, saw this just now. I am not 100% sure, but I think they have a fallback hardcoded somewhere within the OS which is pointing to one of the /e/ servers (or at least not to Google). If you want to be sure, you have to sniff the outgoing traffic from that phone after connecting to a WiFi. :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.