Problem with Fairphone FP1 running Waze

I am trying to run Waze (a car navigation app) on my Fairphone and it does not work. The problem seems to be the GPS - the app thinks that the car is in a different street every few minutes, so it recalculates the route unnecessarily…

I run Cherry 1.6 on an FP1. I have tried various solutions offered on the forum to fix the GPS, but none works. Is there a definitive answer to fixing the GPS for running an app like Waze?


(Right now I find the phone unfair to those who buy it …)

Have you tried the “Fix Location Issue” of Gravity Box?
Links are at the very bottom of the GPS Guide


Hello @KostisS and welcome to the forums,

take a look at @paulakreuzer’s link which i used before to improve GPS accuracy.

Futhermore, i take part in Fairphones Software Beta Program and i am running an updated Version of the OS (1.8.X) that fixed GPS for me and did not require any manual interventions anymore. I think that update will be released soon and it might help you with your GPS problems.

I am sorry for that bad experience and hope you will able to get Waze working, but honestly this deficiency of the Fairphones GPS software has something to do with Fairness :-).


Have tried it and it did not work for me :(.

I just downloaded waze and will try it tomorrow to see if I can reproduce the problem. But I’m also running FPOS beta so…

1 Like

Ben, thank you for your email and your suggestions. I have just upgraded to Kola Nut 1.8. It did not solve the problem.

Regarding fairness, let me explain. I bought the phone because I subscribe to the ideal it promotes. However, I have been spending about circa 8h to get Waze working and testing while I drive. The phone costs approx. 250GBP, so one would expect that it would not have problems with the GPS. The fact that it has, it is unfair to those who buy it, as it does not provide the services other phones in that price can provide. Also, from what I’ve read, it seems to me that people do not really know what the problem is. Because, if the problem was known, it would have been solved generically, at the touch of a button, like most other phones, not by having to read pages and pages of documented speculation with no outcome. Also, there should have been a s/w test to check if the problem for a phone is h/w one.

When do you think version 1.8.X will be coming out? I will wait until it does and if the problem is not solved, I am considering selling the phone. I also believe it is important to communicate this to community, because in my view problems such as these undermine the effort in the eyes of the wider audience that are not necessarily hackers, but want to support the “movement”.

Sorry about the long message, but at this moment I feel cheated and still maintain that the phone is unfair at the s/w service layer. I remain to be convinced otherwise by a working GPS version :-).

1 Like

Thank you Paul. Please let me know if you can reproduce it. I am really keen to solve this, as it is a really frustrating problem…

@KostisS You are right, that is frustrating. Just to be sure, please go to Settings -> Location access and check your configuration. For me the following works well:
Access to my location - checked
GPS saellites: On
Wi-Fi & mobile network - checked.

Now tap GPS satellites to verify the GPS settings:
GPS EPO assistance - not checked/off
A-GPS - checked/on.

Now tap A-GPS settings:
Network request - checked
Profile selector - GOOGLE

I just tried Waze and it works very smoothly on my phone. The only time it didn’t show my correct position was when I was driving the wrong way down a one-way street (with my bike; wich is legal :wink: ).

Have you tried any other apps to navigate or track your position? Is it just Waze that doesn’t work for you?

@ben I changed all the settings as you suggested but it does not work :(. Any further ideas?

@paulakreuzer I am using only Waze.

Try another App to see if it happens there too.

@KostisS Just remove the micro USB cable when your GPS fix gets astray. It will then get the correct result in a matter of seconds.
I guess this is why @paulakreuzer did not have problems with his GPS navigation. He most probably had no USB cable plugged into his phone on a bike…
With this trick, you can even leave the GPS EPO assistance on.
Can people with no GPS problems confirm that they do or not have the micro USB cable plugged-in to see if this is consistent?


@DonatCallens this could be the solution! I forgot about that issue.

@KostisS I took Waze for a test drive yesterday as well and it worked really well. I used my bike and keep an eye on the location on the map which very well matched my real location. I did not have the USB cable connected. On my way back, i recorded my route with another app and you can see the positioning is really exact. I conclude there is no general usability issue with Waze and the Fairphone. Could you try if leaving out the USB cable improves your experience, as @DonatCallens suggested?

PS: Here my example route:

@KostisS If you have a problem when using a charging cable, it could be the charging cable itself.
A charging cable consists of 2 wires. Trying using a data cable for charging. A data cable has 4 wires.
For me and some others changing to a data cable did the trick. Now my GPS fix won’t get astray, when I’m driving and charging.

1 Like

I don’t want to open a flame nor go too deep into OT but your statement sounds like “I bought a t-shirt in organic cotton with natural tinting, why does it cost 30 GBP and I can’t have it in yellow-fluo coloring?” :wink:
I expect the GPS or other hardware components could HAVE problems because of the production numbers, the workers conditions and the hardware testing capabilities; I bought this phone BECAUSE I do expect production firms not to produce too much e-waste with components not falling in the highest quality range (think about the possibility to order a b-quality display with a discount instead of having it dropped in the trashcan…) and this is normal in a transparent way of sharing production processes, which no other company can (or want) give you at the moment :smile:

@DjDas Neither do I. But, what I am trying to stress with my message above is that if the services of the phone (in this case the GPS) do not work, then you limit the usefulness of the phone, so people won’t buy it again and as a result you will not have the envisaged impact on workers, e-waste etc ever. Do you see my point? Unless if this is the plan … which makes an even stronger case for the Apples and Samsungs of this world. :smile:

1 Like

@paulakreuzer So you want me to test another system Paul, even if I like Waze so much. Ok, I’ll cooperate. Do you have one to suggest that works well with FP?

@Lidwien Thank you for your answer. The problem is that I have the problem both with and without the cable. But more generally, why should running an app should be cable dependent? That beats me :unamused:.

@DonatCallens Thank you for your comment. See my answer @Lidwien. Why should navigation be dependent to the micro USB cable been plugged-in?