Problem with aurora store Fairphone Open OS

Hello !

Since a week I can’t update my apps with aurora store. It says that the apks are corrupts… I don’t know what to do.
And I don’t know why I haven’t the download button in F-droid for installing yalp store.

Are there some other trust apk store on the web ?

Thanks for the upcoming help !

Aurora Store updates working fine here on FPOpen.

Have you tried going to the Aurora Store side swipe menu > Downloads > Force clear all?

It may be that an update went wrong and it keeps trying to update your apps with partially downloaded APKs. If you perform the above action and then update, hopefully it’ll work.

If it doesn’t, make sure you’re not using the ‘Spoof’ option to emulate a device that supports app versions that Android 7.1.2 doesn’t.


I just tried and it work for me.

Sometimes, there are issues with the “tokenizer”, whatever that is. In that case go to the settings (the gear top right), then network and activate the 3rd item from the bottom, which might be called in English “Own account seeder”. The URL below will then be activated and that account is used as “tokenizer”. This helped me a couple of times in the past.

After using Aurora, don’t forget to sign-out. I think the numbers of log-ins is limited and there might be no auto-sign-out.

Preference should always be on free software, such as from F-Droid. But I also have to use some Guhgel Apps, even though most developers wrote me they were considering providing a download link on their web-page. For some reason, they never did.

By the way, Yalp does not work any more, nor the next generation of that. I think Guhgel inhibts their access.


Hello Guys !

Thank you for your answers and sorry I didn’t reply earlier but my week was full !

However I tried everything you said but the problem persists. I have even uninstall aurora and reinstall it but without solving the issue.

@robbert.f the spoof option is on fp2 so you think it’s ok ?

@DietmarP Yes I use f-droid the most but some apps just like firefox is not on f-droid ! Just the firefox klar that I don’t like much, and others apps.

Yalp store doesn’t work anymore as you said, so… I really don’t know what to do. No one knows a site of trus where we can find the apk ?

Thanks again for trying to help me.

There aren’t really any viable alternatives at the moment, and it isn’t recommended to download APKs off websites. In a pinch I’ve used but I don’t think anyone can guarantee they’re not sneaking in bad code.

Maybe try a fresh install of a new version of an app rather than an update?

  1. pick one of the apps that needs updating
  2. backup /data/app/<>/base.apk to a safe location
  3. uninstall the app
  4. install the app fresh from Aurora
  5. If that doesn’t work, you can reinstall the app from that base.apk that you backed up

Thanks for the help. I shame a little but I think all the problem is coming from my wifi connexion. It’s so very slow that it took 6 minutes to downloads 50% of firefox and then it stopped. I think that in add of the slowness there is also micro cuts of the connection all of the time. And I tried then with the phone network and it worked !

I’m french but I live in Bolivia since one month so I’m not used to the internet here and I don’t know how it works. But I don’t believe it was like that at the beginning. I will see with the internet provider.

Thanks again for your help !

1 Like

It’s always the things you don’t take into account, no worries. And I wish you well in Bolivia! That country’s really taken a turn for the better and I hope it’ll keep it up.

And while you’re there and if you feel like it, maybe you’d consider adding a picture to this thread:


Thank you ! We’re here with my wife and my two kids (11 and 9 ) for a year as volunteers. But there’s problem with the visas so we don’t know if we can stay the whole year.

I will participate right now !

Thanks again !


Firefox isn’t, but there is Fennec F-Droid which basically is Firefox with reduced trackers, and which works just fine!

I also had an issue once with an app that wouldn’t download because apk is corrupt.
Though in my case I had Shelter, and in the work profile it accepted to be downloaded just fine.

1 Like

My worries are back ! I’m still the one who have problems with aurora since two weeks or more ? “Failed to build api”… And it’s not the wifi this time !

In settings —> installation it it written aurora services unvailable. Then it tells me to click to go to the service repository and I arrive on gitlab but I don’t understand what I have to do or if I have to do something.

Did you update Aurora to the latest version? It was revamped a few weeks ago and the old version doesn’t work anymore.

Aurora services are something completely different which allow automatic installation of apps, a bit in the same way as the F-Droid privileged extension for F-Droid. Just keep the installation method as native and don’t mind.

1 Like

Is it an idea to de-install Aurora, reboot your phone and then go to/install F-Droid and install Aurora through the F-Droid app?


Thanks for your answers !
@Lidwien it could have been an idea, only at the moment to reinstall aurora store via f-droid it says that it doesn’t find the file and so can not download it ! :frowning:

Did you try to update the repositories of F-Droid? (on the main page just swipe down to refresh)

1 Like

Ok thanks ! I didn’t thought to updates the repositories. I could download and install it again but it refuses to connect to aurora store again !

1 Like

Ok I can confirm I can’t connect to Aurora either today, it is normal. See what is said in official Telegram channel:


Ok ! Thanks a lot for your help !

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.