English

Problem to flash a custom rom with GSI

Hi everyone,

Following this post to install LineageOS on my fp3, i have a problem:
line one (to flash custom OS), it says “waiting for a device”
But i ran twrp, and when I do “adb devices” i see my phone…
Anybody got this problem, or have a solution to it ?
Thanks you

Which step exactly of the guide you linked to or which command exactly gives you this trouble?

it’s at step 1 “fastboot flash system {my os}.img”
i tried “fastboot getvar -all”, same answer

And your phone is booted in Fastboot mode (aka bootloader, with Volume - pressed while starting or rebooting the phone) for this?

Yes, it’s boot in fastboot mode, and then in twrp

When you use fastboot to boot TWRP, then other fastboot commands will not work.
If TWRP is running, you are in recovery mode ( and could use adb, which wouldn’t work in fastboot mode)

1 Like

oh okay thank you! Now i’ve a problem when i type “fastboot getvar all”
, only slot a is in succes state. I tried the troubleshootings part:
i type “fastboot --set-active=a”
then “fastboot reboot =” then i wait til reboot in bootloader
then i type “fastboot --set-active=b”
then “fastboot reboot =” then i wait til reboot in bootloader

and when i type “fastboot getvar all”, it says that only slot b is active, and slot a & b are not in sucess mode

Only one slot can be active at any time. If you set B active, A will no longer be active.

yes i know but the tuto says that slot a and b has to be in “succes sate”

Did you do a full boot into (the stock) ROM as suggested by the guide? Your post suggests you’ve booted straight into bootloader instead.

After having forgotten my lockscreen password, i deleted some system files that should have unlocked it. The device booted normaly, and there was no password. But the launcher didn’t work…So i flashback stock rom as says in the topic, everything was alright. And after that i tried to flash custom rom, and in step one when i did “fastboot --set-active=a”, i could not do a full boot: the device stays wheeling at the little blue wheel…So i reboot in bootloader and did “fastboot --set-active=b”, and then reboot, but same thing. I format data, system and cache with TWRP. I tried to flash back stock rom but i always get on the wheeling blue wheel, indefinitly ^^

“fastboot getvar all” ="(bootloader) slot-success:b:Yes
(bootloader) slot-active:b:Yes
(bootloader) slot-unbootable:b:No
(bootloader) slot-retry-count:a:6
(bootloader) slot-success:a:Yes
(bootloader) slot-active:a:No"

Could you help me please ? just to flash back stock rom in a first time :ocean:

EDIT: I just saw that slot a and b are in sucess state. So I tried again to flash LOS16. Every step worked well. But at the end when i reboot it, after a while I get on the recovery mode that propose me to try again or factory data reset… I don’t understand !

And you’re not seeing a message about a reboot in 30 seconds before that happens?

Yes I do. it says that my device may be corrupt and will power off in 30 sec

Does the issue you describe then happen after you press power to continue booting, or does this happen after the phone shuts down by itself?

I’m not familiar with the whole procedure, apologies for perhaps asking irrelevant questions.

Also, I’m not sure which version of LineageOS actually works (17 doesn’t, 16 has multiple versions if I’m not mistaken) and whether it needs an overlay. You may want to ask in the topic you linked to in your original post.

it happen after i press the power button. It’s okay no problem ! :slight_smile:
Okay i’m goanna ask in it. thanks !