Problem of connexion to a mac


When I connect my fairphone to the Mac with a cable usb, the message: " connected as multimedia device " appears a few seconds, then disappears. Then the computer don’t find the fairphone but the battery is in charge.

To restart Fairphone changes it nothing.

Thank you for your help.


Do you have Android File Transfer installed on your Mac?

Media Device is the right setting but you can change it by swiping from the top of the screen downwards after the notification appeared. Tap the notification and you’ll have different connection options. But like I said Media Device is the right one for Mac.

Media device disappear, I can’t open it. Before it was working, I don’t understand why it dosen’t work now.
I have Adroïd File Transfer but I use Isync without any problem untill yersteday. This txo applications find the fairphone a few second but then it desappear and it’s not possible to work anymore.

Well that sounds like a loose connection. Can you try another cable?

I tried tree differents cables…

Just two ideas from my own experience:

  1. When you connect the USB cable to your Fairphone, do you keep a case on the Fairphone?
  2. Have you just done just small routine tasks/syncs through USB before the loss of the data connection or did you try to move really big amounts of data right before the disconnection happened?

I did’nt try to transfer anything, I lost de connexion before. And I don’t have a case when I connect de Fairphone.

For me connection only works when the phone is unlocked and the screen is on, which is why I leave the “Stay Awake” option (Settings > developer options) ticked at all times. But if connection worked for you before and you didn’t change that option or something about the screen lock that’s probably not the cause of your problem.