Problem installing TWRP on FP3: Partition table doesn't exist

Hi guys,
I’m a newbie trying to install TWRP on my FP3 (to sequentially install /e/OS), but I received the following error message:

“Remote: Partition table doesn’t exist.”

Before, I’ve successfully installed adb and flashboot and downloaded the twrp.img file from this website: []

Then I started the phone manually in fastboot mode (power key and vol + key) and ran these commands:
fastboot devices
fastboot flash recovery twrp.img

But then I received the above mentioned error message (sending ‘recovery’ worked). I was wondering whether I needed to somehow first install the “twrp-installer…zip” file from the twrp-website??

Since I’m new to fairphone (this is my first fairphone) and to the developer world, I’m afraid of braking it by just trying it out xD.

Sorry if this issue has already been discussed in another post, I searched my way through the forum and couldn’t find a helpful solution yet. If there is one, I’d be greatful if you could just send me a link. Otherwise I’m thankful for any solutions and/or step-by-step instructions. :sweat_smile:

Thanks a lot in advance! :slight_smile:

Do these topics answer your question?

1 Like

Hi Ingo,

thank you for the links! I’ve read them through before, but I wasn’t quite sure whether this would solve my problem. I don’t just want to boot TWRP, but install it. From the second link it looks like one needs to apply the installer first?! But how do I do this? The same way as the .img file (only then referring to the installer file instead of the .img file)?

Sorry if my questions are stupid, but since I’m very new to this (just learned about what OTA means :see_no_evil: ) I don’t understand much of it yet.

Cheers! :blush:

Install instructions are here …

In case it isn’t clear yet … installing TWRP instead of just booting it on the Fairphone 3 will break automatic OS updates in Fairphone OS, and there is no recommendable (let alone official) way yet to update manually.
If you just want to install TWRP because you are used to this setup from a different phone and want to have it the same way on the Fairphone 3, then really consider whether that reason would be worth the consequences.

1 Like

Ah, so I have to boot it first to be able to install it, is that correct? I thought it was either or (depending on whether I wanted to just boot or install it).

Thanks for the warning, I’m aware of that. But since I want to install /e/OS anyway, this shouldn’t bother me, no?



I don’t know.
/e/ gets OTA updates, too, and I don’t know whether the /e/ updater checks for altered partitions like the Fairphone OS updater does.
I haven’t seen anybody confirm or deny that it works this way with /e/ yet.

Be a hero and find out :wink: . (If it wasn’t established already somewhere and I just haven’t seen it.)

1 Like

So now I was running adb (command “adb”) and then “adb devices” to check whether it would recognise my phone. It did, but with the comment “unauthorized” next to it. I googled and found this page:

I followed the instructions, but after flashing fastboot and adb I wasn’t able to get access to the stock OS (android 9) anymore (it just wouldn’t go beyond the 4 blue moving dots since flashing). And now both adb and fastboot aren’t working anymore either.

I’m really afraid of breaking my phone since I have no idea what I’m doing and just have to trust instructions I find on the internet. But it just gets worse! HELP!!! :see_no_evil:

Is there a wonderful person who would give me live step-by-step instructions on how to install TWRP and /e/OS on my FP3 (maybe via Skype)?? I’m panicking and in despair. :anguished:

The adb command only works when Android or TWRP are booted.

The fastboot command only works in Fastboot Mode (aka bootloader).
To get the phone into Fastboot Mode, just start or reboot it while keeping Volume - pressed.
To force a reboot, just keep the power button pressed for about 15 seconds.

To get the stock OS running again, you can follow this guide …

Make sure the instructions you follow are not just any random site you get across.
Fairphone have official guides out there,
/e/ have their own instructions out there,
TWRP have their own instructions out there.

You could ask for assistance in this topic …

Or if you happen to have #fairphoneangels (<- see link for info) with a Fairphone 3 running /e/ in your vicinity, they might be able to help you out.

Oh, cool! Thanks a lot! I have asked for help in the forum and I’m lucky to have 4(!) fairphoneangels in my home town :)) - hopefully one of them will take the challenge and help me with this. :sweat_smile:

Fastboot seems to work, but when running the command “adb reboot bootloader” I get the error message “no devices/emulators found” which didn’t happen before I tried to reset adb. And yes, I have tried to apply fairphone, /e/ and TWRP instructions from their websites, but sadly none of them worked (they just say how simple it is and make me feel like the most stupid person on earth). That’s why I was googling for a solution to the error messages (and now got into more trouble^^).

I’ll better wait and hope someone will help me installing it per video or on site. Thanks again!!

Sorry, I hope I don’t annoy you too much, but I just managed to boot TWRP! Since I did not download the /e/OS zip-file onto my phone (only my Mac), I used the Terminal to unzip it and now it asks me whether I want to replace the ramdisk-recovery.img (options: yes, no, all, none, rename). These instructions ([]) don’t help here and I can’t find anything on the internet. Do you maybe have an idea what I should do? THANKS!!!

Fastboot and ADB don’t work at the same time.
As you said you can’t boot Android just now this would mean you could only use the adb command when TWRP is booted … but you don’t need ADB just to “adb reboot bootloader” anyway, this just reboots the phone into Fastboot Mode, and you can do that with the button combo given above, there’s no difference.
In TWRP you could use the Reboot menu to reboot into Fastboot Mode (it’s called Bootloader there).

… which is the correct way …

We’re missing some step(s) here, I think.
What exactly did you do after unzipping the file until you were given this prompt?

Do you have access to a Windows or Linux computer? Macs are not very wide-spread among the users here and time and again users stumble about some peculiarities of them when dealing with their Android phones.

Judging from my own experience, Windows is the most robust OS when dealing with ADB and Fastboot stuff, and for Linux there’s a very detailed guide with screenshots on how to install /e/ over at the /e/ forum … might be worth a read in any case …

That’s good, it means Fastboot Mode works :+1: .
But just in case … you don’t need TWRP to install /e/.
You install /e/ with the phone in Fastboot Mode.
One step at a time.

Hi “AnotherElk”,

Sorry for the late reply! Meanwhile I got helped by an awesome “Fairphone Angel” who was able to install /e/OS without problems using his Linux PC and the instructions you mentioned! I’m really happy!!! :heart_eyes: THANKS a lot!!!

To answer your questions:

I was trying to run ADB first (before booting fastboot) and it still wouldn’t work. But I hadn’t booted TWRP before, so this might have actually been the reason why it didn’t work. Thanks for the note that the button combo does the same job, now I get it. :grin:

The video on youtube showed how to install /e/OS using TWRP so I would have needed the zip-file on my phone, but the download folder (where I had copied it into before booting TWRP) did not appear after erasing everything except for the internal storage folder. Wonderous tech, will always stay a mircale to me…^^

I unzipped the folder using the terminal and then received the error message ‘cannot generate image for userdata’. Subsequently, I copy-pasted the commands shown in the instructions and received the prompt for every single command and after allowing all of them, it said ‘Waiting for device’ and nothing happened anymore. A guy from the e-foundation suggested to unzip the folder manually on my Mac and to then run the commands step by step instead. But then I received other error messages and finally gave up. :sweat_smile:

For other Mac users who might stumble upon the error message 'Couldn’t parse partition size ‘0x’ when trying to flash the boot.img : Since FP3 is an A/B device (as I have learned :sunglasses:), choosing partition a might help by using the command ‘fastboot flash boot_a boot.img’ instead of ‘fastboot flash boot boot.img’ But this has nothing to do with TWRP. You really don’t need that (I’m learning - slowly, but I am! :wink:).

Again, a BIG THANK YOU for your effort and help!!! :blush: