Problem installing OpenVPN (in FP2 Open OS)

Dear all,
I’ve been carefully migrating to my new FP2 (Open OS) following this forum & guidelines and now feel compelled to write here my first message (coolio!) coz I am a bit blocked when trying to use the OpenVPN: after installing it and importing my .ovpn from my VPN service I just cannot click on the “ok” of the pop-up confirmation message (see screenshot attached). The “ok” just doesn’t work, it seems like there might be some “basic” configuration issue on my new phone that doesn’t allow me to launch it. Any idea?
I’m an averge user, not really an expert but learning a lot in this forum. My FP2 is not rooted, but I’m not against the idea of doing it if needed. However in this case it changes nothing.
Thanks a lot for any tip! :slight_smile: I’m just lost!! :frowning:


This is caused by an app running which has the “draw over other apps” permission. The most commonly used app which does that is a night screen app.

The Android system blocks some buttons like “Install” when installing an app or this one because an user can be tricked to make some actions he doesn’t want to do by a malicious app with the “draw over other apps” permission.

To solve this, just stop the app that’s causing this, then add the VPN and then re-launch or turn on again the first one.


Bravo! @Roboe You are a genious!! :smiley: it has worked out!
Just in case it’s relevant for others:
1-How to see which apps are using “Draw over other apps” permission? Most simple permission apps show you just the permissions used by each app. You better need other type of more technical app (ex: “App Permission Watcher”) showing the whooole list of types of permissions, and there you will find the culprits! :smiley:
2-In my case the culprit app was “DataStats”
As @Roboe said all worked when: I stopped the culprit, tried again the OpenVPN (completing its installation) and then reactivated the “culprit”.
Bravo, community!! :smiley:


Oh, no, you’re wrong here; I just happen to tinker a lot with Android for several years. But of course this community is indeed awesome, :blush:

I’m glad you’ve solved it!

1 Like

Have to disagree, I’m pretty sure @Guzmanovich exactly nailed it!



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.