Problem Fairphone 5 internet connection

It’s one month I have Fairphone and I noted this issue: sometime internet connection seem not working, or very slow. I mean internet page never reload, on I can’t send/receive messages with whatsapp or telegram or email.
Normal calls work.
This happened 2-3 times in a month, to solve this I rebooted the phone and magically internet restart.
I noted that this happens regardless of wifi or sim.

Has this ever happened to anyone?

Same Problem here. I thought i am the only one since my gf hast No probs at all.

What provider in which country? 5G enabled/disabled? What is shown 4G,E as connection when slow? Have you checked the APN?

Germany, and it doesnt matter if it is mobile traffic or wlan. The Problem comes both ways.

Btw what ist the APN you mentioned?

Under settings-network-SIM card without or with incorrect no mobile data

1 Like

Hello Everyone

Living in France, had my FF5 for two months now and started to experience this issue last month. I have now to reboot pretty much three to five times a week to recover internet access.
4G or WiFi doesn’t change anything.

No solution found.

Have any of you tried just turning off both Internet connection services and then turning ONE of them on at a time?

This can be done using the swipe-down quick settings panel.

I got the same error here I have to reboot at least once a day other devices do not have issues on the network I can ping using termux on my phone to localhost and my own IP but If I try to do it to other devices on the network it fails, meaning the issue is on the software if I reboot the problem goes away

Did anyone find a solution? I have the same issue with both 4G or WiFi and have to reboot constantly.

Has anyone who experiences this problem actually reported it to official FP support? If no-one does that, then it won’t get fixed. FP do not read the forum unless a particular thread is pointed out.

My 2 cents worth: this might be a software error that occurs when the phone automatically switches between mobile data and Wi-Fi.
Personally I never leave both on at the same time. I turn on one or the other as and when needed, and both off when I don’t need them. Try that and see if that helps. Please report back whether it does or not, since that would contribute to getting the bug fixed.

1 Like

As oposit info to OldRoutard, my FP5 also not have this problem, but
I always have enabled 4G/5G + Wifi, and in Developers settins/Networking:

  • “Wi-Fi scan throttling” = ON (i think, this default)
  • “Wi-Fi not-persistent MAC randomization” = OFF (i think, default is ON)
  • “Mobile data always active” = OFF (i think, default is ON)

Some other info:

  • primary with enabled “Wi-Fi calling”, but sometime disable it
  • don’t connect to public wifi
  • in home have 2x wifi (OpenWRT) router, both with different SSID, without 802.11r

Newer see reboot when auto or manual switch between both wifi and mobile data