Problem - eSIM stopped working

Hello,

I have a FP4 with LineageOS since 14 months, and since this morning I can not make any phone calls or send SMS. It worked yesterday.

I get a message on the lock-screen “No SIM card”, which I did not get before.

The network strength indicator has a ! to indicate no connection to the base station.

My wife’s phone has strength 4/5, and we have the same subscription/provider (Hallon/Tre in Sweden).

I have tried the following:

  • Reset Network Settings
  • Reinstall eSIM
  • Reboot (5x)
  • Open up and remove old (no longer used) physical sim-card

Still same problem “Calls and SMS Temporarily unvailable” and no mobile data.

Last week this happened once, and it went away after a reboot.

What do you suggest?
Is there any way that I can see if the telephone/modem module is broken?

Kind regards,
Göran

Hello Forum,
I have now tried with different physical sim cards. No sim card works.
I get no calls, no SMS, no mobile data.
WIFI works fine.

I guess hardware failure.

Which replacement part do I need to switch out, to get my phone working again?

Kind regards,
Goran

Dont you have warranty?

You should really try to settle this under warranty. That should be absolutely no problem after only 14 months, if I understand you correctly.
Your problem is probably with the mainboard/“core module” which is the most expensive piece in the phone and also not regularly sold as a spare part.