English

Powerbutton not working

hi, it’s been a few days since my powerbuttom decided to suddenly not work anymore. I don’t know what to do. I tried to take off the battery then I put it right in and now my phone is switch off (since my powerbuttom isn’t working). Does someone know what the problem is?

Have you tried to press the button with the case taken off?
This can be a little tricky without the plastic button part of the case, but it can be done to test whether the problem actually is the plastic part in the case you normally press or the “real” button part on the core module.

1 Like

yes, I’ve already tried that. before and after taking off the battery and it doesn’t work.

Can you charge the battery? Does the display show anything when you do so? Does the LED light up?

1 Like

yes, I can charge the battery. The display shows the battery percent (it is 100%) and the green LED lights up but the phone won’t switch on.

1 Like

I think it’s clear you need to contact Fairphone Support about this:

https://support.fairphone.com/hc/en-us/requests/new

2 Likes

thank you anyway :slight_smile:

1 Like

Charge it to the full, couple of hours, then try to hold the power button for a minute or so. Happened to me a couple of times long time ago, I think it was HTC and Motorola. Basically what I did was connecting-disconnecting the charger and holding-releasing the power button. Try to press the power button with the volume key up, then down. I know it’s weird and unintuitive but it worked for me.

1 Like