English

Possible bug found in 19.11.2 concerning the USB port and MTS file transfer

During transferring of several photos I ran into the following issue: Since the 19.11.2 update, MTS file transfer seems to be not longer working.

The following behaviour occurs:

  • Only charging from a regular charger power supply works
  • Connected on a PC, the charger symbol does not appear and therefore also not the USB option notification appears when plug in
  • Only when I reboot the Fairphone while plugged in on the PC, charging at least works. Data option does not appear for selecting MTS.
  • When plug out and plug in again (relevant on PC only), charging does not come back (until I reboot again)

Important note: I tested several USB cables (several ones which worked flawlessly with the previous Fairphone OS release) as well as PCs to exclude a hardware defect on the USB cable or PC’s USB port.

Fairphone hardware release is from April 2016.

Thanks for any feedback if someone can confirm the same issue.

2 Likes

Does the computer detect the device normally? If it doesn’t, the bottom module might be defective or have a poor connection to the core module. The latter can sometimes be fixed by removing the module, cleaning the contacts, and reassembling.
Charging takes two lines on USB, data and advanced charging modes take four. It’s possible to have defects that break data transfer but leave charging intact to some degree.

1 Like

I am also having problems with the USB port: my FP2 (fairphone open 19.11.2) is not recognized by my computer anymore: the phone does not offer me the connect options anymore and Windows only recognizes an unknown device. Charging works all the time though. I tried tons of things already, all without any success:

  • toggeling the developer mode on and activating USB debugging mode
  • deleting the cache for the apps “External Storage” and “Media Storage”
  • trying out all settings in ‘developer options’ -> ‘USB-Konfiguration auswählen’
  • running the Phone in Safe mode
  • resetting the OS (Power On + Volume Up -> ‘Wipe data/ factory reset’
  • I swapped the USB module with a friends Fairphone (same OS and same OS Version! His Phone is only 2 years old): my USB module works with his phone, his USB module does not work with my phone --> my USB modul is technically ok!
  • making sure the USB cable is fine: with the same USB cable my friends Fairphone gets a normal connect to a Win10 Computer. With the same cable I do not get a connect to the same computer (also checked with swapped USB modules).
  • installing ADB drivers in Win10
  • I tried on 3 different Win10 computers
  • Setting up FastBoot (Power on + Volume down) -> device is not detected by Win10, same results like connecting with Open Fairphone OS running
  • with the Fairphone connected, I let windows try to find a suitable driver -> windows does not find a suitable driver
  • I disassembled the whole phone, cleaned all contacts with isopropyl alcohol and assembled everything again

The FP support sais that it could be a defect on the core module but I cannot buy a 200€ replacement just to give it a shot… Also I cannot downgrade to another OS version with a broken USB port to change the OS and see if that has any effect :confused:

So I am hoping it may be a software problem that could get fixed with an update in the future…

1 Like

Same issue for me, and I’ve also tried lot of things, without success. I’m still investigating. Did you also notice a difference between the internal memory space left and the total size of your files? I am wondering if this bug could be related to a partition problem…