English

Porting LineageOS to FP2

lineageos
Tags: #<Tag:0x00007fefc85ef618>

#209

Can you tell me which provider you are using?

The LineageOS build is not using the apns-conf.xml provided by Fairphone (Ubuntu and Sailfish do). I think the best way to fix this is upstream, so all LineageOS users will benefit from it.


#210

Yes, please give more details on provider and which settings were wrong.

Chris


#211

it might be an LineageOS bug but I’m not sure so I put it here.
I’ve installed recently some tile apps what added a plenty of new tiles options. When I try to drag one of the tiles into the area of the active tiles and the area of the recently used tiles is not visible, dragging is aborted as soon as you enter the area for recently used tiles.


#212

My provider is Telfort, from the Netherlands.

When resetting to default, which resulted in very poor internet connection, the APN settings are set like this:

  • Name: Telfort Mobiel Internet
  • APN: internet
  • Proxy: 193.113.200.195
  • Port: 8080
  • MMSC: http://mms
  • MMS proxy: 193.113.200.195
  • MMS Port: 8080
  • MCC: 204
  • MNC: 12
  • Authentication type: PAP
  • APN type: default,supl,mms
  • APN Protocol: IPv4
  • APN roaming protocol: IPv4
  • Bearer: Unspecified
  • MVNO type: None

While I now have it manually set to these (Excluded the values that remained the same):

  • Name: Telfort
  • APN: internet
  • Proxy: Not set
  • Port: Not set
  • MMSC: Not set
  • MMS proxy: Not set
  • MMS Port: Not set
  • APN type: default

#213

Makes sense to remove the proxy, but the MMSC / MMS proxy / MMS port should have no impact on your internet connection. If you remove these settings you won’t be able to send MMS messages anymore.


#214

Can you try just removing the proxy and testing if it works?


#215

You were correct, only removing the first proxy/port combination was sufficient. Thanks for the input.


#216

Can you try sending an MMS to see if it works if it doesn’t cost you too much?

Btw I’ve created a change request on the Lineage Gerrit: https://review.lineageos.org/187588


#217

I just tried the USB-OTG feature (with a male USB to male micro USB adapter) and it worked great. I can read from a USB stick with a FAT filesystem (not from an external HDD, though) and from another Android phone (!) through MTP, :slight_smile:


#218

Is it are FP 2 LineageOS bug?


#219

I am not even sure whether MMS is supported anymore with my provider… No mention of it anywhere on their website afaik.


#220

As per July 1th 2017 Telfort stopped MMS. telfort nieuws einde mms.


#221

I have issues with Dual SIM as well:
Everything is working fine with one SIM card in Slot 1.
When there is only one card in Slot 2, PIN entry won’t happen at boot and no connection to mobile network will establish.

When both slots are used, the issue seems to originate in mobile data on Slot 2. As soon as I select SIM 2 for mobile data, both mobile network connections are lost. Upon reboot, both PIN requests are skipped and there will be no mobile connection whatsoever. Changing back to Slot 1 for mobile data and rebooting again fixes things.

So basically: Mobile data from SIM slot 2 breaks mobile connection as a whole.

This is on self-built (but not customized) LOS 14.1-20170805. Building right now to see if the problem still exists.


#222

When setting mobile data to SIM 2, you first have to set the SIM 1 to 2G.
Only one SIM can have a 3/4G setting.


#223

I would expect this to be adjusted automatically or at least have some notification and not just break.


#224

I don’t think this has to do with the issue that the connection is lost. It should work (not lose the connection) regardless which SIM card is in 3G/4G mode.


#225

I have experienced the same behavior last month


#226

BUG TRACKER :worried:

how about setting up bug reporting system such as Mantis Bug Tracker?
I afraid that some reported bugs are getting lost here.


#227

@snevas just pinged me about this and I made the project in bugtracker.fairphone.com. Snevas will modify it a bit and open it up later. Thnx for the idea.


#228

Because people can kind of localize you with BLE beacons.