English

Porting LineageOS to FP2

lineageos
Tags: #<Tag:0x00007fefbd766150>

#189

After a few days of testing, I notice that LineageOS has significant trouble on my phone with Mobile data. I have the modem version as is mentioned in the post I reply to, so I think the modem files are up to date. My Lineage version is of 3 august, so that’s up to date as well.

Messaging and mails in general work, but anything more bandwith heavy (even simple web browsing) just refuses to load (not slow but time-outs and ‘no network’ errors). Also my VPN (TCP connection) is unable to connect under mobile data, while it works fine with Wifi. Under FPOOS my vpn never had any issue connecting to mobile networks.
Btw, the icon in the status bar sometimes has a small X, but other times just shows a healthy graph with LTE above it while the symptoms appear (No X or other additions). So this doesn’t seem to reliably indicate that there is an issue. I also tried turning airplane mode on and off. Sometimes it works a bit, but does not solve the issue completely.

Anybody knows something I can try to debug this? Is anyone else having this much trouble with mobile data?


#190

Untrusted apps are not getting any additional SELinux privileges. That’s what SELinux is about.

Chris


#191

Hi,

the fingerprint should from time to time being updated to the latest FP version that Fairphone has officially released including android CTS tests passing. As far as I know, some apps on playstore test this.

Chris


#192

You should rather discuss this with the lineage community. There wont be any fairphone specific enhancements.

Chris


#193

Well, i wouldn’t restrict it to untrusted apps. SELinux is about controlling all accesses. But i guess this is no point of argument. I just question the access denial to /, which on one hand isn’t reflected by file system permissions, and for good reason, because that’s what / is all about in Unix in the first place, and denying read access does not offer any security pluses.
Besides, but this may just be my problem, i don’t know what’s all put into the untrusted apps domain. It looks like all apps installed by the user land there… Most of the time you don’t see this, but with a file manager and a terminal it’s obvious. Re file manager: it’s quite annoying not being able to walk the tree just because you aren’t allowed to start at /. Breaks expected behavior. In every (SELinux enabled system everybody may read /, because that’s the way the unit file system works)


#194

Thanks. This was one of my questions


#195

I noticed two random reboots in the last days (14.1-20170807-UNOFFICIAL-FP2). I had this already with the Fairphone Open version. Had anyone here? Whether that is possibly related to the properitäre firmware (blobs)?


#196

Can you get the /proc/last_kmsg file after a random reboot and post it here?

Chris


#197

I’ll make it the next time.


#198

FP2:/ # cat /proc/last_kmsg
[…]
5NwanD: Unknown sxmbol aDdress c01028c0
unw)nd: Index not fkund c01028c0
COde: 00000000 00000000 00000000 00000000 (00000000)
—[ end trace da227214a82495a8 ]—
Kernel panic - not syncing: Fatal exception in hnterrupt
CU2: stoppijg
[] (unwifd_backtrace+0x0/0x!38) froi [,c010dab> (handhe_IPI+0x044/0X248)
[] (handle[IPI+0x144/0x248) from [<c0102914<] (gic_handle_irq+0xec/0824)
unwinD: Unknmwn symbOd a`dress c010914
unwild: INd%x foT found c01 2914
SMP: failed to st/p secondary CPUs
wcj3s cra3h shutdown 0
Rebkotin’ in 4 seconds…
SMP: failed to stop sebondary CPQr
Going douf for restart no7
Calling CCM to disable SPMI PC arbiter
2729 Corrected bytes, 420 unrecoverable blocks
FP2:/ $

Looks like kernel panic. If you need a full kmsg, let me know.


#199

Yes, please upload always full one.

Chris


#200

Here it is: https://gist.github.com/anonymous/b59771715d5eda972bb0ccd0ac0eeb36


#201

My FP2 (14.1-20170807-UNOFFICIAL-FP2) had one more random reboot today morning: last_kmsg

This one was 2 days ago: last_kmsg

This message is present in the last_kmsg of this morning and the one from 2 days ago:

synaptics_rmi4_sensor_report: spontaneous reset detected


#202

Battery low indicator led does not work on my FP2 (14.1-20170815-UNOFFICIAL-FP2). Does anyone know if this is a fairphone open os feature? Or is it a bug at LineageOS?


#203

I think I see them as well. Random reboots without any details in last_kmsg. Hmmmm. No idea for now.

Chris


#204

I have updated the modem.zip file to the latest modem firmware of Fairphone OS 17.08.1. This zip file also includes the official Fairphone splash image. In case you have installed a custom splash image, you might want to reflash it.

:file_folder: Download: modem-17.08.1.zip
:bookmark_tabs: SHA256: 3f9ac2aa8968f7249780573f9f05ba4c488537c910e4ae2cd8ccd792d49e7f01

After you have flashed the zip file, you should see the version 4436.1-FP2-0-05 under Settings -> About Phone -> Baseband Version.

Since those are binary blobs, I have no idea what has changed since the previous release. But comparing the image files, I can see that the following files were changed:

NON-HLOS.bin
rpm.mbn
sbl1.mbn
tz.mbn

The following files were not changed since previous release:

splash.img
emmc_appsboot.mbn
sdi.mbn

Alternatively, you can flash the latest modem firmware using fastboot. You can get the firmware images from the official Fairphone OS downloads page (scroll down to binary images). Don’t flash system.img, boot.img and recovery.img obviously.


LineageOS 14.1 with OTA updates for FP2
#205

Thanks for the latest modem updates.

I was hoping it would fix or alleviate my data issues with LineageOS. It doesn’t, so there is something else causing it. I am now considering going back to FPOOS due to this issue (with a reflash of LineageOS, just to check if that helps).
Any other components that may interfere with this? Can it be due to a mobile network incompatibility (LTE vs 4G?)

Small summary of the issue: The phone takes ages to load a web page and even time-outs frequently while loading them. It feels like it has barely any bandwith, even though it mentions LTE in the status bar.


#206

It would be interessting to know if it works as desired when you switch back to Fairphone Open OS. I don’t really know why you have such problems and I don’t think it is related to the modem firmware, since the same firmware is used on Fairphone OS and Fairphone Open OS as well.

Have you tried doing a factory reset? Can you confirm that your APN settings are correct and according to the ones your provider has specified?


#207

I first had to look what APN actually was, and then the settings for my provider. It appears you were correct, the APN settings were wrong.
Essentially it had set proxies, which hampered the connection.

Since I have never actually set these connections, I am wondering where this (faulty) setup comes from. Is it a LineageOS thing to setup the details or does it come from the network operator/sim card?
I have tried multiple roms (e.g. Ubuntu Touch, Sailfish) and I never had to change these APN settings.


#208

Great that you found the solution for your problem.

Since I have never actually set these connections, I am wondering where this (faulty) setup comes from. Is it a LineageOS thing to setup the details or does it come from the network operator/sim card?

I haven’t looked into why this happens on LineageOS, but a first guess would be that in the current LineageOS builds the apns-conf.xml, which holds all the APN default settings, is not included. I’ll try to figure this out, if I have some spare time on the weekend.