Poll + general discussion: who got Android 10 Update on their FP3 & first impressions

I’m also on VF. I had to do as others have suggested. Use a 2nd sim from another carrier (O2) and make the date live on that Sim. That’s the only way I could trigger the update.

My two sims are xs4all/kpn (sim1) and vodafone (sim2). I have tried every possibility:

  • both in
  • xs4all in sim1 & empty sim2
  • xs4all in sim2 & empty sim1
  • vodafone in sim1 & empty sim2
  • vodafone in sim2 & empty sim1
  • wifi only with empty sims

Nothing could trigger the update.
Solution is to wait? Or is another trick available?
Sincerely, Kees

Did you switch on 3G/4G mobile data on the xs4all sim? The update will still download over wifi, but setting a 3G/4G connection seems to be the only way to make that SIM the primary SIM (which determines how the update is requested). You may not even need to disconnect from wifi or actually use any data. Remember to switch back after you start downloading the update.
If it didn’t/doesn’t show, there could be delays with KPN approval as well (there were at some point in the past, haven’t heard about it recently), or the update could be on hold / going through phased release. Make sure to check for updates using the settings menu instead of waiting for a notification (though I’m assuming you’ve done this).

1 Like

Just put in another (non-Vodafone) SIM to download the update.

1 Like

Alternative is to buy a cheap T-Mobile SIM only (can be from MVNO just make sure it isn’t Vodafone, and I think KPN doesn’t work either at least Xs4all does not). I did back when the issue existed on Android 9, and it cost me 10 EUR.

Got the update 2 days ago and so far it seems to work OK(-ish).

Only one issue I have had so far: The notifications in sleep don’t seem to work properly anymore. I mean the ones where the display would stay black for the most part and just show the text in the middle of the screen. It still turns on, but it only shows the lock symbol at the top, not the actual notification.

Yeah it seems to be a bug. It shows a lock but not the notification text.

1 Like

I think it’s a bit soon to conclude it’s not coming at all via Vodafone and the modules are apparently delayed so I don’t need the upgrade right now. Also I still don’t like the idea of paying money for a sim card just to get an update I should get anyway and I’m not a fan of people kind of carelessly suggesting I spend money.


I totally agree! This is not a solution, it’s ridiculous! If there’s a problem between the manufacturer of my phone and my carrier, it’s not my responsibility. They have to solve it, and they should solve it soon. I am a customer of both of them, and none of them told me that it might be problematic to use them together.
Besides that, I still suppose that Vodafone just refuses to distribute a buggy update…


Hello I got the update Yesterday. Seems fine so far

Are you on Vodafone?

I got the update a couple of days ago. Two bugs I’ve been experiencing are the camera app issue where it often doesn’t take the picture and crashes and also the phone restarts itself on its own often.

Hello I’m in Italy, on Iliad

1 Like

I just put in an old, expired (non-Vodafone) SIM card, and I’m able to upgrade to Android 10 now. My new camera modules arrived today, so I didn’t want to wait any longer…


Hi mgkoeln,
I have same problem with resound. I’m afraid
direkt audio streaming ist missing, witch ist necessary as well.
ASHA (Audio Streaming for Hearing Aids) is the protocol witch ist part of google - but has fairphone implemented it in Android 10?
I need an english brush up, but I hope you understand my execution.
Best Ruth

Now available on Vodafone (Germany). I’m downloading version 3.A.00045. Fingers crossed…

Edit: 8 hours later, no problems so far. VoWiFi works too now, finally!


UK, Three network, got update this week, absolutely shocking performance since. No sound on calls issue and 10+ reboots a day. Significantly affecting my work, no response from Fairphone. @formerFP.Com.Manager has FP made any statements about these widespread issues?

@Aisling_Roche Please contact FP support. They do not read this, and they can only fix what they know.

Since she posted, that there is no response from Fairphone, my guess would be, that she already informed support.

What version did you install?
There was a new update version quite recently, that - at least for some users - seems to have worked. See the posting above yours and check, if there is a new update available for you as well (if you don’t do so already all the time).
The support page on how to update states:

Fairphone OS version 8901.3.A. 0045 is the latest operating system for your Fairphone 3/Fairphone 3+ (FP3/FP3+), available for the open market, released on September 15, 2020. It is based on Android 10.

I keep my fingers crossed for a fast solution for you.
The fact, that the update was not available for a while shows, that they are aware of the troubles and are working frantically to get the troubles solved.


@HMZ Hi I contacted them through several channels, I’m aware of the existence of customer support. FP did not respond, as it said in my original post.

@BertG Unfortunately the latest security patch did not improve the situation, if anything the reboots are occuring with increasing frequency

1 Like