Pickup incoming call on locked phone

Contacts and phone. Interestingly it also had the “Zonder geluid weergeven” switched on but it sill gives an normal ring tone…

EDIT btw the telefone app is set as the telefone app

I’m a bit lost as to where which settings are exactly on Android 7 - as said there may be an other menu for notifications that allows app-level control. If that also doesn’t work, a factory reset might also work - but make sure you have all your data backed up (including e.g. SMS) so you can restore what you need later.
The reason for thinking permissions issues is that this issue was relatively common on Android 6, where it definitely was a permissions issue. Unfortunately, Android 7 seems to handle notification permissions differently, which means I’m lost as to where to find the relevant setting.

1 Like

Maybe this helps you:

and the solution:
…This was a good opportinity to clean the phone from inside, now the calling screen is working again, at least for the moment.

Maybe the proxyimity was too full of dust, and the software could not handle the situation and behaved idiotic, …

Picking up a call is working again since then

2 Likes

No, the screen does not stay black when it is unlocked, The screen on whatever it was on. I expect the phone screen to move to anser or reject the call (e.g. the green and red button)

I reset the phone to factory reset. Still the screen does not go on when a call is coming in.

The FP2 does not show a screen on incoming call.

Reset the FP2. Not helping

I am having the same or similar problem on my FP3+. When the screen is off and I receive an incoming call, the screen goes on and briefly shows the expected white screen with the red and green buttons.

However, before that phone screen is even done showing itself, it is pushed out by the lock screen. On the lock screen, there is (1) a notification about an incoming call and (2) a subtle text below the notifications saying “Back to call” (in Dutch)

It seems like the phone app and the lock screen are competing to show on screen, and the lock screen wins.

Interestingly, when the phone is already showing lock screen at the moment the call comes in, then everything is peachy: the white phone app screen pops up and I can accept the call.

I’ve given the phone app every possible permission, I’ve disabled Android Accessibility Suite just in case: nothing matters.

It doesn’t matter if I allow lock screen to show notifications fully or only nonsensitive content, or not at all: lock screen still kicks out the incoming call screen.

I’ve given the phone app access to Do Not Disturb in case that might interfere. Makes no difference. same goes for allowing Android Adaptive Notifications on or off.

What should I do…?

If I disable the phone app setting for “Show on screen”, then an incoming call only triggers the screen to turn on and show the lock screen.

EDIT 1: It gets even stranger. I’ve completely disabled the lock screen (so no pin code, no fingerprint, nothing) to see what is and isn’t caused by the lock screen.

Now, when I receive a call while screen is off, the screen will come on. The white fullscreen phone call view will briefly show. Then, it will pop down out of the screen within less than a second. The home screen will remain on (and unlocked).

So it appears that it’s not the lock screen that is pushing the phone app out. The phone app either changes its mind about coming on screen, or it is blocked (with delay) by some other process or app.

Getting weirder and weirder.

EDIT 2: undoing all updates for phone app had no effect. Same difference.

Did you check the behavior running in #dic:safemode to see if it’s an installed app causing this?

3 Likes

Thanks Volker, in safe mode the problem is not there. This helped me figure out that the cause was silly me:

I had MacroDroid automatically show the launcher (i.e. close any open app) whenever screen comes on. The point is to make sure I don’t get distracted by whatever app I was previously using before I closed the screen. Anyhow.

Somehow that didn’t interfere with incoming calls on my previous Fairphone.

Fixed it so that MacroDroid only does this thing when phone is not in call / ringing.

3 Likes

So I understand that replying to a call is not possible on a locked FP2. That is awkward.

And not the case in general.
Was working for me with Fairphone Open OS, LineageOS, LineageOS for microG, and is now working for me with /e/.

If the issue is somewhere on the OS side, a factory reset will not help, as it only deletes user data and Apps and leaves the OS untouched.

1 Like

@ Volker: can you explain a bit more about this please? My FP2 (2 yr, 1 month old) has the same issues, namely that I cannot answer the phone because of the lock, it is stupid and a bit embarrassing to have to call back because “I was too late to pick up the phone”.
What is “safemode”?
Thank you for explaining!

If you want to increase your chances being seen when addressing a particular user, either reply to their post and not somebody else’s, or proof-read whether you got the reference right … it’s @Volker :wink: .

#dic:safemode <- is a link to an explanation.

1 Like

I tried the link, there is nothing there.

There are no more dic:safemode topics.

That’s odd, for me it leads here, does this work? …

If not, here’s what it says …

Safe Mode

Not to be confused with #dic:recoverymode

Safe Mode let’s you boot up your phone without any third party apps. Sometimes you might end up in Safe Mode automatically but you can also do it manually to check weather an issue you are having is software related.

Note: On FP1 the popup doesn’t say you’ll reboot into safe mode, it only says “reboot”.

Another option to get to safe mode is to power off your device and while powering on again hold down volume up and volume down until the phone has finished booting.

You know you are in Safe Mode if the words “Safe Mode” are written in the bottom left corner of the screen.

:warning: In some cases accounts get lost after safe mode. If you are rooted, back up your accounts with #titaniumbackup.

3 Likes

Maybe you’ve missed the red marked entry?

That’s again a link and it leads to the information pasted above by @AnotherElk

3 Likes

Thank you, I did not know I had to click on the red warning! A bit confusing for me, but thank you and also to Another Elk.

Yes I can. I a call comes in the screen stays black I cannot answer the call