PhotoSphere on Fairphone not available?

Hi everyone,

I’ve been wondering ever since why the PhotoSphere feature is not available on the FairPhone. According to the internet, it should be available in Android 4.2 by default, but I can’t find it anywhere in the default camera app.
I also tried to download the AOSP camera2 from F-Droid (backported 4.4 camera), but PhotoSphere isn’t in the list of camera modes either.

I found a thread where someone stated that the phone ought to have a gyroscope and 1GB of RAM for the PhotoSphere feature to work - which definitely applies to the Fairphone.

Still, no PhotoSphere anywhere. Does anyone have any hint about this?


I don’t believe Photosphere was included until android v4.3 or 4.4, so the stock camera on 4.2.2 doesn’t have it. The google camera app currently isn’t available for android 4.2.2 (which the FP is running) and this does include it.

The only way currently would be to use an unofficial version of the camera app (such as this), or use a replacement camera app.

Hey Chris,

thanks for your reply, but I believe you’re mistaken about the Android version including the feature. If I do a quick Google search for PhotoSphere, all articles state that it’s available since Android 4.2, for example

I found some people stating that, with 4.2, PhotoSphere might have been only available on Nexus devices by default, but this was quite a while ago, so this is why I assume that this could actually be included in FP’s Android.

I also understand that not only the camera app, but also the gallery (and some system files) need to be compliant with PhotoSphere, so this might be the reason why it’s not available even in the AOSP KitKat (4.4) Camera App which I already tried.

Any more ideas about this?


PhotoSphere, to my knowledge, is not included in Android if you do not install the Google Apps. It uses proprietary software by Google. While Google states it is “include in Android 4.2” this only applies if your Phone comes with Google Apps, even for releases 4.3, 4.4 and later.

Sadly, Mediatek, the supplier of Fairphones Chipset modified the Camera App (notice the modified interface), so the Camera App of the Fairphone is not truly the Stock Camera App. You can get a stock camera app on F-Droid and notice the difference in settings, ui and features. For reasons stated above, this camera does not include photosphere either.

Google made a lot of it Apps previously only bundled on phones available on the Play Store in the recent months. The Google Camera is among these, look here @Chris_R: see However it is marked as incompatible for the Fairphone and requires Android 4.4+. Notice: I have another device running 4.2.2 as well (Transformer Pad) and the Google Kamera is available for that device and installs fine.

Google Camera app isn’t supported on anything less than 4.4 as mentioned in the app description

Works on phones and tablets running Android 4.4+ KitKat and above

And also says this at the bottom

Requires Android
4.4 and up

Not sure how exactly you have got it running on 4.2.2, but I’m sure I remember reading somewhere that there is an intention at Google to make it backward compatible.

@Chris_R you are right. I found out was is causing my confusion. On the Photosphere Website by Google, it says 4.2 is required. My Tablet runs 4.2 and i was browsing the Play Store on my PC. Since i once had Omnirom (an unoffical Android port) 4.4 on my Tablet, the Play Store seems to mix things up and Google Camera is marked as “installed”. In fact it is not, i double checked on the tablet.

1 Like

so the Camera App of the Fairphone is not truly the Stock Camera App

Yup, this is what I concluded by now.

The pre-installed gallery/camera package on FP1 is (as far as I remember, I uninstalled it), and the AOSP gallery is
I installed the latter with Amaze File Manager and the package from (contains the gallery apk as well as some system libraries [which seem to be the main point why the AOSP KitKat Camera from F-Droid didn’t offer the PhotoSphere feature]), and now it works flawlessly.

It may get overwritten with any FPOS update, but I’m quite sure that I can install it again after every update.

Thanks for your input!


please help! I installed amaze file manager and downloaded the package that contains the gallery apk’s and system libraries. whenever i try to install the 2 apk’s now it tells me: "xApp not installed"
What can I do?

You don’t have to install the apps by tapping on them, but you have to copy them to the root>system/app folder with Amaze (you might activate root access in the settings first) and overwrite the existing GmsCore.apk, also you should remove the old gallery apk to avoid confusion. The .so files need to be copied to root>system/lib, also overwriting existing versions.

Vom Handy gesendet. Bitte entschuldigen Sie formale bzw. Rechtschreibfehler.

Oh, and you also need to edit all files’ permissions to rw-r-r (owner: read+write, group and others: only read). This is also possible with amaze.
You also might deactivate the photo sync in the Google account in your system settings, otherwise the new gallery will sync all picasa photos, Google profile photos and so on, which I personally find annoying.

Vom Handy gesendet. Bitte entschuldigen Sie formale bzw. Rechtschreibfehler.

This topic was automatically closed after 16 days. New replies are no longer allowed.