English

Phone won't charge until after reboot

My phone seems to have an odd problem where sometimes when the phone is plugged into a charger, it doesn’t charge, even though it gives every indication it is - light, icon etc. It discharges, sometimes faster than if it were idle or at the same rate.

After a reboot it charges fine.

Its not GPS - it wasn’t on. I don’t think its an app as looking at the graphs of battery life, there is not a huge rapid drain before the charge, the charge just doesn’t happen.

Have other people had this problem? What’s the fix?

Yup, I have this too every now and then. As you say, the phone seems to be charging, but isn’t. Reboot fixes it. I have taken the habit to ‘check up’ on the charging process after a couple of minutes / half hour in order to avoid unpleasant surprises. Don’t know of a fix for this.

  • But your normal power-up battery time is ok? (let’s say >24-48h of normal usage?)
  • you already checked for wake-locks with the App “BetterBatteryStats” during this strange “loading” process? (To check, if any not-sleeping app boost your CPU and cause heavy battery load)
  • did you try also at the PC, another charger or another cable after hit happend again?
  • is your FP becoming warm, if it behaves as you described?
  • did you perform the “spinning test” to check for a bloating battery?

Cheers, Robert

2 Likes

Yes, battery life is normal (± 24h, same as ever). Type of charger doesn’t matter. Has happened with different wall-socket chargers, PC USB port, etc. Will occur, then after reboot will charge fine with the same charger.

As ‘luck’ would have it, happened again this morning. Except this time reboot didn’t help. Had to do the ‘battery reset’ dance (take out battery, plug in, insert battery) before it would charge. Could only let it charge to 12% before I had to leave for work and had to unplug it. Phone booted, and showed 52% charge after boot…

the 12%–>52% is a known bug…unfortunately
Here you have to make again 52%–>0% switch off --> 0%–> at least 60% (while switched off).
If you then switch on the FP, the percentage should remain.

But does not help with your other problem, right?

Great that this topic is being discussed!

Recently my fairphone FP1U also started to have problems getting charged. This is especially annoying for me, as I already had a battery replacement because of the swollen battery and a phone replacement because of the problems with the proximity sensor like described again and again f.e. here Accidentally ending phone calls with my face.
I can only hope that all these problems are fixed in the extremly expensive FP2. Probably the “FP2” community is not as idealistic and expects a reliable phone.

Back to the battery issue. I tried several chargers, PC-USB, and several cables. But the issue seems to be caused be the charging electronics of my fairphone. It behaves as you describe, it looks like the phone is getting charged (moving charging symbol), but the percentage charged does not increase. Unplugging the phone from the cable then shows the real charging percentage (mostly less than when having it plugged in)
Neither the phone nor the charger gets warm when this behavior occurs.

Has anyone made a support request on this topic yet?

I have no solution but at least you know you are not alone.

Greetings, Jazzzman

Same here: various charging cables & power sources, but the same (erratic!) behavior. no correlation with big drainers (gps & friends) on or off.

so far, only a reboot will allow charging.

joost

Same here. My phone seems to be charging but its not. I mostly charge during the night so when i wake up in the morning i find it to be at 1-10% instead of 100…
I’ve tried different chargers because at first i used an old one but doesnt matter…
A bug in the system???

Ah, good to have confirmation that it is indeed a bug. Never noticed it before since when I do the “battery reset” dance, I normally do let it charge fully. So this was a first. The “not charging” is indeed not solved, but frankly it is little more than an annoyance to me.

I’ve had the same problem for a couple of weeks (that’s when I first noticed it). The only difference is that I don’t have to reboot the phone, just unplugging it and then plugging it in again usually works. And it doesn’t always happen… feels like someone (the RNG god?) throws a die when I plug it in, and if it is a ‘one’, then it doesn’t charge…

Best “solution” I’ve found so far is, as someone already said, to check the phone after 10-15 minutes, and if the battery level hasn’t increased, unplug and plug it in again.

Thanks for all the thoughts, and confirmation.

But OMG the effecting the call with my ear is a thing, its not just me? I thought I was clumsy!

SO, that, the battery non-charging, (plus the GPS being amazingly rubbish, having to reboot to get data sometimes?). I thought that’s just me being dim or having high expectations? But no - its not just me? Amaze-balls.

Gps is rubbish, i had to buy a car nav because of it.
My phone decided that it would only charge via pc, not by wall/AC. It has now been returned to fairphone and they will not be returning it (due to me being in australia).
One of the support staff labelled me as negligent due to me using these forums to try to overcome the gps issues and tried to use that as an excuse to not provide service for the charging issue.

Same problem here, but I think it started with my FP1 just after I did the last update (Koala 1.7.8) and unified my partition of the phone memory, in September. The phone arbirarily charges, and when it does not, only the battery dance does the job. It is my second battery after getting my bloated battery exchanged in winter 2014. Battery life is otherwise fine, just under 14% it goes down in around 5 mins.

Did you know that you can reset the battery’s software? This is taken from the FP1(U) community battery guide:

[quote=“Stefan,topic:5372,post:7”]At FP they told me that the battery has its own software inside, which sometimes needs to be reset.
Battery-Software Reset/Recalibration:

  1. Use the battery up until it is below 0% (until the phone dies).
  2. Take the battery out of the phone.
  3. Plug your charger into the phone (still without battery). [Wait a few minutes]
  4. Insert your battery. (This will give the battery a kick)
  5. Charge your phone in one go until 100%. Do not boot the phone during charging.
  6. If this doesn’t work for the first time, try it a second time, beginning from step 1[/quote]